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Введение 
 

FEMLAB – это интерактивная среда моделирования 
для расчёта большинства научных и инженерных задач на 
основе дифференциальных уравнений в частных произ-
водных, которые решаются методом конечных элементов. 
Эта среда позволяет соединить и оптимизировать функ-
циональные возможности для анализа различных механиз-
мов передачи тепла [1,2,3]. Этот пакет позволяет привлечь 
широкую аудиторию исследователей, разработчиков, пре-
подавателей и студентов для качественно нового матема-
тического моделирования процессов теплообмена.  

Процессы теплопередачи возникают во многих физи-
ческих явлениях поэтому изучение моделирования тепло-
обмена полезно и для изучения других дисциплин. Моде-
лирование эффектов теплопередачи имеет важное значе-
ние при проектировании изделий во многих областях, 
включая электронику, автомобильную и медицинскую от-
расли промышленности. Совмещение экспериментальной 
работы в лаборатории с теоретическими исследованиями 
на компьютерных моделях позволяет более полно и эф-
фективно проводить научную работу и уменьшает затраты 
времени для разработки новых процессов. В прошлом 
сложные инструменты моделирования могли себе позво-
лить только большие компании, в которых затраты на про-
граммное обеспечение и специализированных инженеров 
были оправданы при больших объёмах производства. Се-
годня моделирование на компьютере стало обязательным 
элементом исследования и развития процесса. 

FEMLAB – ценный инструмент при моделировании 
передачи тепла в различных теплотехнологических уста-
новках. 
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1. Основы теплопередачи 
В этой главе представлен обзор теории и уравнения, ко-

торые используются при моделировании теплопередачи, а 
также передачи тепла излучением между поверхностями. 

Теплопередача определяется как движение энергии на 
основе температурного перепада. Для этого используются три 
механизма: 

• Теплопроводность – осуществляется на основе раз-
личных механизмов в зависимости от теплоносителя. Теоре-
тически её можно объяснить: для газа – через столкновение 
молекул в результате колебания каждой молекулы в ячейке, 
сформированной из самых близких соседей в газе, для твёр-
дого вещества – через распространение упругих волн колеб-
лющихся атомов и молекул, для металлов – через перемеще-
ние свободных электронов и колебания атомов решётки. Ти-
пичным для теплопроводности является то, что поток теплоты 
пропорционален температурному градиенту. 

• Конвекция теплоты – имеет место в движущихся сре-
дах (газе, жидкости) на основе переноса теплосодержания 
жидкости за счёт её собственного движения. Термин конвек-
ция используется также для описания теплового потока меж-
ду твердой поверхностью и жидкостью, где коэффициент те-
плоотдачи используется для описания теплового потока ме-
жду твердой поверхностью и жидкостью с разными темпера-
турами на вымышленной пленке, расположенной между ни-
ми. Оба описания включены в модуль передачи тепла. 

• Радиация. Передача тепла радиацией имеет место при 
транспортировке фотонов. Эти фотоны могут поглощаться 
или отражаться твердыми поверхностями. Модуль передачи 
тепла включает радиацию от поверхности к  поверхности, ко-
торая объясняет эффекты затенения и отражения между ис-
ходными поверхностями. Он также включает радиацию от 
поверхности к окружающему пространству, где радиация 
может быть установлена или дана произвольной функцией. 
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В пакете FEMLAB обозначения физических величин не-
сколько отличаются от общепринятых (табл.1.1) 
Таблица 1.1.          Соответствие обозначений величин в формулах                     

пакета FEMLAB c общепринятыми [4] 

Обозначение 

Еди-
ницы 
изме-
рения 

FEM
LAB 

Обще-
приня-

тые 
обо-

значе-
ния 

Удельная теплоёмкость 
Время 
Коэффициент теплопроводности 
Удельный источник или потребитель 
теплоты 
Вектор потока теплоты 
Нормальный вектор потока теплоты 
Коэффициент теплоотдачи 
Температура на поверхности тепло-
обмена 
Коэффициент теплового излучения 
облучаемого тела 
Коэффициент отражения 
Коэффициент поглощения 
Падающий тепловой поток 
Эффективный тепловой поток 
Температура окружающей среды, 
видимая поверхностью участвующей 
в теплообмене 

Дж/(кг٠К) 
с 

Вт/(м٠К) 
Вт/м3 

 
Вт/м2 

 

– 
Вт/(м2٠К) 

K 
 
– 
– 
– 

Вт/м2 

Вт/м2 

K 

C 
t 
k 
Q 
 
q 
 
n 
h 

Tinf 
 
ε 
ρ 
α 
G 
J 

Tamb 
 

c 
τ 
λ 
q 
 

q  
 
0n  

α 
T(1,τ) 

 
ε 
R 
А 

Епад 

Еэф 

Токр 

Модуль передачи теплоты поддерживает все три механизма. 
Уравнение передачи тепла 

Математическая модель передачи тепла теплопровод-
ностью – уравнение теплоты: 

  QTk
t
TC 



 ,                    (1.1) 
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где   – плотность, кг/м3; C  – удельная теплоёмкость, 
Дж/(кг·К) ( pC – удельная теплоёмкость при постоянном 
давлении, vC – удельная теплоёмкость при постоянном 
объёме); T – температура, К; t – время, с; k  – коэффици-
ент теплопроводности, Вт/(м ·К); Q  – удельный источ-
ник или потребитель теплоты, Вт/м3. 

Для установившегося режима температура в каждой 
точке не изменяется со временем и первый член уравнения 
исчезает. Коэффициент теплопроводности  становится те-
пловым тензором k . 

Если теплопроводность анизотропна, 



















zzzyzx

yzyyyx

xzxyxx

kkk
kkk
kkk

k  .                     (1.2) 

Чтобы моделировать теплопроводность и конвекцию в 
жидкости, уравнение теплоты также включает конвектив-
ный член. FEMLAB представляет эту формулировку в ре-
жиме приложения General Heat Transfer как 

  QuTCTk
t
TC pp 



  ,                 (1.3) 

где u  является скоростным полем. Это поле может задаваться 
или обеспечиваться как выражение независимых переменных. 
Может использоваться расчетная связь с импульсом в при-
кладных режимах для несжимаемого (Навье-Стокса) или не 
изотермичного потока. 

Вектор теплового потока определен выражением в преде-
лах круглых скобок в (1.3). При передаче теплоты теплопро-
водностью и конвекцией уравнение запишется в виде 

uTCTkq p   ,                           (1.4) 
где q  – вектор потока теплоты. Если передача тепла осуще-
ствляется  только теплопроводностью, то   
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Tkq  .                                  (1.5) 
Теплоёмкость – количество теплоты, которое необхо-

димо изменить в единице массы вещества при перепаде тем-
ператур в один градус, или энергия единицы массы при из-
менении температуры в один градус, или внутренняя тепло-
та или внутренняя теплоёмкость. 

Граничные условия 
При моделировании используются два различных типа 

граничных условий: типа Дирихле (граничные условия пер-
вого рода) и типа Неймана (граничные условия второго рода). 
Условие границы типа Дирихле используется, чтобы устано-
вить температуру на  границе 

0TT  .                                   (1.6) 
Условие типа Неймана используется, чтобы установить 

поток теплоты на границе 
0qqn  ,                                  (1.7) 

где q  – вектор потока теплоты; n  – нормальный вектор гра-
ницы; 0q  – внутренний поток теплоты, нормаль к границе. 

Тепловое условие адиабаты получается при установке  
0q = 0. Это имеет место для границ симметрии. 

Модуль передачи теплоты использует более общую 
формулировку уравнения (граничные условия третьего рода) 
(1.7): 

 TThqqn  inf0 .                       (1.8) 
Эта формулировка позволяет явно определять поток тепло-

ты через 0q  и коэффициент теплоотдачи h  относительно 
искомой температуры infT . 

Для учёта радиационной составляющей в передаче тепла 
с правой стороны уравнения (1.8) добавляются дополнитель-
ные условия, чтобы учесть поток теплоты излучением.  
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Радиационная передача тепла 
Третий механизм для передачи теплоты – радиация. Теп-

ловая радиация означает поток электромагнитных волн, ис-
пускаемых телом, которое имеет некоторую температуру.  

Получение потока теплоты излучением 
Тепловое излучение свойственно всем телам, и каждое 

из них излучает энергию в окружающее пространство. При 
попадании на другие тела эта энергия частично поглощается, 
частично отражается и частично проходит сквозь тело. 

Рассмотрим точку x, которая расположена на непрозрач-
ной поверхности с коэффициентом теплового излучения облу-
чаемого тела  , с коэффициентом отражения  , с коэффици-
ентом поглощения   и температурой T (рис. 1.1). 

Тело непрозрачно. Это означает, что никакая энергия 
излучением через тело не передаётся, что является истиной 
для большинства тел.  

Полный излучающий поток теплоты, который достигает 
элементарной поверхности x, называют падающим тепло-
вым потоком G  (рис. 1.1, а). 

 
а)                                          б) 

Рис. 1.1.  Поступление тепловой энергии (а), отвод тепло-
вой энергии (б) 

Полный излучающий поток теплоты, который x отдаёт, 
называют эффективным потоком J (рис. 1.1,б). Эффективный 
поток – сумма отраженной радиации и собственной испус-
каемой радиации: 
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4TGJ   .                                 (1.9) 
Поглощённый телом поток теплоты 

JGq  .                                        (1.10) 
Подставляя (1.9) в (1.10), получаем следующее выраже-

ние для поглощённого телом потока излучения: 
  41 TGq   .                              (1.11) 

Помимо предположения, что поверхность является не-
прозрачной, также предполагаем, что поверхность является 
серой. Для серых поверхностей можем принять следующее: 
для коэффициента отражения   и коэффициента теплового 
излучения облучаемого тела   

 1  .                                          (1.12) 
Подставляем (1.12) в (1.11), убираем коэффициент от-

ражения  в уравнении (1.11) и выражаем поглощённый  
внутрь тела поток излучения q : 

 4TGq   .                                    (1.13) 
Это выражение обозначает поглощённый поток теплоты, 

поступающий на поверхность. 
В модуле передачи теплоты делаются отличия между 

двумя различными типами радиационной передачи теплоты: 
радиация от поверхности к окружающему пространству и 
радиация от поверхности к поверхности. Уравнение (1.13) 
подходит для обоих типов излучения. Однако падающий те-
пловой поток G является различным для радиации от по-
верхности к поверхности и радиации от поверхности к ок-
ружающему пространству.  
Радиация от поверхности к окружающему пространству 

Для радиации от поверхности к окружающему про-
странству принимаются следующие допущения: 

1. Окружающая среда, видимая поверхностью, имеет по-
стоянную температуру ambT . 
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2. Окружающая среда имеет свойства черного тела, то 
есть излучаемая и поглощаемая способности тела равны 1, а 
коэффициент отражения – нулю. 

Эти предположения позволяют выразить падающий теп-
ловой поток на поверхность как 

4
ambTG  .                                     (1.14) 

Вставив (1.14) в уравнение (1.13), получим для погло-
щённого излучающего потока теплоты от поверхности к 
окружающему пространству следующее уравнение: 

 44 TTq amb   .                                (1.15) 
Этот поток прибавляется в правую часть уравнения 

(1.8) для учёта граничных условий радиации от поверхно-
сти к окружающему пространству. 

Радиация от поверхности к поверхности 
Для случая радиации от  поверхности к поверхности си-

туация более сложная. В общем случае излучение в данной 
точке на поверхности определено геометрией и местными 
температурами окружающих границ и температурой окру-
жающей среды. Получим выражение излучения для общего 
трехмерного случая. 

Рассмотрим точку x на поверхности (рис. 1.2). Точка x  
«видит» другие точки на других поверхностях и также окру-
жающую среду. 

Принятые точки на других поверхностях имеют свой 
эффективный тепловой поток J ', в то время как окружающая 
среда имеет постоянную температуру ambT . 

Радиация в точке x  – сумма потоков теплоты от всех 
точек на поверхности S   (для точек типа x  ) и потока теп-
лоты от окружающей среды, который проходит через поверх-
ность ambS . 

Поток теплоты, который достигает точки x  от точки 
x  , зависит от эффективного теплового потока J', проекти-
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руемого на точку x . Проектирование вычисляется с исполь-
зованием нормальных векторов n и n' и вектора r. Поток теп-
лоты, который приходит от окружающей среды, зависит от 

ambT  и поверхности ambS , то есть от поверхности, не входя-
щей в поверхность S  . 

 

 
Рис. 1.2. Пример геометрии для радиации от поверхности  

к поверхности 
 
Суммарный тепловой поток излучением вычисляется 

интегрированием потоков теплоты от всех точек на поверхно-
сти S   и добавлением вклада потока теплоты от окружающей 
среды. Окончательное выражение для излучения в точке x  

    4
4 amb

S
amb TFdSJ

r
rnrnG 

 





,              (1.16) 
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где S' – поверхность твёрдого тела, по которой взят интеграл; 
ambF  – доля поверхности по вкладу излучения из окружаю-

щей среды. 
Чтобы найти выражение для поверхности ambF , сначала 

определим долю для поверхности S  , которая оказывает влия-
ние на излучение, обозначим её через F  . Долю поверхности 
излучения F   можно получить из интеграла 

   






S

dS
r

rnrnF 4
.                               (1.17) 

Используем то, что сумма долей равна 1: 
1 FFamb .                                         (1.18)      

Используя (1.17) и (1.18), получим следующее выраже-
ние для площади ambF : 

   






S
amb dS

r
rnrnF 41


.                          (1.19) 

Это уравнение для общего трехмерного случая. 
Поверхностные интегралы используются для уравнения 

трехмерного случая и поэтому могут быть упрощены в инте-
гралы для двухмерного случая. Конечные выражения с излу-
чением в точке x  и добавлением вклада потока теплоты от 
окружающей среды для двухмерного случая  

    4
32

amb
S

amb TFdSJ
r

rnrnG 
 






  ;              (1.20) 

   







 


S
amb dS

r
rnrnF 32

1  ,                             (1.21) 

где интеграл по поверхности S используется, чтобы обозна-
чить интеграл строки по границам двухмерной геометрии. 
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Определение эффективного теплового потока 
В предыдущем разделе получили выражение для па-

дающего теплового потока G  на произвольную поверхност-
ную точку x . Выражение для эффективного теплового пото-
ка от точки x  представлено в (1.9) 

В уравнении (1.9) раскроем коэффициент отражения, ис-
пользуя уравнение (1.12): 

4)1( TGJ    .                                      (1.22) 
После подстановки в выражение G из (1.16) получим 

формулу для определения эффективного теплового потока 

    44
4)1( TTFdSJ

r
rnrnJ amb

S
amb 














 






 .(1.23) 

Это заключительное уравнение, которое используется для 
вычисления эффективного теплового потока для точки 
x на поверхности в трёхмерной системе координат. 

На границах, которые участвуют в передаче теплоты ра-
диацией от поверхности к поверхности, FEMLAB использует 
зависимую переменную J, чтобы моделировать излучение. 

В FEMLAB уравнение (1.23) приводится к системе 
линейных уравнений для теплового потока J , которая ре-
шается параллельно с системой уравнений для температуры 
T. Решив для потока J систему уравнений, определяется 
поток теплоты (1.13). 

2. Краткий обзор режимов 
Модуль передачи тепла FEMLAB состоит из множест-

ва прикладных режимов, которые описывают температурное 
поле неизотермической системы. Эти прикладные режимы 
используются для решения задач с передачей тепла тепло-
проводностью, конвекцией и радиацией. 

В дополнение к прикладным режимам, которые опи-
сывают температурные поля, этот модуль включает также 
прикладные задачи для динамики жидкости, при решении ко-
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торых моделируется скоростное поле неизотермической жид-
кости. Этот прикладной режим используется при решении 
задач с конвективным тепломассообменом (табл. 2.1) в паке-
те FEMLAB. 

Таблица 2.1.      Краткий обзор типовых режимов, решения задач 
теплообмена        в пакете FEMLAB 

 
 

 
Прикладной режим 

Н
аз

ва
ни

е 

1D
 

2D
 

3D
 

Ст
ац

ио
на

рн
ый

 
Н

ес
та

ци
он

ар
ны

й 

Общая передача тепла, декартовые 
координаты htgh + + + + + 

Общая передача тепла, полярные 
координаты htgh + +  + + 

Биообогрев, декартовые координаты htbh  + + + + 

Биообогрев, полярные координаты htbh  +  + + 

Тонкая теплопроводная оболочка htsh   + + + 
Неизотермический поток, декарто-

вые координаты ns  + + + + 

Неизотермический поток, полярные 
координаты ns  +  + + 

В следующих разделах будут представлены приклад-
ные задачи передачи тепла в модуле передачи тепла 
FEMLAB.  

3. Запуск и работа с программой 
Для создания и расчета задачи рекомендуется сле-

дующая последовательность действий [5]. 
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1. Выбрать размерность модели, определить физиче-
ский раздел в Model Navigator (Навигаторе моделей) 
(каждому разделу соответствует определенное дифферен-
циальное уравнение) и определить стационарный или не-
стационарный анализ температурного поля. 

2. Определить рабочую область и задать геометрию. 
3. Задать исходные данные, зависимости переменных 

от координат и времени. 
4. Указать теплофизические свойства и начальные ус-

ловия. 
5. Указать граничные условия. 
6. Задать параметры сетки и выполнить её построение. 
7. Определить параметры решающего устройства и 

произвести  расчет. 
8. Настроить режим отображения. 
9. Получить анализ результатов. 

3.1. Навигатор моделей и главное меню 
При выборе размерности модели необходимо знать, 

что задание сетки для трехмерной модели может значи-
тельно увеличить время решения задачи. Поэтому для 
большинства трехмерных задач имеет смысл сначала по-
пробовать решить двумерную задачу, а уже затем при не-
обходимости повторить расчет для трехмерной задачи. 

Размерность модели выбирается в окне Model 
Navigator (Навигатор моделей) на первой вкладке New в 
Space Dimension (Размерность пространства); кроме 1D, 
2D и 3D, также есть Axial Symmetry (1D) и (2D) для 
осесимметричных моделей (рис. 3.1). 

Затем выбираем физический раздел (в рамках данного 
пособия рассмотрен раздел Heat Transfer (Теплопере-
нос)) и в составе мультифизической модели – раздел Fluid 
Dynamics (Гидродинамика). Раздел Fluid Dynamics ис-
пользует уравнение Навье-Стокса для несжимаемой жид-
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кости. Раздел Heat Transfer включает в себя кроме под-
раздела Conduction (Кондукция) подраздел Convection 
and Conduction (Конвекция и кондукция), который от-
личается тем, что кроме теплофизических свойств можно 
задать поле скоростей теплоносителя. Один из модулей 
расширения General      Heat     Transfer       (Общий      
теплоперенос) включает в себя объединенные модули с 
излучением, конвекцией и кондукцией, а также разделы 
Thin Conductive Layer  (Тонкий теплопроводный слой), 
Bioheat equation (Режим расчета тепломассопереноса в 
живых тканях),  Non-Isotermal Flow (Неизотермический 
поток). 

 
Рис. 3.1. Окно “Навигатор моделей” 

Для создания мультифизических моделей требуется, 
например, охлаждение конвективным потоком в канале: 
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необходимо нажать кнопку Multiphisics, затем кнопку Add 
geometry (Добавить геометрию), в открывшемся окне 
выбрать размерность и названия осей. Затем опять нажи-
мается кнопка Add… (Добавить) и сначала выбирается 
физический раздел (Heat Transfer → Convection and 
Conduction), а потом в модель добавляется второй раздел 
(Fluid Dynamics → Incompressible Navier-Stokes). Между 
собой они взаимодействуют через поле скоростей. 

Также на вкладке New в Model Navigator можно вы-
брать вид конечных элементов, по умолчанию предлага-
ются Лагранжевы элементы Lagrange-Quadratic (Ла-
гранжевы-квадратичные), которые можно выбрать 
вплоть до пятой степени, в некоторых разделах доступны 
элементы  Эрмита, Эйлера и множество других приклад-
ных элементов.  

Кроме New в Model Navigator есть еще три вкладки. 
 Model Library (Библиотека моделей) – в ней рас-

положены примеры моделей для всех физических разде-
лов. 

 User Models (Пользовательские модели) – пред-
ставляет собой отображение папки, в которой хранятся 
модели, созданные пользователем. 

 Settings (Настройки) – позволяет установить язык 
(при установленном русификаторе даже русский), и изме-
нить фон рабочей области с белого на чёрный. В версии 
COMSOL 3.2 там же устанавливается система единиц, 
включая СИ. 

В версии FEMLAB 3.2 появилась вкладка Open, кото-
рая, так же как и User Models, позволяет работать с фай-
лами.  

После нажатия клавиши OK в Model Navigator откры-
вается окно основной программы с рабочей областью, ин-
струментальными панелями и главным меню. Кнопки на 
инструментальных панелях повторяют пункты главного 
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меню, поэтому далее рассматриваются пункты меню по 
порядку.  

Главное меню 
File – содержит команды создания, открытия и сохра-

нения файлов, печати, а также импорта геометрии из 
внешних CAD систем и экспорта полученных данных в 
текстовый файл. 

Edit – содержит команды отмены и повторения опера-
ций, работы с буфером обмена и команды выделения. 

Options – содержит команды задания рабочей области 
Axes/Grid settings, констант Constants, выражений 
Expression, функций Function, связанных переменных 
Coupling Variables и различные настройки отображения 
геометрических элементов и масштаба. 

Draw – содержит команды построения и преобразова-
ния геометрических объектов, а также команды превраще-
ния двумерных объектов в трехмерные. 

Physics – содержит команды задания физических 
свойств подобластей Subdomain, граничных условий 
Boundary, в том числе периодических Periodic Condition, и 
изменения системы дифференциальных уравнений 
Equation system. 

Mesh – содержит команды управления конечноэле-
ментной сеткой. 

Solve – содержит очень важные команды управления 
решающим устройством, можно выбрать зависимость от 
времени, линейность или нелинейность, а также указать 
множество других параметров решателя. 

Postprocessing – содержит команды для отображения 
результатов вычислений во всех возможных видах: от век-
торов и поверхностей уровня до графиков и интегралов по 
границе. 
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Multiphisics – открывает Model Navigator и позволяет 
переключаться между физическими режимами в мульти-
физических моделях. 

Help – содержит обширную справочную систему. 
3.2. Рабочая область и задание геометрии 

Окно основной программы представлено на рис. 3.2. 
Если выбрать размерность пространства 1D, то можно 
увидеть рабочую область с координатной осью и кнопками 
для рисования геометрии. В одномерном режиме – это 
кнопки Point (Точка), Line (Линия), Mirror (Отображе-
ние объекта зеркально), Move (Перемещение объекта) и 
Scale (Изменение  размера  объекта).  В  верхней  части  
экрана  

 
Рис. 3.2. Рабочая область 
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есть стандартные кнопки для выполнения операций с фай-
лом и буфером обмена и кнопки, повторяющие основные 
команды из разделов Mesh, Solve и Postprocessing главно-
го меню. 

В режиме 2D добавляются кнопки создания кривых Бе-
зье, прямоугольников и овалов, кнопка Array (Массив), 
создающая из одного объекта матрицу    объектов  любого 
размера. Кнопка Rotate (Вращение) позволяет повернуть 
созданный объект на любой угол. В трехмерном режиме с 
помощью кнопок можно создавать параллелепипеды, эл-
липсоиды, конусы, цилиндры и шары, а также управлять 
расположением координатных осей и освещением фигуры.   

В первую очередь, рекомендуется задать границы ото-
бражаемой рабочей области Options > Axes/Grid settings 
(Опции > Установки оси/решетки) (рис. 3.3). Предполо-
жим, что мы работаем в двумерном режиме и хотим задать 
модель объекта с размерами метр на метр. В открывшемся 
окне выбираем вкладку Axis (Оси), галочка Axis equal оз-
начает, что оси будут равны, то есть один метр по оси Х 
будет визуально такого же размера, как по оси Y. Для про-
тяженных объектов эту галочку  можно   снять,   и тогда на 
экране оси могут быть не равны. Это удобно, когда в ка-
ком-нибудь из измерений объект непропорционально 
большой. 

В разделе x-y limits нужно задать пределы отображения 
осей, в нашем случае – это 0 и 1.1 для минимума и макси-
мума соответствующих осей. На вкладке Grid (Решетка)  
(рис. 3.4) можно снять галочку Auto и самим установить 
интервал решетки. Вообще, при построении модели можно 
задавать просто координаты соответствующих фигур (на-
пример, координаты центра окружности и ее радиус), но 
часто удобнее задать фигуру, просто отметив эти коорди-
наты с помощью мыши, и тогда очень важно, чтобы узлы 
решетки совпадали с ключевыми точками фигуры. Поэто-
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му, если толщина минимального элемента составляет, ска-
жем, один миллиметр, то целесообразно  задать именно 
такой интервал сетки. 

Галочка Visible (рис. 3.4) позволяет выключить  режим 
отображения решетки. Внизу рабочей области можно вы-
ключить и привязку мыши к решетке SNAP, но тогда в 
случае ввода объекта с помощью мыши ключевые точки 
можно будет задать лишь примерно. В области x-y grid 
можно задать в полях x и y spacing интервал решетки по 
соответствующим осям. Поля Extra x и Extra y позволяют 
добавить любое количество дополнительных линий решет-
ки. 

  
Рис. 3.3. Окно «Задание осей на отображаемой области» 

Не стоит путать понятия Grid (Решетка) и Mesh          
(Сетка конечных элементов). Grid служит только для 
удобства задания геометрии модели и никак не влияет на 
расчеты. От сетки же конечных элементов Mesh напрямую 
зависит точность расчетов. 
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Рис. 3.4.  Окно «Задание интервала решётки в отображаемой 

области» 

После задания решетки можно приступить к опреде-
лению геометрии. Если она у нас заранее не создана во 
внешней CAD - программе или не задана в MATLAB (в 
этих случаях она просто импортируется через команды 
File > Import), то придется ее задавать внутренними сред-
ствами. Предположим, надо нарисовать прямоугольник. 
Можно воспользоваться соответствующими кнопками 
Rectangle/Square (Прямоугольник/квадрат) и 
Rectangle/Square (Centered) (Прямоугольник/квадрат 
(Центрированный)). Первым щелчком отмечается 
расположение угла или центра, а потом прямоугольник 
растягивается до нужного размера и закрепляется вторым 
щелчком. При нажатой клавише Ctrl создается квадрат. 
Если нажать на клавишу Shift и щелкнуть на кнопке, то 
откроется окно со всеми параметрами фигуры (рис. 3.5). 
Это же окно можно открыть через главное меню, 
используя команды Draw > Specify objects.  
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Область окна Size задает размер объекта с помощью 
полей Width (Ширина) и Height (Высота). Область окна 
Rotation angle (Угол поворота) задаёт угол поворота пря-
моугольника в градусах.  

Область Position (Место) определяет расположение 
объекта. Раскрывающийся список Base позволяет задать 
место начала координат x и y. Область Corner означает, 
что начало координат находится в районе угла прямо-
угольника (если используется фигура эллипс, то начало ко-
ординат находится в угле описанного прямоугольника). 
Область Center означает, что координаты будут находить-
ся в центре объекта.  

Раскрывающийся список Style предлагает варианты 
Solid ( для создания целой фигуры) и Curve (для создания 
кривого     контура   фигуры).   Кривая    необходима     для 

 
Рис. 3.5 Окно с параметрами фигуры. 

создания сложной фигуры. Сначала задаются кривые гра-
ницы объекта, а потом командой Coerce to solid выделен-
ные кривые делаются цельной фигурой. В режиме 3D вме-
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сто Curve (Кривая) есть понятие Face (Оболочка). В поле 
Name можно вписать имя объекта.  

Несмотря на то, что в окнах Specify objects можно за-
дать точные координаты и размеры объектов, часто легче 
задавать их с помощью мыши, а кривые Безье – только с 
помощью мыши. Вот почему важно заранее определить 
период решетки.  
      При задании сложных фигур приходится задавать де-
сятки элементарных объектов (овалы, прямоугольники, 
кривые Безье, линии, точки), потом их надо объединить 
или разделить. Обычно это делается по физическим при-
знакам с помощью кнопок Union (Объединить), 
Difference (Разность), и Intersection (Пересечение) или 
команды Draw > Create Composite Object… Эта команда 
открывает окно, где можно указать, из каких элементов 
создается фигура.  
       После создания фигуры с помощью кнопки 
Fillet/Chamfer или одноименного пункта меню Draw 
можно задать фаски или округления углов. Также можно 
размножить фигуру с помощью кнопки Array, зеркально 
отразить с помощью Mirror  и изменить размер с 
помощью Scale. Кнопки Rotate и Move поворачивают и 
сдвигают выделенную фигуру. Все эти кнопки 
повторяются в виде пунктов меню Draw > Modify. 

Для создания трехмерных моделей удобно элементар-
ные фигуры задавать в режиме 3D, а более сложные задать 
сначала в режиме 2D, а потом перенести в трехмерную об-
ласть. Например, мы создали прямоугольник 1 x 0,5 м.  

Если его выделить и нажать кнопку Draw> Extrude, 
то откроется окно Extrude (Экструзия) (рис. 3.6), где 
можно задать объект, подвергающийся операции экстру-
зии, назвать рабочую область (для одной модели можно 
задать несколько рабочих областей, обычно это несколько 
2D геометрий и одна составная 3D). В поле Distance опре-
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деляется, насколько можно растянуть сечение. Если был 
нарисован круг, то после экструзии появится цилиндр, ес-
ли было сечение рельсы, то появится модель рельсы. В по-
лях Scale x- и y- параметры определяют, во сколько раз бу-
дет изменяться сечение по длине объекта. Если в эти поля 
задать две двойки, то после экструзии (если сечение было 
круглым) появится усеченный конус. Поле Displacement 
определяет сдвиг верхней плоскости фигуры относительно 
основания. Поле Twist «закручивает» фигуру вокруг своей 
оси.  

Команды Draw > Embed позволят скопировать дву-
мерный прямоугольник в трехмерную рабочую область      
(по умолчанию в плоскость z=0). Плоскость задается через 
команды Draw > work plane settings… 

Последовательность действий Draw > Revolve создаёт 
фигуру вращения, то есть из прямоугольника можно соз-
дать  кольцо с  прямоугольным  сечением. В открывшемся 

Рис. 3.6. Окно создания 3D моделей на основе 2D 
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окне можно задать градусы вращения по двум осям и ко-
ординаты точек, вокруг которых будет создаваться фигура 
вращения.  

Для наглядности можно установить Scene Light (Ос-

вещение объекта), кнопка Zoom extents увеличит фи-
гуру до размеров на весь экран. 

Если в процессе дальнейшей работы с моделью пона-
добится изменить какой-либо элемент геометрии, вернуть-
ся в режим ввода геометрии, то это можно сделать с по-
мощью команды Draw > Draw Mode или кнопки Draw 

Mode . 

3.3. Функции, константы и выражения 
Теплофизические параметры могут зависеть от темпе-

ратуры и координат, внешние воздействия могут описы-
ваться различными функциями, зависящими от времени и 
множества других параметров. В расчетных уравнениях 
могут присутствовать различные константы, причём их 
значения могут отличаться для разных частей геометрии 
(например, коэффициент теплоотдачи или коэффициент 
черноты поверхности).  

В пакете FEMLAB существует инструментарий для ра-
боты с константами и функциями. Большинство этих ко-
манд находится в меню Options.  

Constants (Константы) рекомендует все применяемые 
в системе константы вынести в таблицу, а во всех форму-
лах задавать только буквенное обозначение. Например, за-
дать температуру окружающего воздуха Т_air=30, а во 
всех граничных условиях вместо цифры задавать Т_air. 
Тогда в случае необходимости можно будет поменять одну 
цифру, а не менять по всем граничным условиям темпера-
туру окружающего воздуха. Список всех часто употреб-
ляемых констант можно сохранить в отдельный файл и пе-
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реносить из модели в модель. В последних версиях про-
граммы появилась возможность написать к каждой кон-
станте Description (Примечание), при работе нескольких 
человек с одной моделью не стоит игнорировать эту графу. 

Expression (Выражения) содержит Scalar expression 
(Скалярные выражения), Subdomain, Boundary, Edge 
(только в трехмерном режиме) и Point expression. Можно 
задать зависимость теплофизического параметра от време-
ни t, координат x, y, z, безразмерной координаты s (изме-
няется от 0 до 1 по длине каждой границы) или от любых 
других вычисляемых параметров, например 
Q_ist=100*exp(t). У различных элементов системы очень 
часто одни и те же параметры определяются по разным за-
конам. Есть возможность задать одно имя у переменной, 
например alfa, и, открыв Boundary expression (Гранич-
ные выражения), задать для разных границ различные 
формулы вычисления alfa. Тогда для всех границ можно 
будет задать коэффициент теплообмена alfa, а программа 
сама подставит для каждой границы соответствующую 
формулу. 

Coupling Variables (Переменные связи). С помощью 
этой опции меню можно задавать очень сложные зависи-
мости между частями системы. Например, связать гранич-
ные условия с интегралом по объему. 

Functions (Функция) может задать свою функцию, 
причем используя не только математические выражения. 
Если выбрать Interpolation function, то можно задать мас-
сив параметров и массив значений функций и по ним по-
строить интерполяционную функцию. Можно задать метод 
интерполяции, есть возможность импортировать данные из 
внешнего файла. 

С помощью Coordinate systems (Системы координат) 
можно создать произвольную систему координат с любым 
расположением осей относительно друг друга.  
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В Material/Coefficients Library (Библиотека мате-
риалов) есть возможность задать любые физические свой-
ства веществ и даже их зависимость от параметров (темпе-
ратуры и давления). 

Visualization/Selection settings (Установки визуали-
зации) позволяют управлять отображением объектов, ос-
вещением и выделением. 

Suppress (Скрытие). В сложных объектах для нагляд-
ности иногда нужно сделать невидимым какой-либо эле-
мент системы. Например, если рассматривается процесс 
конвективного охлаждения, то удобнее для наглядности 
сделать воздух невидимым, а видимой только охлаждае-
мую поверхность с распределением температуры.  

3.4. Задание теплофизических свойств материалов и 
начальных условий 

Когда геометрия задана и все константы определены, 
можно приступить к заданию теплофизических свойств. 
Для начала открывается меню Physics > Subdomain 
Settings или кнопкой F8 окно ввода коэффициентов 
соответствующих дифференциальных уравнений (рис. 3.6). 
Для физического режима это окно имеет свой вид. Далее 
рассматриваются поля, только общие для всех режимов. 
На рис. 3.7 показано окно для режима Heat Transfer by 
Conduction в трехмерном режиме. Наверху окна в поле 
Equation указано текущее уравнение. В поле Subdomain 
selection необходимо выбрать область, для которой 
определяются физические свойства. Если областей много, 
то необходимо выделить все области, имеющие 
одинаковый материал. Чтобы выделить все области, надо 
нажать сочетание клавиш Ctrl+A. 

Во вкладке Physics необходимо задать свойства мате-
риала, в данном случае теплофизические. Для распростра-
ненных материалов можно воспользоваться встроенной 
библиотекой. В нестационарном режиме присутствует по-
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ле Time-scaling coefficient (Временной коэффициент). 
Значение 1 соответствует заданию времени в секундах. Ес-
ли рассматриваются процессы, протекающие значительно 
дольше или меньше, чем одна секунда, то удобнее задать 
другой коэффициент и указать внешние воздействия в со-
ответствующих единицах. Для того чтобы работать со 
временем в минутах, в это поле надо записать 1/60, если в 
часах, то 1/3600 и т.д. 

 
Рис. 3.7 Окно Subdomain Settings 

Кроме этого, можно задать дополнительные параметры 
объекта. В режиме теплопереноса – это объемная мощ-
ность. В режимах с использованием уравнения Навье-
Стокса и конвекции – это скорость потока по всем осям.  В 
каждое из полей можно вводить математические выраже-
ния, синтаксис такой же, как у MATLAB, но удобнее вво-
дить в поля не формулы, а названия переменных и опреде-
лять их через Options > Expression.   

В режимах, связанных с конвекцией, диффузией или 
потоком жидкости, во вкладке появляется кнопка Artificial 
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Diffusion… (Искусственная диффузия), которая позволя-
ет стабилизировать решение. Метод конечных элементов 
подразумевает дискретизацию пространства. При модели-
ровании явлений переноса в сложных объектах это может 
привести к нестабильности решения. Нестабильность 
можно обнаружить по большим колебаниям значений в 
областях с большими градиентами. Из-за больших колеба-
ний решение может не сходиться. С нажатием кнопки 
Solve > Restart (Решать > заново) новое решение будет 
отличаться от предыдущего. Методы стабилизации реше-
ния основаны на добавлении малых слагаемых в диффе-
ренциальные уравнения.  

Вкладка Init предназначена для задания начальных ус-
ловий, в данном случае это температура. Вкладка Element 
позволяет выбрать вид конечных элементов и их коэффи-
циенты.  

В последней версии программы FEMLAB 3.2 появи-
лись вкладки Groups и Color. Вкладка Group позволяет 
распределить различные элементы по группам и менять 
свойства сразу у всей группы. По умолчанию они раскра-
шиваются в разные цвета, изменить этот режим можно с 
помощью вкладки Color.  

3.5.  Задание граничных условий и изменение  
дифференциальных уравнений 

Задание физических свойств в областях граничных ус-
ловий (ГУ) и условий на ребрах или точках происходит 
автоматически при открытии окон ввода свойств этих эле-
ментов. Вручную режимы включаются кнопками Point 
Mode, Edge Mode, Boundary Mode и Subdomain Mode 

 или командами из раздела меню 
Physics>Selection Mode>… 

Граничные условия задаются в окне, которое открыва-
ется комбинацией клавиш Physics > Boundary Settings или 
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F7. В этом окне    (рис. 3.8) надо      выбрать   необходимые 
границы в поле Boundary selection. Для того чтобы задать 
температурный перепад на границе двух тел, надо сначала 
включить галочку Interior boundaries, иначе внутренние 
границы будут  недоступны.  Во вкладке  Coefficients  надо  

 
Рис. 3.8. Окно Boundary Settings 

выбрать вид граничных условий и указать в соответст-
вующих полях коэффициенты ГУ. На рис. 3.8 показан 
пример задания граничного условия третьего рода. В поле 
Equation выводится соответствующее уравнение. Как и в 
окне Subdomain Settings, в окне Boundary Settings в по-
следней версии программы  FEMLAB 3.2 появились 
вкладки Groups и Color. Они присваивают границам с 
различными ГУ разные цвета. В режиме расчета теплопе-
реноса излучением в модуле General Heat Transfer кроме 
группировки по свойствам теплообмена для экономии вы-
числительных ресурсов появляется группировка по взаи-
модействующим границам. Принято, что обмениваются 
излучением («видят друг друга») только границы, принад-
лежащие к одной группе. Эта группа задаётся отдельным 
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полем Member of Group(s) во вкладке Boundary 
Condition.  

В некоторых моделях (в основном связанных с элек-
тричеством) кроме свойств на границе необходимо зада-
вать свойства ребер и точек. В режиме Fluid Flow > 
Incompressible Navier-Stokes также необходимо задавать 
давление в точке. 

Часто при моделировании сложных систем, например 
радиоэлектронных аппаратов кассетного типа, выделяют 
элементарный объем и проводят расчет для этого элемен-
тарного объема. Для корректного расчета необходимо за-
дать особый вид граничных условий – периодические гра-
ничные условия. В программе они задаются с помощью 
команды меню Physics > Periodic Condition. Кроме усло-
вий на границе Boundary требуется задать периодические 
свойства для точек Point и в некоторых режимах для ребер 
Edge. Настройки этих окон позволяют задать зависимость 
противоположных границ элементарного объема. 

Для некоторых классов мультифизических задач, где 
надо связать два объекта с разным типом сетки (например, 
прямоугольную сетку в одной части системы с треуголь-
ной в другой) и граничными условиями неразрывности, 
можно применять условия идентичности Physics > Identity 
Conditions. 

В FEMLAB 3.2 есть много возможностей гибкой на-
стройки системы под каждую конкретную задачу. Можно 
изменять систему дифференциальных уравнений в част-
ных производных (PDE). Для этого служит группа команд 
Physics > Equation system. Эти команды позволяют в ши-
роких пределах изменять исходные PDE, способы задания 
начальных и граничных условий, а также параметры ко-
нечных элементов.  

Чтобы самостоятельно добавить значения необходи-
мых коэффициентов, открываем окно Physics > Equation 
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system > Subdomain settings или Ctrl+F8. Здесь можно 
для каждой подобласти (Subdomain) задать в прямом виде 
значение любого коэффициента PDE или же изменить 
формулу вычисления коэффициентов. У каждой области, 
для которой принимаются изменения, появится значок 
замка. Он будет виден и из окна Physics > Subdomain 
settings. Приоритет всех значений – у окна Physics > 
Equation system > Subdomain settings, поэтому надо про-
верить, какие коэффициенты уже здесь указаны, и лишь 
потом задавать материальные свойства в Physics > 
Subdomain settings. Сбросить все изменения системы 
уравнений можно кнопкой Reset Equation. 

Для изменения формул ГУ служит окно Physics > 
Equation system > Boundary settings или Ctrl+F7. Работа с 
ним аналогична предыдущему. С помощью команды 
Physics > ODE settings в FEMLAB 3.2 можно добавить 
любые обыкновенные дифференциальные уравнения.  

3.6. Построение сетки 
После задания всех свойств и граничных условий на-

ступает очередь построения сетки. Для простейших моде-
лей на первом этапе оценочного расчета можно задать сет-
ку по умолчанию Mesh > Initialize Mesh (кнопка с изобра-

жением треугольника ), несколько раз нажать Mesh > 
Refine mesh и, получив достаточно мелкую сетку, присту-
пить к решению. При нажатии этих кнопок рабочая об-
ласть переходит в режим Mesh Mode и в рабочей области 
отображается разбиение фигуры. Этот режим вручную 

можно вызвать соответствующей кнопкой  или коман-
дой меню Mesh > Mesh Mode. Для моделей только с теп-
лопроводностью, не связанных с тепломассобменом, мож-
но этим и ограничиться: для более мелких элементов сетки 
система автоматически произведет сгущение, а если необ-
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ходимо в какой-либо части системы еще более сгустить 
сетку, то можно нажать кнопку Refine selection и указать 
нужную область. Для одномерного и двумерного стацио-
нарных режимов можно просто делать наиболее мелкую 
сетку. Скорость вычисления на современных компьютерах 
все равно будет достаточно приемлемой. В моделях, учи-
тывающих конвекцию, надо всегда помнить, что размер 
конечного элемента должен быть в несколько раз меньше 
толщины пограничного слоя, иначе решение может не сой-
тись и будет в любом случае нестабильно. Поэтому реко-
мендуется строить сетку такой густоты, чтобы между лю-
быми двумя границами было не меньше десяти конечных 
элементов. 
По умолчанию в пакете FEMLAB строится в двумерном 
режиме треугольная сетка, а в трехмерном режиме – тетра-
эдрическая. Для задания параметров сетки надо выбрать 
Mesh > Mesh parameters или нажать кнопку F9. Откроет-
ся окно настроек, на вкладке Global (рис. 3.9) можно вы-
брать один из предустановленных режимов. В списке 
Predefined  mesh sizes  девять режимов от  Extremely  fine 
(Чрезвычайно точный) до Extremely coarse (Чрезвы-
чайно грубый), остальные расположены между этими 
крайними режимами. В полях можно задать собственные 
значения параметров сетки. 

Maximum element size задает максимальный размер 
элемента. По умолчанию равен 1/15 максимальной сторо-
ны, задавать его необязательно. Если ничего не задавать в 
предыдущее поле, то значение поля Maximum element size 
scaling factor будет определять размер элемента (если за-
дать 0.5, то размер элемента будет равняться 1/30 макси-
мальной стороны, если 0.1 то 1/150). Element growth rate 
(Темп роста элемента) отвечает за степень сгущения, 
принимает значения от единицы до бесконечности; чем 
ближе   значение  к  единице, тем более равномерная сетка.   
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Рис. 3.9. Окно Mesh parameters 

Поля Mesh curvature factor и Mesh curvature cut off отве-
чают за криволинейность границы: чем меньше эти значе-
ния, тем более точно задана криволинейность границы. 
При больших значениях этих параметров вместо кривой 
будет считаться ломаная линия. Поле Resolution of narrow 
regions задает минимальное количество элементов по са-
мой короткой границе, для точных вычислений рекомен-
дуется устанавливать значения этого параметра не меньше 
десяти. Поле Mesh geometry to level  позволяет выбрать 
создание сетки для областей, поверхностей и ребер. Для 
большинства задач тепломассопереноса это значение 
должно быть областью Subdomain. Refinement method 
принимает два значения Regular и Longest и отвечает за 
режим работы команды Refine mesh. Если установлено 
значение Regular, при нажатии этой команды каждый эле-
мент делится на четыре части в 2D - режиме и на восемь в 
3D - режиме. Значение Longest делит каждый элемент на 
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две части по самой длинной стороне. Вкладки Subdomain, 
Boundary, Edge и Point позволяют задать размер элемента 
для соответствующих элементов модели. Вкладка 
Advanced позволяет задать анизотропию сетки.  

Кнопка Remesh перестраивает сетку с новыми пара-
метрами. 

В двумерном режиме для объектов, близких к прямо-
угольным, можно задать четырехугольную сетку или с по-
мощью пунктов меню Mesh > Map mesh, или одновремен-
ным нажатием клавиш Ctrl+F9.  

В разделах «Рабочая область» и «Задание геометрии» 
были упомянуты способы преобразования двумерных мо-
делей в трехмерные с помощью команд Draw > Extrude и 
Draw > Revolve. Тогда после задания трехмерной геомет-
рии придется заново строить сетку из тетраэдров, что мо-
жет занимать значительное время. Иногда целесообразно 
сначала построить сетку в 2D - режиме (треугольную или 
четырехугольную), а потом с помощью пунктов меню 
Mesh > Extrude Mesh… растянуть фигуру с сеткой или с 
помощью Mesh > Revolve Mesh… раскрутить фигуру с 
сеткой. Тогда элементы будут не тетраэдрические, а в виде 
параллелепипедов или призм. Времени на построение та-
кой сетки уходит меньше, чем при строительстве тетраэд-
рической сетки заново. На скорость расчета задачи вид 
сетки кардинально не влияет. 

3.7.  Решающее устройство 
 Выбор решающего устройства и его параметров очень 
важен, так как в основном от него зависит достоверность 
вычислений. Неправильная настройка может привести к 
грубым ошибкам решения, которые очень трудно выявить. 
Также очень важно правильно оптимизировать решение, 
так как даже не очень сложная трехмерная модель элемен-
та кассетной конструкции рассчитывается десятки минут 
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на компьютере с процессором Athlon64 3000+ и 1Gb опе-
ративной памяти, а некоторые нелинейные нестационар-
ные модели – многие часы даже на очень мощном компью-
тере.  

Кнопка Solve (или пункт меню Solve > Solve problem) 
запускает решающее устройство с текущими настройками. 
Кнопка Restart (или пункт меню Solve > Restart) переза-
пускает решающее устройство, используя текущие значе-
ния (поле температур или скоростей) как начальные. Если 
рассматривается стационарная задача, то нажатие этой 
кнопки не должно менять решения. Колебания значений в 
этом случае говорят о нестабильности решения. Эту ко-
манду целесообразно применять для сложных расчетов, 
когда можно получить приближенный вариант решения на 
грубой сетке и для линейного или стационарного решате-
ля. Потом сделать более мелкую сетку,  при необходимо-
сти изменить решатель на нелинейный или переходный и 
пересчитать задачу.  Это позволяет получить решение бы-
стрее, чем если сразу запустить сложный расчет.   

Для изменения параметров необходимо нажать F11 
Solve > Solver parameters… или соответствующую кноп-
ку. Откроется окно (рис. 3.10).    

Если стоит галочка Auto select solver, то это значит, 
что программа в зависимости от прикладного режима по-
добрала наиболее подходящее устройство, для несложных 
вычислений чаще всего менять его не надо. 

Выбирая решающее устройство, надо, в первую оче-
редь, определиться с изучением стационарного или пере-
ходного процесса. Если процесс нестационарный, то в по-
давляющем большинстве случаев подходит решатель Time 
Dependent. 

Для очень редких задач, связанных с нахождением соб-
ственных чисел дифференциальных уравнений, например 
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волнового уравнения теплопроводности, надо выбирать 
решатель Eigenvalue. 

 Если задача стационарная, то, в первую очередь, необ-
ходимо определить: линейная она или нелинейная. Если 
есть сомнения в линейности задачи, то рекомендуется сра-
зу устанавливать нелинейный решатель. Если для линей-
ной задачи установить нелинейный решатель, то ответ бу-
дет корректен, но на вычисления затратится больше вре-
мени, а если для нелинейной задачи установить линейный 
решатель, то наверняка будут грубые ошибки. 

 
Рис. 3.10. Окно Solver parameters 

Необходимо обратить внимание на то, что если в за-
данных коэффициентах присутствуют переменные (на-
пример, теплоемкость или теплопроводность), для которых 
задали их зависимость от искомого поля (температуры) 
или от других связанных с искомым полем переменных, то 
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задача нелинейная. Все задачи, в которых учитывается те-
плообмен излучением, то есть где С или Ctrans (константа 
Стефана-Больцмана) не равна нулю, – нелинейные. Моде-
ли, которые задают в прикладном режиме Incompressible 
Navier-Stokes, практически всегда нелинейные.  

Для линейных и нелинейных стационарных задач мож-
но выбрать параметрический решатель, в котором надо 
указать параметры с заданными несколькими значениями. 
Например, задать ряд разных теплопроводностей или 
мощностей для какого-либо объекта, а потом сравнить 
распределение температур при всех значениях параметра. 
После выбора решателя в поле Solver задаются основные 
свойства. 

Для Time Dependent на вкладке General – это Time 
stepping (шаги по времени) в поле Times в формате 
0:10:60 задаются временные слои. Здесь  от 0 до 60 секунд 
с промежутком 10 секунд. Единица измерения времени – 
секунда, она устанавливается в Physics > Subdomain 
Settings в поле Time scaling coefficient. Если вместо 1 за-
дать 1/60, то единица измерения времени будет равна од-
ной минуте. В полях tolerance определяется ошибка на 
каждом шаге итерации. Галочка Allow complex number 
позволяет применять в расчетах комплексные числа. Это 
нужно в случаях, если мы задали коэффициенты PDE в 
комплексном виде. Вкладка Time Stepping определяет ша-
ги по времени. Пункт Times to store in output определяет, 
какие временные шаги будут выводиться для постобработ-
ки вычислений. По умолчанию стоит Specified Times, то 
есть время, определённое на вкладке General. Для того 
чтобы получить значения всех шагов решающего устрой-
ства, надо выбрать Time steps from solver. Вообще, ре-
шающее устройство выбирает шаги произвольно, в зави-
симости от динамики системы, то есть игнорирует задан-
ные значения Times на вкладке General. Чтобы решающее 
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устройство учитывало этот список (например, если внеш-
ние воздействия импульсные и решатель может «проско-
чить» мимо них), надо установить Time steps taken by 
solver в значение Strict (тогда решатель будет использо-
вать только эти шаги) или Intermediate (решатель исполь-
зует и свободные шаги, и перечисленные на вкладке 
General) вместо стоящего по умолчанию Free. Если надо 
принудительно задать шаг по времени нужного размера, то 
это делается в поле Manual Tuning of step size. 

Для Eigenvalue необходимо задать количество собст-
венных чисел уравнения в поле Desired number of 
eigenvalues и диапазон значений в поле Search for 
eigenvalues around. 

Для параметрического решателя надо установить имя 
параметра, которое вводится в поле Name of parameter, и 
значения, которые он будет принимать в поле List of 
parameter values. Значения можно перечислить через про-
бел, задать в виде 0:10:100 или как функцию 
linspace(1,100,25), то есть 25 значений, равномерно распо-
ложенных от 1 до 100. 

Для нелинейных решателей появляется вкладка 
Nonlinear, где можно указать количество итераций (по 
умолчанию стоит 25). Для сильно нелинейных проблем 
рекомендуется поставить галочку Highly nonlinear 
problem и увеличить количество итераций. 

Для всех режимов, кроме Time Dependent, можно ус-
тановить галочку Adaptive Mesh Refinement, тогда в про-
цессе решения сетка будет уточнена по сложному алго-
ритму. Если физические явления и геометрия объёма дос-
таточно сложны и не очень ясно, как задавать параметры 
сетки, рекомендуется установить эту галочку. Но это уве-
личит время вычисления. 

Кроме того, можно установить Matrix symmetry в зна-
чение Symmetric, если матрица симметрична. Чаще всего 
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это бывает, если мы рассматриваем процессы только теп-
лопроводности или диффузии. При выборе соответствую-
щего линейного решателя это ускорит расчет. Матрицы 
заведомо несимметричны в мультифизических моделях, 
моделях, связанных с конвекцией или уравнением Навье-
Стокса.  

Большая часть времени расчета занята решением сис-
тем линейных уравнений, отвечает за их решение Linear 
system solver. По умолчанию стоит Direct(UMFPACK), 
который затрачивает много ресурсов компьютера. Для мо-
делей, требующих длительного расчета, можно подобрать 
более подходящий решатель. Если решатель Direct 
(UMFPACK) не работает или работает недопустимо долго, 
можно попробовать Direct (SPOOLES). Он требует мень-
ше памяти, но работает нестабильно. В крайнем случае 
выбирается итеративный решатель GMRES. Для положи-
тельно определенных систем с симметричными матрицами 
– Direct Cholesky (TAUCS) или итеративный Conjugate 
Gradients. Итеративные решатели потребляют меньше па-
мяти, но надо следить за тем, чтобы они сходились только 
в случае необходимого увеличения количества итераций. 

Уравнения только для теплопроводности и только для 
диффузии в стационарных режимах являются линейными, 
а в нестационарном режиме – параболическими. Для них 
очень эффективно использование решателя Geometric 
multigrid. Часто в процессе решения какой-либо задачи, 
например тепловой расчет при конструировании прибора, 
приходится перебирать большое количество конструкци-
онных материалов и изменять  геометрические размеры. 
Общие же принципы физической модели остаются теми 
же. В таком случае можно после длительного расчета 
стандартным решателем (UMFPAK) попробовать другие 
решатели, и если они работают быстрее, а результат реше-
ния остается тем же, то дальнейшие исследования можно 
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проводить уже с помощью более быстрого решателя – это 
сэкономит много времени. 

После задания свойств кнопкой Solve (или пунктом ме-
ню Solve > Solve Problem) запускается решающее устрой-
ство. Часто после получения решения модель и её пара-
метры (физические свойства и граничные условия) немно-
го изменяются. Если эти изменения не очень велики, то 
можно использовать команду Solve > Update model, тогда 
задача пересчитываться не будет, а новые значения будут 
получены методом интерполяции. Можно нажать кнопку 
Restart, тогда задача пересчитается, но за Init (Началь-
ные) значения будут взяты те, которые были получены на 
предыдущем этапе. Это может немного ускорить вычисле-
ния. Также с помощью этой команды можно выявить не-
стабильность решения; если при нажатой этой кнопке без 
изменения параметров модели получаются разные резуль-
таты решения (осцилляции численного решения), то это 
говорит о нестабильности решения. В этом случае нужно 
уменьшить сетку или, если эта задача связана с конвекци-
ей, применить диффузионную стабилизацию в настройках 
физических свойств модели. 

3.8. Визуализация результатов 
После завершения решения автоматически включается 

режим Postprocessing mode (Режим постобработки), в 
котором можно наблюдать результаты вычисления. Вруч-
ную этот режим можно включить соответствующей кноп-

кой  или командой Postprocessing > Postprocessing 
mode. По умолчанию результаты после расчётов теплопе-
редачи выводятся в виде поля температур, после расчетов 
диффузии – в виде поля концентраций, а после расчетов по 
уравнению Навье-Стокса – в виде поля скоростей.  

Рассмотрим одномерный, стационарный режим, где 
после расчета требуется получить распределение какого-
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либо параметра по оси, например распределение темпера-
туры по длине стенки. По умолчанию оно выводится пря-
мо в рабочей области в виде графика. В случае нестацио-
нарного режима выводится график распределения для по-
следнего временного слоя. Настройки визуализации вклю-
чаются командой Postprocessing > Plot parameters… или 
клавишей F12. После этого откроется окно Plot parameters 
с четырьмя вкладками (в режиме 1D).  

На вкладке General в поле Plot type необходимо 
выбрать, какие параметры результатов вычисления будут 
отображаться: Line (Линия), Max/min marker (Метка 
максимума и минимума) и Geometry edges (Грани гео-
метрии – параметр показывает или скрывает границы сте-
нок). В поле Solution to use (Использование решения) в 
режиме переходного анализа можно выбрать временной 
слой (по умолчанию изображается последний) в раскры-
вающемся списке Solution at time (Решение для време-
ни). Если там выбрать пункт Interpolated, то в поле Time 
можно указать промежуточное значение времени и полу-
чить интерполированный расчет.  

В режиме параметрического решателя в списке будут 
не временные слои, а значения параметра. 

На вкладке Line расположена галочка Line plot, дубли-
рующая аналогичную кнопку на вкладке General, поле 
Height data (Данные по вертикальной оси) позволяет за-
дать нужную нам переменную, которая будет отображать-
ся по оси ординат. В режиме Heat transfer в списке 
Predefined quantities (Предопределенные значения) по 
умолчанию стоит температура (рис. 3.11), но есть возмож-
ность задать практически любой возможный параметр: 
Heat flux (Тепловой поток), Temperature gradient (Гра-
диент температуры), а также все коэффициенты PDE (те-
плоемкость, теплопроводность и т.п. в случае теплопере-
дачи) и все параметры граничных условий (например, 
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внешнюю температуру или коэффициент теплоотдачи). 
При этом в поле Expression (Выражение) будет отобра-
жаться текущая переменная или задающее её выражение. 
Например, градиент температуры в программе задается как 
gradT_ht. В это поле можно заносить и свои произвольные 
выражения. Таким образом, вместо распределения абсо-
лютных значений температуры по толщине исследуемой 
стенки можно получить график перегревов. 

 
 

Рис. 3.11. Распределение температуры в трехслойной стенке 
 В поле Line color можно выбрать Uniform (Одноцвет-
ный) график или для наглядности задать Line color 
expression (Зависимость цвета линии) от любого 
параметра.  

На вкладке Max/Min можно задать параметры этих 
маркеров. На вкладке Animation time dependent (В режи-
мах переходного времени) или Parametric (Параметри-
ческого) задаются параметры анимации результатов вы-
числений. Анимацию можно сохранить в одном из не-
скольких видеоформатов. 
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В двумерном исследовании режим постобработки бо-
лее обширен. На левой панели расположены кнопки пре-
дустановленных режимов. 2D Surface Plot – выводит зна-
чение скалярного поля (температуры, скорости или кон-
центрации) в цветном виде. 3D Surface Plot – выводит зна-
чение скалярного поля в виде трехмерной поверхности. 
Contour plot – выводит результаты решения в виде изоли-
ний (в режиме теплопередачи – изотермы). Arrow plot – 
выводит векторное поле (потока тепла, скоростей или по-
тока диффузии) в виде стрелочек. Streamline plot – выво-
дит векторное поле в виде линий потока. Line Plot – осу-
ществляет визуализацию значений на границах в цветовом 
виде. Animate – в переходном режиме создает анимацию 
решения. Все эти кнопки дублируются в окне 
Postprocessing > Plot Parameters… или кнопкой F12, где 
можно задать всевозможные параметры вывода 
результатов. На вкладке General можно отметить 
галочками все виды визуализации, которые будут 
выводиться, а на вкладках задать их свойства. На каждой 
вкладке можно выбрать любые переменные или задать 
свои, определить цветовое соответствие результатам, 
задать диапазон выводимых параметров и многое другое. 

Чтобы получить значение отображаемой величины в 
конкретной точке, можно щелкнуть мышкой в необходи-
мом месте фигуры. Значение будет выведено в строке со-
общений под рабочей областью вместе с координатами 
точки. При активизированном переключателе SNAP мож-
но посмотреть только значения в узлах решетки. Если на-
жать меню Draw Point for Cross-Section Point Plot, а по-
том курсором от мыши отметить нагреваемое тело, то от-
кроется окно с графиком изменения температуры во вре-
мени. Кнопка Draw Line for Cross-Section Line Plot по-
зволяет провести через фигуру прямую линию и получить 
график температуры вдоль этой линии. Эти кнопки дубли-
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руют пункт меню Postprocessing > Cross-Section Plot 
Parameters…, который открывает окно с тремя вкладками. 
На вкладке General можно выбрать временные слои или 
(при параметрическом решателе) значения параметров, для 
которых строится график. Вкладки Point позволяют задать 
координаты точек, для которых будет построен график, и 
переменную, от которой он строится. Вкладка Line также 
задает переменную и координаты линии, есть возможность 
задать количество равноотстоящих параллельных линий. В 
случае переходного анализа будет построен график для 
каждого выделенного временного слоя.  

Пункт меню Domain Plot parameters позволяет полу-
чить вид решения для каждой области отдельно или рас-
пределение переменной на границах и в углах фигуры. 

 В трехмерном режиме основным видом визуализации 
является Slice Plot (График сечений), в этом режиме по-
казывается определенное количество сечений расчетной 
области с распределением заданной переменной. 
Isosurface Plot показывает изоповерхности, Subdomain 
Plot – распределение скалярного поля переменной по 
всему объему, Boundary Plot –распределение температур 
на всех границах фигуры. Остальные режимы аналогичны 
2D. Все параметры соответствующих режимов 
визуализации настраиваются в окне Postprocessing > Plot 
Parameters… или клавишей F12 

Кроме того, в трехмерном режиме можно видеть кноп-
ки, отвечающие за «освещение» и ракурс объекта. 

Часто возникает необходимость проинтегрировать ка-
кой - либо параметр по объему, поверхности или ребру. 
Команды Postprocessing > Subdomain/ Boundary/Edge 
Parameters… позволяют это сделать, выбирая необходи-
мый элемент, задавая переменную или выражение. Чтобы 
узнать площадь или объем (например, чтобы вычислить 
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объемную мощность) объекта надо вместо подынтеграль-
ного выражения задать 1. 

Каждый из полученных графиков можно сохранить как 
в виде отдельного рисунка, так и в виде текстового файла. 
Полностью экспортировать  все полученные данные мож-
но с помощью пункта меню File > Export > Postprocessing 
Data. 

4. Нагрев изделий  
В твёрдых телах передача тепла происходит посредст-

вом теплопроводности. Если при передаче тепла в теле не 
происходит изменение температур во времени: ( ddT =0), 
то тепловое состояние называют стационарным. При не-
стационарном тепловом состоянии ddT ≠0, температура 
тела меняется во времени, происходит изменение энталь-
пии тела. Такие процессы связаны с нагревом или охлаж-
дением тел. Аналитическая зависимость изменения темпе-
ратуры и количества переданного тепла во времени для 
любой точки тела может быть получена на основании ре-
шения основного дифференциального уравнения тепло-
проводности, которое в декартовой системе координат 
имеет следующий вид: 
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где а – коэффициент температуропроводности, характери-
зующий скорость выравнивания температуры в неравно-
мерно нагретом теле, м2/с; x,y,z – расстояния в декартовой 
системе координат. 

Для получения однозначного решения уравнения теп-
лопроводности его необходимо решать совместно с урав-
нениями краевых условий, состоящих из начальных и по-
верхностных или граничных условий [6].  
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Существует несколько способов задания граничных 
условий: 
 поверхностные условия первого рода, когда задано 
распределение температур на поверхности тела, как функ-
ция времени; 
 поверхностные условия второго рода, когда задан теп-
ловой поток; 
 поверхностные условия третьего рода, когда задан за-
кон изменения температуры окружающей среды и закон 
теплообмена между поверхностью тела и окружающей 
средой; 
 поверхностные условия четвёртого рода, характери-
зующие условия теплообмена тела с окружающей средой 
по закону теплопроводности.  

4.1. Нагрев тела при граничных условиях I рода  
(стационарный режим 1D модель) 

Режим предназначен для расчета нагрева листа метал-
ла с толщиной, на порядок меньшей двух других размеров. 
В качестве граничного условия принята постоянная темпе-
ратура на поверхности металла, а со стороны теплового 
центра режим условия адиабаты. Для нагреваемой пласти-
ны надо выбрать режим 1D. 

Рассмотрим модель однослойной пластины толщиной 
0,1 м с граничными условиями I рода с одной стороны и II 
рода (условия адиабаты) c другой. Температура внешней 
стороны пластины равна 1000 °С. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator.  
Выберите в списке Space Dimension 1D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Steady-state 
analysis. 

Нажмите OK.  
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Откроется рабочая область с одной координатной осью.  
ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 10 см. Введите в поле цифры 0    0.1. 
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1. Это же окно можно от-
крыть, если щелкнуть на кнопке Line при нажатой клави-
ше Shift.  

Нажмите OK.  

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 
Теперь можно задать физические свойства материала 

пластины.  
Откройте окно Physics>Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область сразу выделится красным.   
Введите в поля свойства в соответствии с табл. 4.1. 

Таблица 4.1.                    Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k ,Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см Сталь 38.67 7850 608.3 0 
В стационарном режиме Density (Плотность) и Heat 

capacity (Теплоемкость) можно принять равными едини-
це.  В остальных полях оставить нулевые значения. 
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Для того чтобы установить начальное значение темпе-
ратуры, откройте в том же окне вкладку Init. 

Введите 273 как начальное значение в поле 
Temperature. 

Нажмите OK. 
Граничные условия  

Откройте окно Physics>Boundary Settings… (F7).  
В Boundary selection выберите номер границы. В рабочей 

области соответствующая граница выделяется красным.  
Введите граничные условия в соответствии с табл. 4.2. 

Таблица 4.2.                  Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты 

ГУ 

1 Среда–сталь Temperature T0=1273 К 
2 Сталь–среда Thermal insulation  

В нашем случае можно использовать линейный реша-
тель, так как все физические свойства и коэффициенты 
приняты не зависящими от температуры.  
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh>Initialize Mesh или кнопкой . 
Получится пятнадцать узлов по длине стенки. Чтобы уве-

личить количество узлов, надо нажать кнопку  (Mesh > 
Refine Mesh). При необходимости её можно нажать не-
сколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver 

Parameters(Параметры решателя). 
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В списке Solver (Решатель) выберете Stationary linear 
(Стационарный линейный). 

Нажиммите OK. 

Нажмите кнопку Solve (Решать).  [Solve > Solve 
Problem]. Получите распределение температуры по толщи-
не пластины в основном окне.  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.1).  
По результатам расчета видно, что при условиях ста-

ционарного режима температура теплового центра пласти-
ны сравнялась с температурой поверхности. 

 
Рис. 4.1. Распределение температур по толщине стенки (стацио-

нарная задача) 

4.2. Нагрев тела при граничных  условиях I рода 
(нестационарный режим 1D модель) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева листа металла с толщиной, на порядок 
меньшей двух других размеров. В качестве граничного усло-
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вия принята постоянная температура на поверхности метал-
ла, а со стороны теплового центра – условия адиабаты. Для 
нагреваемой пластины надо выбрать режим 1D. 

Рассмотрим модель однослойной пластины толщиной 0,1 
м с граничными условиями I рода с одной стороны  и  II рода 
(условия адиабаты) c другой. Температура внешней стороны 
пластины равна 1000 °С. Время нагрева пластины 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator.  
Выберите в списке Space Dimension 1D. 
В Application Mode выберите режим COMCOL 

Multiphysics  > Heat Transfer  > Conduction > Transient 
analysis. Нажмите OK.  

Откроется рабочая область с одной координатной осью.  
ЗАДАНИЕ ГЕОМЕТРИИ  

Выберите пункт меню Draw>Specify Objects>Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 10 см. Введите в поле цифры 0   0.1.  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1.  
Это же окно можно открыть, если щелкнуть на кнопке 

Line при нажатой клавише Shift. 
Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 
Для задания физических свойств материала пластины 

требуется следующее.  



58 

Откройте окно Physics>Subdomain Settings… (в по-
следней версии программы оно вызывается клавишей F8).  

В Subdomain selection выберите номер пластины. В ра-
бочей области эта  область сразу выделится красным.   

Введите в поля свойства для стали в соответствии с табл.  4.3. 
Таблица 4.3.                Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 

k , Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q,  Вт/м3 

1 10 см Сталь 38.67 7850 608.3 0 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7).  
В Boundary selection выберите номер границы. В рабочей 

области соответствующая граница выделяется красным. 
Введите граничные условия в соответствии с табл. 4.4. 

Таблица 4.4.                  Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты 

ГУ 

1 Среда–сталь Temperature T0=1273 К 
2 Сталь–среда Thermal insulation  

В нашем случае можно использовать линейный реша-
тель, так как все физические свойства и коэффициенты 
приняты не зависящими от температуры. 

Нажмите OK. 
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ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . 
Получится пятнадцать узлов по длине стенки. Чтобы уве-

личить количество узлов, надо нажать кнопку  (Mesh > 
Refine Mesh). При необходимости её можно нажать не-
сколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000. Это значит, что для вывода решения бу-
дет использоваться шаг по времени 20 секунд. Этот шаг не 
имеет отношения к точности решения, но для визуализа-
ции он важен. В самом решателе шаг по времени доста-
точно маленький и зависит от скорости изменения темпе-
ратуры. Расчет будет длиться до 1000 с.  

Нажмите OK. 

Нажмите кнопку Solve (Решать).  (Solve > Solve 
Problem). Получите распределение температуры по тол-
щине пластины в основном окне.  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.2).  
По результатам расчета видно, что при условиях не-

стационарного режима температура теплового центра пла-
стины равна 1099,9 К. 
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Рис. 4.2. Распределение температур по толщине стенки           

(нестационарная задача) 

4.3. Нагрев тела при граничных условиях I рода  
(нестационарный     режим    1D   модель  с   учётом   

зависимости      теплофизических       свойств                 
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева листа металла с толщиной, на порядок 
меньшей двух других размеров. В качестве граничного усло-
вия принята постоянная температура на поверхности метал-
ла, а со стороны теплового центра – условия адиабаты. Для 
нагреваемой пластины надо выбрать режим 1D. 

Рассмотрим модель однослойной пластины толщиной 
0,1 м из стали 20 с граничными условиями I рода с одной 
стороны и II рода (условия адиабаты) c другой. Температу-
ра внешней стороны пластины равна 1000 °С. Время на-
грева пластины 1000 с. Зависимость теплофизических 
свойств для стали 20 представлена в табл. 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 
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Таблица 4.5.         Зависимость теплофизических коэффициентов 
для стали 20 от температуры металла 

Температура, 
˚С 

Коэффициент теп-
лопроводности, 

Вт/(м·˚С) 

Удельная те-
плоёмкость, 
Дж/(кг·˚С) 

 
Плотность 

стали, 
кг/м3 

 
T k Cp ρ 

273 51.9 − 7863 
323 51.5 465 7849 
373 51.1 486 7834 
423 49.9 507 7819 
473 48.5 519 7803 
523 46.5 532 7787 
573 44.4 557 7770 
623 43.6 574 7753 
673 42.7 599 7736 
723 41.1 624 7718 
773 39.3 662 7699 
823 37.7 703 7679 
873 35.6 749 7659 
923 33.9 787 7635 
973 31.9 846 7617 
1023 28.5 432 7620 
1073 25.9 950 7624 
1123 25.9 737 7616 
1173 26.4 649 7600 
1223 27.2 649 7574 
1273 27.7 649 7548 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляется таким образом: 
Из меню Options выберите Functions. 
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В диалоговом окне, которое появляется, нажмите New 
(рис. 4.3). 

 
Рис. 4.3. Окно для создания зависимой переменной 

В Functions name дайте последовательно названия за-
висимых переменных k, c, rho , радиокнопкой выберите 
Interpolation, а в списке Use data from отметьте Table и 
нажмите OK. 

Появляется диалоговое окно Function (рис. 4.4) 
В диалоговом окне Function definition, в списке 

Interpolation metod выберите Linear. 
В списке  Extrapolation metod подставьте  

Extrapolation 
Затем введите значения в столбцы для x температуры  в 

f (x) зависимых  переменных k, c, rho, в соответствии с 
табл. 4.5. 

После окончания нажмите OK.  
Свойства подобласти 

Для того чтобы задать физические свойства материала 
пластины,  необходимо выполнить следующее. 

Откройте окно Physics > Subdomain Settings…(в по-
следней версии программы оно вызывается клавишей F8). 
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Рис. 4.4. Окно для записи значений зависимых переменных 

В Subdomain selection выберите номер пластины. В ра-
бочей области она выделится красным.   

Введите в поля свойства для стали как функции от тем-
пературы в соответствии с табл. 4.6 
Таблица 4.6.                        Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
K,Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см Сталь k(T) rho(T) c(T) 0 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 
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Задание граничных условий генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.5). 
По результатам расчета видно, что при условиях не-

стационарного режима температура теплового центра пла-
стины равна 996,7 К. Произошло уточнение температуры 
центра на 103 К или на 10,3 %. 

После работы решателя в главном окне (рис. 4.5) бу-
дет выведено распределение температур по толщине стен-
ки для момента времени 1000 с. Для того чтобы увидеть 
распределение температур по толщине пластины в другие 
моменты времени, необходимо выполнить следущее. 

Откройте окно Postprocessing  > Plot Parameters.  
Во вкладке General откройте список Solution at time. 
Здесь можно выбрать значение времени, для которого 

необходимо посмотреть распределение. 
Выберите значение 300. 
Нажмите кнопку Apply.  
Вы увидите распределение температур в этот момент 

времени. По умолчанию оно выводится в виде черной ли-
нии.  

Выберите вкладку Line в области Line Color, переклю-
чите радиокнопку из значения Uniform Color (Неизмен-
ный цвет) на значение Use expression to color lines (Ис-
пользуйте выражение для расцветки линий). Тогда рас-
пределение температур будет более наглядным. 

Теперь перейдите во вкладку Animate (Анимация). 
Здесь можно выбрать формат и разрешение выходного 
файла и период времени, для которого создается анимация. 
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Проверьте, что выбраны все шаги времени. Для того 
чтобы выделить все шаги,  выделите один из них и нажми-
те Ctrl+A. 

  
Рис. 4.5. Распределение температур по толщине стенки           

(нестационарная задача с учётом зависимости теплофизических 
свойств от температуры) 

Нажмите кнопку Start Animation. Подождите около 
минуты, пока будет создаваться анимация. После этого вы 
можете просмотреть анимацию и сохранить AVI или MOV 
файл.  

Закройте окно с анимацией и нажмите OK. 
Теперь откройте окно Postprocessing > Cross-Section 

Plot Parameters.  
Во вкладке General проверьте, что выбраны все шаги 

времени. 
Затем выберите вкладку Point. 
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В поле Coordinates х: выберите значение 0.1 – точку 
теплового центра пластины. 

Нажмите OK. 
Вы увидите окно с графиком переходного процесса в 

тепловом центре пластины (рис.4.6). 
С помощью кнопки Zoom window можно увеличить 

любую часть графика. 
Можно на одном рисунке совместить графики распре-

деления температур по толщине пластины для различных 
моментов времени. 

 Откройте окно Postprocessing > Domain Plot Parameters. 
В области Plot type включите радиокнопку 

Line/Extrusion Plot. 
В области Solutions to use (Используемые решения) 

раскройте список Select via и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  

В поле Expression должно стоять T. В списке Subdomain 
Selection должна быть выбрана подобласть один. 

По умолчанию после нажатия ОК будут выведены 
разноцветные сплошные линии, без «легенды» – это не-
удобно при печати. 

 Поэтому нажмите кнопку Line settings.  
В открывшемся окне в списке Line color выберите 

Color. В списке Line style выберите Cycle. В списке Line 
marker выберите Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 4.7). 
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Рис. 4.6. Изменение температуры центра пластины              

со временем 

 
Рис. 4.7. Распределение температур в стенке для различных 

моментов времени 
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4.4. Нагрев осесимметричного тела при  граничных 
условиях  I  рода  (нестационарный режим  1D  модель  

с  учётом   зависимости  теплофизических свойств       
от температуры) 

При выборе размерности модели необходимо знать, 
что её увеличение приводит к значительному увеличению 
времени. Этот режим предназначен, как  и  в  предыдущем 
случае, для расчета нагрева металла, только в виде длинно-
го цилиндра. В качестве граничного условия принята по-
стоянная температура на поверхности цилиндра, а тепло-
вой центр совпадает с геометрическим центром. Для на-
греваемого цилиндра надо выбрать режим  Axial symmetry 
(1D). 

Рассмотрим модель цилиндра с радиусом 0,1 м из стали 
20 с граничными условиями I рода на поверхности, тепло-
вой центр у которого совпадает с геометрическим центром. 
Температура внешней стороны цилиндра равна   1000 °С. 
Время нагрева цилиндра 1000 с. Зависимость теплофизиче-
ских свойств стали 20 представлена в табл. 4.5. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator.  
Выберите в списке Space Dimension Axial symmetry (1D).  
В Application Mode выберите режим COMCOL 

Multiphysics  > Heat Transfer  > Conduction > Steady-state 
analysis. 

Нажмите OK. Откроется рабочая область.  
ЗАДАНИЕ ГЕОМЕТРИИ  

Выберите пункт меню Draw > Specify Objects >Line.  
В открывшемся окне введите координаты радиуса ци-

линдра в поле Coordinates. 
Радиус цилиндра 10 см. Введите в поле цифры 0 0.1.  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1. Это же окно можно от-
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крыть, если щелкнуть на кнопке Line при нажатой клавише 
Shift. 

Нажмите OK.  

Нажмите кнопку Zoom Extents , для того чтобы 
расположить фигуру на весь экран.  

Задание физических установок, граничных условий, ге-
нерация сетки и расчёт в этом примере ничем не отлича-
ются от предыдущего примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по радиусу цилиндра (рис. 4.8). 
По результатам расчета видно, что при условиях не-

стационарного режима температура теплового центра ци-
линдра равна 1207,7 К.  

 
Рис. 4.8. Распределение температур по радиусу цилиндра       

(нестационарная задача с учётом зависимости теплофизических 
свойств от температуры) 
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4.5.  Нагрев  тела   при   граничных    условиях  I  рода  
(нестационарный режим 2D модель) 

Режим предназначен для расчета нагрева металла с се-
чением, у которого размеры одного порядка, а длина на по-
рядок больше сторон сечения. В качестве граничного усло-
вия принята постоянная температура на трёх гранях сечения 
металла, а на одной стороне – условия адиабаты. Для нагре-
ваемого металла надо выбрать режим 2D. 

Рассмотрим модель заготовки с сечением в виде квадрата 
с граничными условиями I рода с трёх сторон и II рода (усло-
вия адиабаты) с одной стороны. Температура внешних сторон 
равна 1000 °С. Начальная температура нагрева 273 К. Сторона 
сечения квадрата равна 0.3 м. Время нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 2D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient 
analysis. Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > Rectangle.  
В открывшемся окне Rectangle найдите область Size и 

введите  0.3 в поле Width (Ширина), затем введите 0.3 в 
поле Height (Высота). 

Нажмите OK.  

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в по-
следней версии программы оно вызывается клавишей F8). 
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В Subdomain selection выберите единственную подоб-
ласть 1. В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с табл. 4.7. 
Таблица 4.7.                    Свойства материала 

№ 
по-
доб
лас-
ти 

Размер 
грани 

квадра-
та 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см Сталь 38.67 7850 608.3 0 
В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 
Граничные условия  

Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. В рабо-

чей области соответствующая граница выделяется крас-
ным. 

Введите граничные условия в соответствии с табл. 4.8. 
Таблица 4.8.                    Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты 

ГУ 

1 Среда–сталь Temperature T0=1273 К 
2 Среда–сталь Thermal insulation  
3 Среда–сталь Temperature T0=1273 К 
4 Сталь–среда Temperature T0=1273 К 
Нажмите OK. 
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ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . 
По умолчанию будет сгенерировано 928 конечных элемен-
тов. Чтобы увеличить количество элементов, надо нажать 

кнопку  [Mesh > Refine Mesh]. При необходимости её 
можно нажать несколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберете Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.9).  
По результатам расчета видно, что в условиях неста-

ционарного режима нагрева с постоянными теплофизиче-
скими коэффициентами температура теплового центра в 
квадратном сечении равна 741,9 К. 

4.6. Нагрев тела при граничных  условиях I рода 
(нестационарный     режим    2D  модель  с   учётом    
зависимости   теплофизических   коэффициентов         

от температуры) 
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева металла с прямоугольным сечением и дли-
ной, на порядок большей сторон сечения. В качестве гра-
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ничного условия принята постоянная температура на трёх 
сторонах сечения металла, а на одной стороне – условия 
адиабаты. Для нагреваемого металла надо выбрать режим 
2D. 

 
Рис. 4.9. Распределение температур по сечению заготовки (не-

стационарная задача) 

Рассмотрим модель заготовки с сечением в виде квад-
рата с граничными условиями I рода с трёх сторон и II ро-
да (условия адиабаты) с одной стороны. Температура 
внешних сторон равна 1000 °С. Начальная температура на-
грева 273 К. Сторона сечения квадрата равна 0,3 м. Время 
нагрева 1000 с. Зависимость теплофизических свойств ста-
ли 20 представлена в табл. 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 
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ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры определяется таким образом: 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
В Functions name дайте название зависимой перемен-

ной k, радиокнопкой выберите Interpolation, а в списке 
Use data from отметьте Table и нажмите OK. 

Появляется диалоговое окно Function (рис. 4.10). 
В диалоговом окне Function definition, в списке 

Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation. 

Введите значения в столбцы для x температуры в f (x) за-
висимые переменные k, в соответствии с табл. 4.5. 

 
Рис. 4.10. Окно для записи значений зависимых переменных 
Повторите все действия для c и rho. 
После окончания нажмите OK.  

 



75 

Свойства подобласти 
Для задания физических свойств материала пластины 

выполните следующее:  
Откройте окно Physics > Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функции от тем-

пературы в соответствии с табл. 4.9. 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Таблица 4.9.                      Свойства материала 

№ 
по-
доб-
лас-
ти 

Размер 
грани 

квадра-
та 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см Сталь k(T) rho(T) c(T) 0 
Задание граничных условий, генерация сетки и расчёт 

в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.11). 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
пластины равна 760,0 К. Произошло уточнение температу-
ры центра на 18,1 К, или на 2,4 %. 

В главном окне (рис. 4.11) выведено распределение 
температур по сечению заготовки для момента времени 
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1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, сделайте 
следующее. 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 

Здесь можно выбрать значение времени, для которого не-
обходимо посмотреть распределение. 

 
Рис. 4.11. Распределение температур по сечению заготовки    

(нестационарная задача с учётом зависимости теплофизических 
коэффициентов от температуры) 

Выберите значение 100. 
Нажмите кнопку Apply.  

На дисплее появится распределение температур в этот 
момент времени. Оно выводится как распределение темпера-
тур по сечению в виде контурной картинки, раскрашенной 
различными   оттенками  в соответствии с температурой  
(рис. 4.12). 
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Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги вре-
мени. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.15,        

y: 0 –точка теплового центра сечения заготовки. 
Нажмите OK. 

Вы увидите окно с графиком переходного процесса в 
тепловом центре сечения (рис. 4.13). С помощью кнопки 
Zoom window можно увеличить любую часть графика. 
Можно на одном рисунке совместить графики распределе-
ния температур по толщине пластины для различных мо-
ментов времени. 

 
Рис. 4.12. Распределение температур по сечению заготовки в 

момент времени 100 с (нестационарная задача с учётом зависи-
мости теплофизических коэффициентов от температуры) 
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Откройте окно Postprocessing  > Domain Plot Parameters. 
В области Plot type включите радиокнопку 

Line/Extrusion Plot.  
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  

В поле Expression должно стоять T. В списке Boundary 
Selection должна быть выбрана подобласть 2. 

 
Рис. 4.13.  Изменение температуры теплового центра заго-

товки со временем 
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Нажмите кнопку Line settings.  
В открывшемся окне в списке Line color выберите 

Color, в списке Line style – Cycle, в списке Line marker – 
Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 4.14). 

 
Рис. 4.14.  Распределение температур по сечению заготовки 

для различных моментов времени. 
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4.7.  Нагрев осесимметричного  тела при граничных  
условиях  I рода  (нестационарный  режим  2D модель   

с  учётом зависимости теплофизических                        
коэффициентов от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева металла в виде короткого цилиндра. В ка-
честве граничного условия принята постоянная температу-
ра на всех сторонах его поверхности металла, а тепловой 
центр цилиндра совпадает с его геометрическим центром. 
Для нагреваемого металла надо выбрать режим Axial 
symmetry (2D). 

Рассмотрим модель цилиндра с радиусом 0,3 м и высо-
той 0,6 м из стали 20 с граничными условиями I рода на по-
верхности, тепловой центр у которого совпадает с геомет-
рическим. Температура внешних сторон короткого цилинд-
ра равна 1000 °С. Начальная температура нагрева   273 К. 
Время нагрева цилиндра 1000 с. Зависимость теплофизиче-
ских свойств стали 20 представлена в табл. 4.5. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator.  
Выберите в списке Space Dimension Axial symmetry (2D).  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Steady-state 
analysis. Нажмите OK.  

Откроется рабочая область.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > Rectangle.  
В открывшемся окне введите координаты радиуса ци-

линдра в поле Coordinates.  
Радиус цилиндра 30 см, высота 60 см. Введите в поле 

Width цифру 0.3, а в поле Heigh 0.6. 
Нажмите OK. В рабочей области слева оси r появится 

половина сечения цилиндра, названная по умолчанию R1. 
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Это же окно можно открыть, если щелкнуть на кнопке 
Rectangle при нажатой клавише Shift.  

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  
Задание физических установок, граничных условий, 

генерация сетки и расчёт в этом примере ничем не отли-
чаются от предыдущего примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур внутри цилиндра (рис. 4.15). 

 
Рис. 4.15. Распределение температур по сечению цилиндра (не-
стационарная задача с учётом зависимости теплофизических 

коэффициентов от температуры) 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
цилиндра равна 523,5 К.  
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4.8.  Нагрев   тела   при   граничных   условиях  I  рода 
(нестационарный режим 3D модель) 

Режим предназначен для расчета нагрева заготовки (куба, 
параллелепипеда), у которой все размеры одного порядка. В 
качестве граничного условия принята постоянная температура 
на пяти гранях заготовки, а на одной грани приняты условия 
адиабаты. Для нагреваемой заготовки надо выбрать режим 3D. 

Рассмотрим модель заготовки в виде куба с гранич-
ными условиями I рода у пяти сторон и II рода (условия 
адиабаты) с одной стороны. Температура внешних сторон 
равна 1000 °С. Начальная температура нагрева 273 К. Раз-
мер ребра куба равен 0,5 м. Время нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 3D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient 
analysis. Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Block.  
В открывшемся окне Block найдите область Length 

(Длина) и введите  0.5 в поля x, y, z. 
Нажмите OK. 

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в послед-
ней версии программы оно вызывается клавишей F8). 

В Subdomain selection выберите единственную подоб-
ласть 1. В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с табл. 4.10. 
В остальных полях оставьте нулевые значения. 
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Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле Temperature. 
Нажмите OK. 

Таблица 4.10.                 Свойства материала 

№ 
по-
доб
лас-
ти 

Размер 
грани 

квадра-
та 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см Сталь 38.67 7850 608.3 0 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл. 4.11. 

Таблица 4.11.                  Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты 

ГУ 

1 Среда–сталь Temperature T0=1273 К 
2 Среда–сталь Temperature T0=1273 К 
3 Среда–сталь Thermal insulation  
4 Среда–сталь Temperature T0=1273 К 
5 Среда–сталь Temperature T0=1273 К 
6 Среда–сталь Temperature T0=1273 К 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . 
По умолчанию будет сгенерировано 17035 конечных эле-
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ментов. Чтобы увеличить количество элементов, надо на-

жать кнопку  (Mesh > Refine Mesh). При необходимо-
сти её можно нажать несколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 

После работы решателя в главном окне будет выведе-
но распределение температур в виде срезов по толщине 
куба (рис. 4.16).  

По результатам расчета видно, что при условиях не-
стационарного режима нагрева с постоянными теплофизи-
ческими коэффициентами температура теплового центра 
(средний срез для куба) равна 460,7 К. 

4.9.  Нагрев тела  при граничных  условиях I рода  
(нестационарный     режим   3D  модель    с    учётом      

зависимости    теплофизических  коэффициентов         
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева заготовки, у которой размеры сторон име-
ют одинаковый порядок (куб, параллелепипед). В качестве 
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граничного условия принята постоянная температура на 
пяти сторонах заготовки, а на одной стороне – условия 
адиабаты. Для нагреваемого материала надо выбрать ре-
жим 3D. 

Рассмотрим модель заготовки в виде куба с граничны-
ми условиями I рода у пяти сторон и II рода (условия адиа-
баты) с одной стороны. Температура  внешних  сторон 
равна 1000 °С. Начальная температура нагрева 273 К. Реб-
ро квадрата равно 0,5 м. Время нагрева 1000 с. Зависи-
мость теплофизических свойств стали 20 представлена в 
табл. 4.12. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляется таким образом. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
В Functions name дайте название зависимой перемен-

ной k, радиокнопкой выберите Interpolation, а в списке 
Use data from отметьте Table и нажмите OK. 

Появляется диалоговое окно Function (рис. 4.12). 
В диалоговом окне Function definition в списке 

Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation.  
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Рис. 4.16. Распределение температур по сечению заготовки    

(нестационарная задача) 

Затем введите значения в столбцы для x температуры  в 
f (x) зависимых переменных k в соответствии с табл. 4.5. 

Затем повторите все действия для c и rho. 
После окончания нажмите OK.  

Свойства подобласти 
Теперь можно задать физические свойства материала 

пластины.  
Откройте окно Physics>Subdomain Settings… (в по-

следней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функцию от 

температуры в соответствии с табл. 4.9. 
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Таблица 4.12.                    Свойства материала 

№ 
по-
доб-
лас-
ти 

Размер 
грани 

квадра-
та 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см Сталь k(T) rho(T) c(T) 0 

В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 4.17). 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
пластины равна 546,3 К. Произошло уточнение температу-
ры центра на 85,6 К, или на 15,7 %. 

В главном окне (рис. 4.17) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, необхо-
димы следующие действия. 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 
Здесь можно выбрать значение времени, для которого 

необходимо посмотреть распределение. 
Выберите значение 100. 
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Нажмите кнопку Apply. Вы увидите распределение 
температур в этот момент времени (рис. 4.18).  

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги вре-
мени. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.25, y: 

0.25, z: 0 – точка теплового центра заготовки. 
Нажмите OK. Вы увидите окно с графиком переход-

ного процесса в тепловом центре заготовки (рис. 4.19). С 
помощью кнопки Zoom window можно увеличить любую 
часть графика. 

  

 
Рис. 4.17. Распределение температур по сечению заготовки    

(нестационарная задача с учётом зависимости теплофизических 
коэффициентов от температуры) 
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Рис. 4.18. Распределение температур по сечению заготовки в 

момент времени 100 с (нестационарная задача с учётом зависи-
мости теплофизических коэффициентов от температуры) 

Можно на одном рисунке совместить графики распре-
деления температур по толщине пластины для различных 
моментов времени. 

Откройте окно Postprocessing > Domain Plot 
Parameters, вкладку General. 

В области Plot type включите радиокнопку Surfase Plot.  
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Surfase, отметьте радиокнопку 
Surfase Plot. 

В области Boundary selection выберите 3. 
Нажмите OK в окне Domain Plot Parameters. Откроется 
трёхмерный график (рис. 4.20). 
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Рис. 4.19. Изменение температуры теплового центра заго-

товки со временем 

 
Рис. 4.20.  Распределение температур по сечению заготовки 

для различных моментов времени 
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5. Нагрев изделий при граничных условиях     
II рода 

5.1.  Нагрев  тела   при   граничных   условиях II рода  
(нестационарный режим 1D модель) 

Ранее было описано решение задач нагрева для гра-
ничных условий I рода, теперь решим эти же задачи для 
условий II рода. 

Режим предназначен для расчета нагрева листа материала 
с толщиной, на порядок меньшей двух других размеров. В ка-
честве граничного условия принят постоянный тепловой поток 
на поверхность металла, а со стороны теплового центра – усло-
вия адиабаты. Для нагреваемой пластины выбираем режим 1D. 

Рассмотрим модель однослойной пластины с гранич-
ными условиями II рода с одной стороны и II рода (усло-
вия адиабаты) c другой. Удельный тепловой поток с внеш-
ней стороны пластины равен 146 000 Вт/м2. Время нагрева 
пластины 1000 с. 

Действия для навигатора моделей для задания геомет-
рии и физических установок производятся в соответствии 
с разд. 4.2. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7).  
В Boundary selection выберите номер границы. В рабочей 

области соответствующая граница выделяется красным.  
Введите граничные условия в соответствии с табл. 5.1. 

Таблица 5.1.                    Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты 

ГУ 

1 Среда–сталь Heat flux q0=146000 Вт/м2 

2 Сталь–среда Thermal insulation  
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В нашем случае можно использовать линейный реша-
тель, так как все физические свойства и коэффициенты 
приняты не зависящими от температуры.  

Нажмите OK. 
Генерация сетки ничем не отличается от предыдущих пунк-

тов. Установки для расчёта повторите, как в разд. 4.2.  
ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины  (рис. 5.1).  

 
Рис. 5.1. Распределение температур по толщине пластины в 

конце нагрева (нестационарная задача) 

По результатам расчета в конце нагрева температура 
на поверхности пластины получилась 704,5 К, а темпера-
тура теплового центра 515,9 К. 
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5.2.   Нагрев   тела  при  граничных  условиях  II  рода   
(нестационарный     режим   1D    модель    с   учётом 

зависимости        теплофизических      свойств                
от   температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева листа металла с толщиной, на порядок 
меньшей двух других размеров. В качестве граничного усло-
вия принята постоянная температура на поверхности метал-
ла, а со стороны теплового центра – условия адиабаты. Для 
нагреваемой пластины надо выбрать режим 1D. 

Рассмотрим модель однослойной пластины из стали 
20 с граничными условиями II рода с одной стороны и II 
рода (условия адиабаты) c другой. Удельный тепловой по-
ток с внешней стороны пластины равен 146 000 Вт/м2. 
Время нагрева пластины 1000 с. 

 Зависимость теплофизических свойств стали 20 пред-
ставлена в таблице 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляют таким образом. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New 

(рис. 5.3). 
В Functions name дайте последовательно названия за-

висимых переменных k, c, rho , радиокнопкой выберите 
Interpolation, а в списке Use data from отметьте Table и 
нажмите OK. 

Появляется диалоговое окно Function (рис. 4.4). 
В диалоговом окне Function definition, в списке 

Interpolation metod выберите Linear. 
В списке  Extrapolation metod подставьте  

Extrapolation. 
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Затем введите значения в столбцы для x температуры в  f (x) 
зависимых переменных k, c, rho в соответствии с табл. 4.5. 

После окончания нажмите OK.  
Свойства подобласти 
Теперь можно задать физические свойства материала 

пластины.  
Откройте окно Physics > Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функции от тем-

пературы в соответствии с табл. 4.6. 
В остальных полях оставляем нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 5.2). 
По результатам расчета видно, что температура в кон-

це нагрева на  поверхности равна 747,2 К, а в тепловом 
центре пластины – 681,7 К. Произошло уточнение темпе-
ратуры на поверхности в конце нагрева на 42,7 К, или на     
6,3 %, а теплового центра на 165,8 К, или на 32,3 %. 

После работы решателя в главном окне (рис. 5.2) бу-
дет выведено распределение температур по толщине стен-
ки для момента времени 1000 с. Для того чтобы увидеть 
распределение температур по толщине пластины в другие 
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моменты времени, необходимо выполнить следующие 
действия: 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 

Здесь можно выбрать значение времени, для которого не-
обходимо посмотреть распределение. 

Выберите значение 300. 
Нажмите кнопку Apply.  
Вы увидите распределение температур в этот момент 

времени. По умолчанию оно выводится в виде черной ли-
нии.  

Выберите вкладку Line в области Line Color, переклю-
чите радиокнопку из Uniform Color (Неизменный цвет) в 
значение Use expression to color lines (Используйте вы-
ражение для расцветки линий). Тогда распределение 
температур будет более наглядным. 

 
Рис. 5.2.  Распределение  температур  по    толщине   стенки   

(нестационарная задача с учётом зависимости теплофизических 
свойств от температуры) 
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Теперь перейдите во вкладку Animate (Анимация). 
Здесь можно выбрать формат и разрешение выходного 
файла и период времени, для которого создается анимация. 

Проверьте, что выбраны все шаги времени. Для того 
чтобы выделить все шаги, выделите один из них и нажмите 
Ctrl+A. 

Нажмите кнопку Start Animation. Подождите около 
минуты, пока будет создаваться анимация. После этого вы 
можете просмотреть анимацию и сохранить AVI или MOV 
файл.  

Закройте окно с анимацией и нажмите OK. 
Теперь откройте окно Postprocessing > Cross-Section 

Plot Parameters.  
Во вкладке General проверьте, что выбраны все шаги времени. 
Затем выберите вкладку Point. 
В поле Coordinates х: выберите значения 0 и 0.1 – точки 

на поверхности и тепловом центре пластины. 
Нажмите OK. Вы увидите окно с графиком переходного 

процесса в тепловом центре пластины (рис.5.3). С помо-
щью кнопки Zoom window можно увеличить любую часть 
графика.Можно на одном рисунке совместить графики 
распределения температур по толщине пластины для раз-
личных моментов времени. 

Откройте окно Postprocessing>Domain Plot Parameters. 
В области Plot type включите радиокнопку 

Line/Extrusion Plot. 
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  
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Рис. 5.3. Изменение температуры на поверхности и в центре 

пластины со временем 

В поле Expression должно стоять T. В списке Subdomain 
Selection должна быть выбрана подобласть 1. По умолчанию 
после нажатия ОК будут выведены разноцветные сплош-
ные линии, без «легенды» – это неудобно при печати. По-
этому нажмите кнопку Line settings. 

В открывшемся окне в списке Line color выберите 
Color, в списке Line style – Cycle, в списке Line marker – 
Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 5.4). 
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Рис. 5.4. Распределение температур в стенке для различных мо-

ментов времени 

5.3. Нагрев осесимметричного тела при граничных     
условиях II рода (нестационарный режим 1D модель     

с учётом  зависимости  теплофизических  свойств        
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева металла, только в виде длинного цилинд-
ра. В качестве граничного условия принята постоянная 
температура на поверхности цилиндра, а тепловой центр 
совпадает с геометрическим центром. Для нагреваемого 
цилиндра надо выбрать режим  Axial symmetry (1D). 

Рассмотрим модель бесконечного цилиндра с радиу-
сом 0,1 м из стали 20 с граничными условиями II рода на 
поверхности, тепловой центр у которого совпадает с гео-
метрическим. Удельный тепловой поток с внешней сторо-
ны цилиндра равен 146 000 Вт/м2. Время нагрева цилинд-
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ра 1000 с. Зависимость теплофизических свойств стали 20 
представлена в табл. 4.5. 

Навигатор модели, задание геометрии и физических 
установок, граничных условий, генерация сетки и расчёт в 
этом примере ничем не отличаются от примера, приведён-
ного в разд. 4.4. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по радиусу цилиндра (рис. 5.5). 
По результатам расчета видно, что при условиях неста-

ционарного режима температура теплового центра цилиндра 
равна 827,0 К, а температура поверхности  – 1028,2 К. 

5.4. Нагрев  тела при граничных   условиях  II рода  
(нестационарный режим 2D модель) 

Режим предназначен для расчета нагрева металла с сече-
нием, у которого размеры одного порядка, а длина на порядок 
больше сторон сечения. В качестве граничного условия при-
нят постоянный тепловой поток на трёх гранях  по сечению 
металла, а на одной стороне – условия адиабаты. Для нагре-
ваемого металла надо выбрать режим 2D. 

Рассмотрим модель заготовки с сечением в виде квад-
рата с граничными условиями II рода с трёх сторон 
(q=const) и II рода (условия адиабаты) с одной стороны. Те-
пловой поток с внешних сторон равен 146 000 Вт/м2. На-
чальная температура нагрева 273 К. Сторона сечения заго-
товки в виде квадрата равна 0,3 м. Время  нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 2D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient   
analysis.  Нажмите OK. 
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Рис. 5.5. Распределение температур от центра к поверхности  

цилиндра при нагреве в момент времени 1000 с (нестационарная 
задача с учётом зависимости теплофизических свойствот темпе-

ратуры) 
ЗАДАНИЕ ГЕОМЕТРИИ  

Выберите пункт меню Draw>Specify Objects>Rectangle.  
В открывшемся окне Rectangle, найдите область Size и 

введите  0.3 в поле Width (Ширина), затем введите 0.3 в 
поле Height (Высота). 

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  
ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в послед-
ней версии программы оно вызывается клавишей F8). 
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В Subdomain selection выберите единственную подоб-
ласть. В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с 
табл. 5.7. 

В остальных полях оставте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. В рабочей 

области соответствующая граница выделяется красным. 
Введите граничные условия в соответствии с табл. 5.2. 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите сет-

ку командой Mesh > Initialize Mesh или кнопкой . 
Таблица 5.2.                       Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Среда–сталь Heat flux q0=146000 Вт/м2 

2 Среда–сталь Thermal 
insulation  

3 Среда–сталь Heat flux q0=146000 Вт/м2 

4 Сталь–среда Heat flux q0=146000 Вт/м2 

По умолчанию будет сгенерировано 928 конечных 
элементов. Чтобы увеличить количество элементов, надо 

нажать кнопку  [Mesh > Refine Mesh]. При необходи-
мости её можно нажать несколько раз.  
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РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 5.6).  

 
Рис. 5.6. Распределение температур по сечению заготовки (не-

стационарная задача) 
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По результатам расчета видно, что при условиях неста-
ционарного режима нагрева с постоянными теплофизиче-
скими коэффициентами температура теплового центра в 
квадратном сечении равна 386,5 К, а самые разогретые 
точки будут в координатах 0., 0.3 и 0.3, 0.3 с температурой 
1065 К. 

5.5. Нагрев  тела при  граничных условиях II рода 
(нестационарный   режим   2D модель  с   учётом  
зависимости  теплофизических  коэффициентов     

от температуры) 
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева металла с прямоугольным сечением и дли-
ной, на порядок большей сторон сечения. В качестве гра-
ничного условия принят постоянный тепловой поток на 
трёх сторонах сечения металла, а на одной стороне – усло-
вия адиабаты. Для нагреваемого металла надо выбрать ре-
жим 2D. 

Рассмотрим модель заготовки с сечением в виде квад-
рата с граничными условиями II рода с трёх сторон 
(q=const) и II рода (условия адиабаты) с одной стороны. Те-
пловой поток внешних сторон равен 146 000 Вт/м2. На-
чальная температура нагрева 273 К. Сторона сечения квад-
рата равна 0,3 м. Время нагрева 1000 с. Зависимость тепло-
физических свойств стали 20 представлена в табл. 5.5. 

Геометрическая модель в этом  примере расчёта стро-
ится так же, как и в предыдущем примере. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляют следующим образом. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
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В Functions name дайте название зависимой перемен-
ной k, радиокнопкой выберите Interpolation, а в списке 
Use data from отметьте Table и нажмите OK. 

Появляется диалоговое окно Function (рис. 4.9). 
В диалоговом окне Function definition в списке 

Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation. 

Затем введите значения в столбцы для x температуры в  
f (x) зависимых переменных k в соответствии с табл. 4.5. 

Затем повторите все действия, начиная со второго пунк-
та, для c, rho. 

После окончания нажмите OK.  
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в послед-
ней версии программы оно вызывается клавишей F8).  

В Subdomain selection выберите номер пластины. В ра-
бочей области эта  область выделится красным.   

Введите в поля свойства для стали как функции от тем-
пературы в соответствии с табл. 4.9. 

В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере такие же, как в предыдущем. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 5.7). 
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Рис. 5.7. Распределение температур по сечению заготовки (не-
стационарная задача с учётом зависимости теплофизических 

коэффициентов от температуры) 

По результатам расчета видно, что при условии неста-
ционарного режима нагрева температура теплового центра 
пластины равна 468,0 К. Произошло уточнение температу-
ры центра на 81,5 К (17,4 %). Самые разогретые точки по 
результатам расчёта имеют температуру 1109,3 К, что на 
44,3 К (4 %) больше, чем в предыдущем примере. 

В главном окне (рис. 5.7) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, необхо-
димо выполнить следующие действия: 

Откройте окно Postprocessing > Plot Parameters.  
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Во вкладке General раскройте список Solution at time. 
Здесь можно выбрать значение времени, для которого не-
обходимо посмотреть распределение. 

Выберите значение 100. 
Нажмите кнопку Apply. Вы  увидите  распределение 

температур в этот момент времени. Оно  выводится  как 
распределение температур по  сечению в  виде контурной 
картинки,  раскрашенной различными  оттенками  в соот-
ветствии с температурой (рис. 5.8).  

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что шаги времени вы-
браны. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.15, y: 0 – 

точка теплового центра сечения заготовки, через пробел 
наберите значения для x: 0., y: 3.0 – самая разогретая точка 
на поверхности металла. 

Нажмите OK. Вы увидите окно с графиком переходного 
процесса в тепловом центре сечения (рис.5.9). С помощью 
кнопки Zoom window можно увеличить любую часть гра-
фика. Можно на одном рисунке совместить графики рас-
пределения температур по толщине пластины для различ-
ных моментов времени. 

Откройте окно Postprocessing > Domain Plot 
Parameters. 

В области Plot type включите радиокнопку 
Line/Extrusion Plot.  

В области Solutions to use (Используемые решения) 
раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 
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Рис. 5.8. Распределение температур по сечению заготовки в мо-
мент времени 100 с  (нестационарная задача с учётом зависимо-

сти теплофизических коэффициентов от температуры) 

 
Выберите вкладку Line/Extrusion в области Plot type, 

отметьте радиокнопку Line Plot.  
В поле Expression должно стоять T. В списке Boundary 

Selection должна быть выбрана подобласть 2 (граничные 
условия для адиабаты). 

Затем нажмите кнопку Line settings.  
В открывшемся окне в списке Line color выберите 

Color. В списке Line style выберите Cycle. В списке Line 
marker выберите Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
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Рис. 5.9.  Изменение  температуры  на  поверхности  в  самой 
разогретой точке и в тепловом центре заготовки со временем 

Нажмите OK в окне Domain Plot Parameters. Откроет-
ся график (рис. 5.10). 

5.6.  Нагрев    осесимметричного  тела при  граничных       
условиях  II   рода   (нестационарный режим 2D модель 
с учётом зависимости теплофизических коэффициентов 

от температуры) 
Режим предназначен для расчета нагрева металла в 

виде короткого цилиндра. В качестве граничного условия 
принят постоянный тепловой поток на всех сторонах по-
верхности металла, а тепловой центр цилиндра совпадает с 
его геометрическим центром. Для нагреваемого металла 
надо выбрать режим  Axial symmetry (2D). 
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Рис. 5.10. Распределение  температур  на стороне  сечения      
заготовки с условиями адиабаты для различных моментов     

времени 

Рассмотрим модель цилиндра с радиусом 0,3 м и высотой 
0,6 м из стали 20 с граничными условиями II рода на поверх-
ности, тепловой центр у которого совпадает с геометриче-
ским. Тепловой поток на внешние стороны короткого цилинд-
ра равен 146 000 Вт/м2. Начальная температура нагрева 273 К. 
Время нагрева цилиндра 1000 с. Зависимость теплофизиче-
ских свойств стали 20 представлена в табл. 4.5. 

Навигатор модели, задание геометрии и физических 
установок, граничных условий, генерация сетки и расчёт в 
этом примере ничем не отличаются от примера, приведён-
ного в разд. 4.7. 
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ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур по вертикальному сечению 
цилиндра (рис. 5.11). 

 
Рис. 5.11. Распределение температур по сечению заготовки    

(нестационарная задача с учётом зависимости теплофизических 
коэффициентов от температуры) 

По результатам расчета видно, что при условии неста-
ционарного режима нагрева температура теплового центра 
короткого цилиндра равна 370,3 К. Самые разогретые точ-
ки цилиндра по результатам расчёта имеют температуру 
1179,0 К. 
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5.7.  Нагрев  тела  при  граничных   условиях   II рода  
(нестационарный режим 3D модель) 

Режим предназначен для расчета нагрева заготовки 
(куба, параллелепипеда), у которой все размеры одного 
порядка. В качестве граничного условия принят постоян-
ный тепловой поток на пяти гранях заготовки, а на одной 
грани – условия адиабаты. Для нагреваемой заготовки надо 
выбрать режим 3D. 

Рассмотрим модель заготовки в виде куба с гранич-
ными условиями II рода у пяти сторон и II рода (условия 
адиабаты) с одной стороны. Тепловой поток на внешних 
сторонах равен  146 000 Вт/м2. Начальная температура на-
грева 273 К. Ребро квадрата 0,5 м. Время нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 3D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient 
analysis. 

Нажмите OK.  
ЗАДАНИЕ ГЕОМЕТРИИ  

Выберите пункт меню Draw > Block.  
В открывшемся окне Block найдите область Length 

(Длина) и введите  0.5 в поля x, y, z. 
Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в послед-
ней версии программы оно вызывается клавишей F8). 
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В Subdomain selection выберите единственную подоб-
ласть.  В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с 
табл. 5.10. 

В остальных полях оставте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics>Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл. 5.3. 

Таблица 5.3.                        Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Среда–сталь Heat flux q0=146000 Вт/м2 

2 Среда–сталь Heat flux q0=146000 Вт/м2 

3 Среда–сталь Thermal 
insulation  

4 Среда–сталь Heat flux q0=146000 Вт/м2 

5 Среда–сталь Heat flux q0=146000 Вт/м2 

6 Среда–сталь Heat flux q0=146000 Вт/м2 

Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh>Initialize Mesh или кнопкой . По 
умолчанию будет сгенерировано 17035 конечных элемен-
тов. Чтобы увеличить количество элементов, надо нажать 
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кнопку  [Mesh>Refine Mesh]. При необходимости её 
можно нажать несколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  [Solve>Solve 
Problem].  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур в виде срезов по толщине 
куба (рис. 5.12).  

По результатам расчета видно, что при условиях не-
стационарного режима нагрева с постоянными теплофизи-
ческими коэффициентами температура теплового центра 
(средний срез для куба) 309,0 К, а максимально разогретые 
точки вершины куба 1263,6 К. 

5.8. Нагрев  тела при  граничных  условиях II  рода  
(нестационарный   режим  3D  модель  с  учётом 
зависимости  теплофизических  коэффициентов   

от температуры) 
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева заготовки, у которой размеры сторон име-
ют одинаковый порядок (куб, параллелепипед). В качестве 
граничного условия принят постоянный тепловой поток на 
пяти сторонах заготовки, а на одной стороне – режим ус-
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ловия адиабаты. Для нагреваемого материала надо выбрать 
режим 3D. 

 
Рис. 5.12. Распределение температур по сечениям заготовки  

(нестационарная задача) 

Рассмотрим модель заготовки в виде куба с гранич-
ными условиями II рода у пяти сторон и II рода (условия 
адиабаты) с одной стороны. Тепловой поток на внешних 
сторонах 146 000 Вт/м2. Начальная температура нагрева 
273 К. Ребро квадрата 0,5 м. Время нагрева 1000 с. Зависи-
мость теплофизических свойств стали 20 представлена в 
табл. 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляется следующим образом. 
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Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
В Functions name дайте название зависимой переменной k, 

радиокнопкой выберите Interpolation, а в списке Use data 
from отметьте Table и нажмите OK. 

Появляется диалоговое окно Function (рис. 4.9). 
В диалоговом окне Function definition в списке 

Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation 

Затем введите значения в столбцы для x температуры в  
f (x) зависимых переменных k в соответствии с табл. 4.5. 

Затем повторите все действия, начиная с названия зави-
симой переменной, для c, rho. 

После окончания нажмите OK.  

Свойства подобласти 
Откройте окно Physics > Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функции от тем-

пературы в соответствии с табл. 4.9. 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 
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ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 5.13). 

 
Рис. 5.13. Распределение температур по сечению заготовки (не-

стационарная задача с учётом зависимости теплофизических 
коэффициентов от температуры) 

По результатам расчета видно, что при условии неста-
ционарного режима нагрева температура теплового центра 
375,7 К. Произошло  уточнение температуры центра на 
66,7 К или на 17,8 %. Самая разогретая точка нагреваемой 
заготовки равна 1357,5 К. Это на 93,9 К, или на 6,9 % 
больше, чем в предыдущем примере. 

В главном окне (рис. 5.13) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
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по сечению заготовки в другие моменты времени, необхо-
димо сделать следующее. 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 

Здесь можно выбрать значение времени, для которого хо-
тите посмотреть распределение. 

Выберите значение 100. 
Нажмите кнопку Apply. Вы увидите распределение 

температур в этот момент времени (рис. 5.14).  
Откройте окно Postprocessing > Cross-Section Plot 

Parameters.  
Во вкладке General проверьте, что выбраны шаги вре-

мени. 
Выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.25,       y: 

0.25, z: 0. – точка теплового центра заготовки. Через про-
бел для x: наберите 0.5, для y: 0.5, для z: 0.5 – одна из наи-
более разогретых точек заготовки. 

Нажмите OK. Вы увидите окно с графиком переходного 
процесса в тепловом центре заготовки (рис. 5.15). 

С помощью кнопки Zoom window можно увеличить 
любую часть графика. Можно на одном рисунке совмес-
тить графики распределения температур по толщине пла-
стины для различных моментов времени. 

 Откройте окно Postprocessing > Domain Plot 
Parameters меню General. 

В области Plot type включите радиокнопку Surfase Plot.  
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Surfase, отметьте радиокнопку 
Surfase Plot. 
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В области Boundary selection выберите 3. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся трёхмерный график (рис. 5.16). 
 

 
Рис. 5.14. Распределение температур по сечению заготовки        в 
момент времени 100 с  (нестационарная задача с учётом зависи-

мости теплофизических коэффициентов от температуры) 
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Рис. 5.15.  Изменение температуры на поверхности в самой     

разогретой точке и в тепловом центре заготовки со временем 

 
Рис. 5.16. Распределение температур на гране заготовки с гра-

ничными условиями (q=const) для различных моментов времени 
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6. Нагрев изделий при граничных условиях    
III рода 

6.1.  Нагрев  тела  при  граничных  условиях  III рода  
(нестационарный режим 1D модель) 

Ранее было дано решение задач нагрева для гранич-
ных условий I и II родов, теперь решим эти же задачи для 
условий III рода. 

Режим предназначен для расчета нагрева листа мате-
риала с толщиной, на порядок меньшей двух других раз-
меров. В качестве граничного условия принята температу-
ра внешней среды и приведённый коэффициент теплоот-
дачи на поверхность металла, а со стороны теплового цен-
тра – режим условия адиабаты. Для нагреваемой пластины 
выбираем режим 1D. 

Рассмотрим модель однослойной пластины с гранич-
ными условиями III рода с одной стороны и II рода (усло-
вия адиабаты) c другой. Температура внешней среды 
(External temperature) с внешней стороны пластины равна 
Tinf = 1273 К, приведённый коэффициент теплоотдачи 
(Heat transfer coefficient) h = 300 Вт/(м2·К). Время 
нагрева пластины 1000 с.  

Действия для навигатора моделей для задания геомет-
рии и физических установок производятся в соответствии 
с разд. 4.2. 

Граничные условия  
Откройте окно Physics>Boundary Settings… (F7).  
В Boundary selection выберите номер границы.В рабо-

чей области соответствующая граница выделяется крас-
ным.  

Введите граничные условия в соответствии с табл. 6.1. 
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Таблица 6.1.                    Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

2 Сталь–среда Thermal 
insulation  

В нашем случае можно использовать линейный реша-
тель, так как все физические свойства и коэффициенты 
приняты не зависящими от температуры. 

Нажмите OK. 
Генерация сетки ничем не отличается от предыдущих пунк-

тов. Установки для расчёта повторите, как в разд. 5.2.  
ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 6.1).  

 
Рис. 6.1. Распределение температур по толщине пластины в 

конце нагрева (нестационарная задача) 
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По результатам расчета в конце нагрева температура 
на поверхности пластины 797,3 К, а температура теплового 
центра 602,8 К. 

6.2. Нагрев  тела  при  граничных условиях III рода  
(нестационарный    режим   1D  модель  с  учётом   

зависимости     теплофизических    свойств             
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева листа металла с толщиной, на порядок 
меньшей двух других размеров. В качестве граничного ус-
ловия принята температура внешней среды и приведённый 
коэффициент теплоотдачи на поверхность металла, а со 
стороны теплового центра – режим условия адиабаты. Для 
нагреваемой пластины надо выбрать режим 1D. 

Рассмотрим модель однослойной пластины из стали 
20 с граничными условиями III рода с одной стороны и II 
рода (условия адиабаты) c другой. Температура среды 
(External temperature) с  внешней стороны пластины 
равна Tinf = 1273 К, приведённый коэффициент 
теплоотдачи (Heat transfer coefficient) h = 300 Вт/(м2·К). 
Время нагрева пластины 1000 с. 

 Зависимость теплофизических свойств стали 20 пред-
ставлена в табл. 5.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Для задания теплофизических свойств материала тре-

буется следующее. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New 

(рис. 4.3). 
В Functions name дайте последовательно названия за-

висимых переменных k, c, rho , радиокнопкой выберите 
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Interpolation, а в списке Use data from отметьте Table и 
нажмите OK. 

Появляется диалоговое окно Function (рис. 4.4). 
В диалоговом окне Function definition в списке 

Interpolation metod выберите Linear. 
В списке  Extrapolation metod подставьте  

Extrapolation. 
Введите значения в столбцы для x температуры в f (x) 

зависимых переменных k, c, rho в соответствии с табл. 4.5. 
После окончания нажмите OK.  

Свойства подобласти 
Теперь можно задать физические свойства материала 

пластины.  
Откройте окно Physics>Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функции от тем-

пературы в соответствии с табл. 4.6. 
В остальных полях оставляем нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя  в главном окне будет  выве-

дено распределение температур по толщине пластины  
(рис. 6.2). 
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По результатам расчета видно, что температура в кон-
це нагрева на  поверхности равна 830,7 К, а в тепловом 
центре пластины – 664,3 К. Произошло уточнение темпе-
ратуры на поверхности в конце нагрева на 33,4 К, или на     
4,0 %, а теплового центра на 61,5 К, или на 9,3 %. 

После работы решателя в главном окне (рис. 6.2) бу-
дет выведено распределение температур по толщине пла-
стины для момента времени 1000 с. Для того чтобы уви-
деть распределение температур по толщине пластины в 
другие моменты времени, необходимо сделать следующее 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 

Здесь можно выбрать значение времени, для которого не-
обходимо посмотреть распределение. 

Выберите значение 300. 

 
Рис. 6.2. Распределение температур по толщине стенки           

(нестационарная задача с учётом зависимости теплофизических 
свойств от температуры) 

Нажмите кнопку Apply. Вы увидите распределение 
температур в этот момент времени. По умолчанию оно вы-
водится в виде черной линии.  



125 

Выберите вкладку Line в области Line Color, переклю-
чите радиокнопку из значения Uniform Color (Неизмен-
ный цвет) на Use expression to color lines (Используйте 
выражение для расцветки линий). Тогда распределение 
температур будет более наглядным. 

Теперь перейдите во вкладку Animate (Анимация). 
Здесь можно выбрать формат и разрешение выходного 
файла и период времени, для которого создается анимация. 

Проверьте, что выбраны все шаги времени. Для того 
чтобы выделить все шаги,  выделите один из них и нажми-
те Ctrl+A. 

Нажмите кнопку Start Animation. Подождите около 
минуты, пока будет создаваться анимация. После этого вы 
можете просмотреть анимацию и сохранить AVI- или 
MOV- файл.  

Закройте окно с анимацией и нажмите OK. 
Откройте окно Postprocessing > Cross-Section Plot 

Parameters.  
Во вкладке General проверьте, что выбраны все шаги 

времени. 
Выберите вкладку Point. 
В поле Coordinates х: выберите значения 0 и 0.1 – точки 

на поверхности и тепловом центре пластины. 
Нажмите OK. Вы увидите окно с графиком переходного 

процесса в тепловом центре пластины (рис. 6.3). С помо-
щью кнопки Zoom window можно увеличить любую часть 
графика. Можно на одном рисунке совместить графики 
распределения температур по толщине пластины для раз-
личных моментов времени. 

Откройте окно Postprocessing > Domain Plot 
Parameters. 

В области Plot type включите радиокнопку 
Line/Extrusion Plot. 
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В области Solutions to use (Используемые решения) 
раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие зна-
чения времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  

В поле Expression должно стоять T. В списке 
Subdomain Selection должна быть выбрана подобласть 1. 
По умолчанию после нажатия ОК будут выведены 
разноцветные сплошные линии, без «легенды» – это 
неудобно при печати. 

 
Рис. 6.3. Изменение температуры на поверхности и в центре 

пластины со временем 
Поэтому нажмите кнопку Line settings.  
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В открывшемся окне в списке Line color выберите 
Color, в списке Line style – Cycle, в списке Line marker – 
Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 6.4). 

 
Рис. 6.4. Распределение температур в стенке для различных мо-

ментов времени 
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6.3.     Нагрев  осесимметричного тела  при  граничных     
условиях III  рода   (нестационарный режим 1D модель 

с   учётом    зависимости  теплофизических  свойств     
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева металла, только в виде длинного цилинд-
ра. В качестве граничного условия принята температура 
внешней среды и приведённый коэффициент теплоотдачи 
на поверхность металла, а тепловой центр совпадает с гео-
метрическим центром. Для нагреваемого цилиндра надо 
выбрать режим  Axial symmetry (1D). 

Рассмотрим модель бесконечного цилиндра с радиу-
сом 0,1 м из стали 20 с граничными условиями III рода на 
поверхности и II рода (условия адиабаты) в тепловом цен-
тре, который совпадает с геометрическим. Температура 
среды (External temperature) с внешней стороны пласти-
ны равна Tinf = 1273 К, приведённый коэффициент тепло-
отдачи (Heat transfer coefficient) h = 300 Вт/(м2·К). Время 
нагрева цилиндра 1000 с. Начальная температура нагрева 
273 К. Зависимость теплофизических свойств стали 20 
представлена в табл. 4.5. 

Навигатор модели, задание геометрии и физических 
установок, граничных условий, генерация сетки и расчёт в 
этом примере ничем не отличаются от примера, приведён-
ного в разд. 4.4. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур по радиусу цилиндра       
(рис. 6.5). 

По результатам расчета видно, что при условиях неста-
ционарного режима температура теплового центра цилинд-
ра равна 868,2 К, а температура поверхности – 995,8 К. 
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Рис. 6.5. Распределение температур от центра к поверхности ци-
линдра при нагреве в момент времени 1000 с (нестационарная 
задача с учётом зависимости теплофизических свойств от тем-

пературы) 

6.4.  Нагрев  тела  при  граничных  условиях  III рода  
(нестационарный режим 2D модель) 

Режим предназначен для расчета нагрева металла с се-
чением, у которого размеры одного порядка, а длина на 
порядок больше сторон сечения. В качестве граничного 
условия принята температура внешней среды и приведён-
ный коэффициент теплоотдачи на поверхность металла на 
трёх гранях сечения металла, а условия адиабаты – на од-
ной стороне. Для нагреваемого металла надо выбрать ре-
жим 2D. 

Рассмотрим модель заготовки с сечением в виде квадра-
та с граничными условиями III рода с трёх сторон (h=const и 
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Tinf = const) и II рода (условия адиабаты) с одной стороны. 
Температура внешней среды (External temperature) с трёх 
сторон равна Tinf = 1273 К, приведённый коэффициент тепло-
отдачи (Heat transfer coefficient) h = 300 Вт/(м2·К). Началь-
ная температура нагрева 273 К. Сторона сечения квадрата  
0,3 м. Время нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 2D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient 
analysis. Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > 

Rectangle.  
В открывшемся окне Rectangle найдите область Size и 

введите  0.3 в поле Width (Ширина), затем введите 0.3 в 
поле Height (Высота). 

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  
ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в последней 
версии программы оно вызывается  клавишей F8). 

В Subdomain selection выберите единственную подоб-
ласть 1. В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с табл. 4.7. 
В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 
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Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. В рабо-

чей области соответствующая граница выделяется крас-
ным. 

Введите граничные условия в соответствии с табл. 6.2. 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите сет-

ку командой     Mesh     >  Initialize Mesh  или  кнопкой  

.По умолчанию будет сгенерировано 928 конечных 
элементов. Чтобы увеличить количество элементов, надо 

нажать кнопку  (Mesh > Refine Mesh). При необходи-
мости её можно нажать несколько раз. 
Таблица 6.2.                Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

2 Среда–сталь Thermal 
insulation  

3 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

4 Сталь–среда Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
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На вкладке General в первом поле Times вместо 0:0.1:1 
введите 0:20:1000.  

Нажмите OK. 

Нажмите кнопку Solve (Решать)  [Solve > Solve 
Problem].  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по сечению заготовки (рис. 6.6). 
По результатам расчета видно, что при условиях не-

стационарного режима нагрева с постоянными теплофизи-
ческими коэффициентами температура теплового центра в 
квадратном сечении равна 433,8 К, а самые разогретые 
точки будут в координатах 0., 0.3 и 0.3, 0.3 с температурой 
1006,4 К. 

 
Рис. 6.6. Распределение температур по сечению заготовки (не-

стационарная задача) 
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6.5. Нагрев  тела  при  граничных  условиях   III  рода  
(нестационарный     режим   2D   модель   с   учётом   

зависимости      теплофизических      коэффициентов   
от температуры) 

Режим предназначен, как и в предыдущем случае, для 
расчета нагрева металла с прямоугольным сечением и дли-
ной, на порядок большей сторон сечения. В качестве гра-
ничного условия принята температура внешней среды и 
приведённый коэффициент теплоотдачи на поверхность 
металла на трёх сторонах сечения металла, а на одной сто-
роне – режим условия адиабаты. Для нагреваемого металла 
надо выбрать режим 2D. 

Рассмотрим модель заготовки с сечением в виде квад-
рата с граничными условиями III рода с трёх сторон 
(h=const и Tinf = const) и II рода (условия адиабаты) с од-
ной стороны. External temperature (Температура внеш-
ней среды)  с трёх сторон Tinf = 1273 К, Heat transfer 
coefficient (Приведённый коэффициент теплоотдачи) h 
= 300 Вт/(м2·К). Начальная температура нагрева 273 К. 
Сторона сечения квадрата 0,3 м. Время нагрева   1000 с. 
Зависимость теплофизических свойств стали 20 
представлена в табл. 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляется следующим образом. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
В Functions name дайте название зависимой перемен-

ной k, радиокнопкой выберите Interpolation, а в списке 
Use data from отметьте Table и нажмите OK. 

Появится диалоговое окно Function (рис. 4.9). 
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В диалоговом окне Function definition в списке 
Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation. 

Затем введите значения в столбцы для x температуры в  
f (x) зависимых переменных k в соответствии с табл. 4.5. 

Затем повторите все действия, начиная с названия зави-
симой переменной, для c, rho. 

После окончания нажмите OK.  
Свойства подобласти 
Теперь можно задать физические свойства материала 

пластины.  
Откройте окно Physics > Subdomain Settings… (в послед-

ней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины. В ра-

бочей области эта  область выделится красным.   
Введите в поля свойства для стали как функции от тем-

пературы в соответствии с табл. 4.9. 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 6.7). 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
пластины равна 525,4 К. Произошло уточнение температу-
ры центра на 91,6 К (17,4 %). Самые разогретые точки по 
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результатам расчёта имеют температуру 1023,6 К, что на 
17,2 К, или 1,7  %, больше, чем в предыдущем примере. 

В главном окне (рис. 6.6) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, необхо-
димы следующие действия. 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 
Здесь можно выбрать значение времени, для которого 

необходимо посмотреть распределение. 
Выберите значение 100. 

Нажмите кнопку Apply. Вы увидите распределение 
температур в этот момент времени. Оно выводится как рас-
пределение температур по сечению в виде контурной кар-
тинки, раскрашенной различными оттенками в соответствии 
с температурой (рис. 6.8). 

 
Рис. 6.7. Распределение температур по сечению заготовки (не-
стационарная задача с учётом зависимости теплофизических 

коэффициентов от температуры) 
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Рис. 6.8. Распределение температур по сечению заготовки в мо-
мент времени 100 с (нестационарная задача с учётом зависимо-

сти теплофизических коэффициентов от температуры) 

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги вре-
мени. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.15, y: 0 – 

точка теплового центра сечения заготовки, через пробел 
наберите значения для x: 0., y: 3.0 – самая разогретая точка 
на поверхности металла. 

Нажмите OK. Вы увидите окно с графиком переход-
ного   процесса    в  тепловом  центре  сечения  (рис. 6.9).  
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Рис. 6.9. Изменение температуры на поверхности в самой 

разогретой точке и в тепловом центре заготовки со временем 

С помощью кнопки Zoom window можно увеличить лю-
бую часть графика.  Можно  на  одном рисунке   совмес-
тить  графики распределения температур по толщине пла-
стины для различных моментов времени. 

Откройте окно Postprocessing > Domain Plot 
Parameters. 

В области Plot type включите радиокнопку 
Line/Extrusion Plot.  

В области Solutions to use (Используемые решения) 
раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 
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В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  

В поле Expression должно стоять T. В списке Boundary 
Selection должна быть выбрана подобласть 2 (граничные 
условия для адиабаты). 

Затем нажмите кнопку Line settings.  
В открывшемся окне в списке Line color выберите 

Color, в списке Line style – Cycle, в списке Line marker – 
Cycle. 

Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 6.10). 

 
Рис. 6.10. Распределение температур на стороне сечения заго-
товки с условиями адиабаты для различных моментов времени 
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6.6.  Нагрев осесимметричного тела  при  граничных      
условиях III  рода  (нестационарный режим  2D  модель 

с     учётом      зависимости        теплофизических         
коэффициентов от температуры) 

Режим предназначен для нагрева короткого цилиндра. 
В качестве граничного условия принята температура 
внешней среды и приведённый коэффициент теплоотдачи 
на поверхность металла, а тепловой центр совпадает с гео-
метрическим центром. Для нагреваемого цилиндра надо 
выбрать режим  Axial symmetry (2D). 

Рассмотрим модель цилиндра с радиусом 0,3 м и высо-
той 0,6 м из стали 20 с граничными условиями III рода на 
поверхности и II рода (условия адиабаты) в тепловом цен-
тре, который совпадает с геометрическим. External 
temperature (Температура среды) с внешней стороны 
цилиндра Tinf = 1273 К, Heat transfer coefficient 
(Приведённый коэффициент теплоотдачи) h = 300 
Вт/(м2·К). Время нагрева цилиндра 1000 с. Начальная 
температура нагрева 273 К. Время нагрева цилиндра 1000 с. 
Зависимость теплофизических свойств стали 20 
представлена в табл. 5.5. Навигатор модели, задание геометрии и физических 
установок, граничных условий, генерация сетки и расчёт в 
этом примере ничем не отличаются от примера, приведён-
ного в разд. 5.7. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено рас-

пределение температур по сечению вдоль цилиндра (рис. 6.11). 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
цилиндра равна 401,4 К. Самые разогретые точки по ре-
зультатам расчёта имеют температуру 1046,0 К. 
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Рис. 6.11. Распределение температур по сечению цилиндра 

вдоль в момент времени 1000 с (нестационарная задача с учётом 
зависимости теплофизических коэффициентов от температуры) 

6.7.   Нагрев  тела  при  граничных  условиях III рода  
(нестационарный режим 3D модель) 

Режим предназначен для расчета нагрева заготовки 
(куба, параллелепипеда). Все размеры одного порядка. В 
качестве граничного условия принята температура внеш-
ней среды и приведённый коэффициент теплоотдачи на 
поверхность металла на пяти гранях заготовки, а на одной 
грани – режим условия адиабаты. Для нагреваемой заго-
товки надо выбрать режим 3D. 

Рассмотрим модель заготовки в виде куба с гранич-
ными условиями III рода у пяти сторон  (h=const и 
Tinf=const) и II рода (условия адиабаты) с одной стороны. 
Температура внешней среды (External temperature) у пяти 
сторон Tinf = 1273 К, приведённый коэффициент теплоот-
дачи (Heat transfer coefficient) h = 300 Вт/(м2·К). Началь-
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ная температура нагрева 273 К. Ребро куба 0,5 м. Время 
нагрева 1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 3D.  
В Application Mode выберите режим COMCOL 

Multiphysics > Heat Transfer > Conduction > Transient 
analysis. Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Block.  
В открывшемся окне Block найдите область Length 

(Длина) и введите  0.5 в поля x, y, z. 
Нажмите OK.  

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в последней 
версии программы оно вызывается клавишей F8). 

В Subdomain selection выберите единственную подоб-
ласть.  В рабочей области она сразу выделится красным. 

Введите в поля свойства для стали в соответствии с 
табл. 5.10. 

В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
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В Boundary selection выберите номер границы. В рабо-
чей области соответствующая граница выделяется крас-
ным. 

Введите граничные условия в соответствии с табл. 6.3. 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh>Initialize Mesh или кнопкой . По 
умолчанию будет сгенерировано 17035 конечных элемен-
тов. Чтобы увеличить количество элементов, надо нажать 

кнопку  (Mesh > Refine Mesh). При необходимости её 
можно нажать несколько раз.  
Таблица 6.3.                   Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

2 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

3 Среда–сталь Thermal 
insulation  

4 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

5 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

6 Среда–сталь Heat flux h=300 Вт/(м2·K); 
Tinf = 1273 К 

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
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В списке Solver (Решатель) выберите Time dependent 
(Зависимый от времени). 

На вкладке General в первом поле Times вместо 0:0.1:1 
введите 0:20:1000.  

Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур в виде срезов по толщине 
куба (рис. 6.12). 

По результатам расчета видно, что при условиях не-
стационарного режима нагрева с постоянными теплофизи-
ческими коэффициентами температура теплового центра 
(средний срез для куба) 326,9 К, а максимально разогретые 
точки вершины куба 1077,0 К. 

 
Рис. 6.12. Распределение температур по сечениям заготовки  

(нестационарная задача) 
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6.8.  Нагрев  тела  при  граничных  условиях  III рода  
(нестационарный    режим    3D    модель   с    учётом 
зависимости    теплофизических    коэффициентов       

от температуры) 
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева заготовки, у которой размеры сторон име-
ют одинаковый порядок (куб, параллелепипед). В качестве 
граничного условия приняты температура внешней среды 
и приведённый коэффициент теплоотдачи на поверхность 
металла на пяти гранях заготовки, а на одной грани – усло-
вия адиабаты. Для нагреваемой заготовки надо выбрать 
режим 3D. 

Рассмотрим модель заготовки в виде куба с граничны-
ми условиями III рода у пяти сторон (h=const и Tinf = const) 
и II рода (условия адиабаты) с одной стороны. External 
temperature (Температура внешней среды) у пяти сторон 
Tinf = 1273 К, Heat transfer coefficient (Приведённый ко-
эффициент теплоотдачи) h = 300 Вт/(м2·К). Начальная 
температура нагрева 273 К. Ребро куба равно 0,5 м. Время 
нагрева 1000 с. Зависимость теплофизических свойств стали 
20 от температуры представлена в табл. 4.5. 

Геометрическая модель в этом  примере расчёта стро-
ится аналогично предыдущему примеру. 

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Зависимость теплофизических свойств от текущей 

температуры осуществляется следующим образом. 
Из меню Options выберите Functions. 
В диалоговом окне, которое появляется, нажмите New. 

Появляется диалоговое окно (рис. 4.3). 
В Functions name дайте название зависимой перемен-

ной k, радиокнопкой выберите Interpolation, а в списке 
Use data from отметьте Table и нажмите OK. 

Появляется диалоговое окно Function (рис. 4.9). 
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В диалоговом окне Function definition в списке 
Interpolation metod выберите Linear, а в списке  
Extrapolation metod – Extrapolation. 

Затем введите значения в столбцы для x температуры  в 
f (x)  зависимых  переменных  k в соответствии  с табл. 4.5. 

Затем повторите все действия, начиная с названия зави-
симой переменной, для c, rho. 

После окончания нажмите OK.  
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в по-
следней версии программы оно вызывается клавишей F8).  

В Subdomain selection выберите номер пластины. В ра-
бочей области эта  область выделится красным.   

Введите в поля свойства для стали как функции от тем-
пературы в соответствии с табл. 4.9. 

В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273 как начальное значение в поле 

Temperature. 
Нажмите OK. 

Задание граничных условий, генерация сетки и расчёт 
в этом примере ничем не отличаются от предыдущего 
примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 6.13). 
По результатам расчета видно, что при условии неста-

ционарного режима нагрева температура теплового центра 
409,3 К. Произошло уточнение температуры  центра на 
82,4 К, или на 20,1 %. Самая разогретая точка нагреваемой 
заготовки 1100,9 К. Это на 23,9 К, или на 2,2 % больше, 
чем в предыдущем примере. 
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В главном окне (рис. 6.13) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, необхо-
димо выполнить следующие действия. 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 
Выберите значение времени, для которого необходимо 

посмотреть распределение. 
Выберите значение 100. 
Нажмите кнопку Apply.  
Вы увидите распределение температур в этот момент 

времени (рис. 6.14). 

 
Рис. 6.13. Распределение температур по сечениям заготовки  

(нестационарная задача с учётом зависимости теплофизических 
коэффициентов от температуры) 

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  
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Во вкладке General проверьте, что выбраны шаги вре-
мени. 

Затем выберите вкладку Point.  
В поле Coordinates для х: выберите значение 0.25, y: 

0.25, z: 0. – точка теплового центра заготовки. Через про-
бел для x: наберите 0.5, для y: 0.5, для z: 0.5 – одна из наи-
более разогретых точек заготовки 

Нажмите OK.Вы увидите окно с графиком переходного 
процесса в тепловом центре заготовки (рис. 6.15). С помо-
щью кнопки Zoom window можно увеличить любую часть 
графика. На одном рисунке можно совместить графики 
распределения температур по толщине пластины для раз-
личных моментов времени. 

 
Рис. 6.14. Распределение температур по сечению заготовки в 

момент времени 100 с (нестационарная задача с учётом зависи-
мости теплофизических коэффициентов от температуры) 

Откройте окно Postprocessing > Domain Plot 
Parameters, вкладку General. 
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 В области Plot type включите радиокнопку Surfase 
Plot.  

В области Solutions to use (Используемые решения) 
раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Surfase, отметьте радиокнопку 
Surfase Plot. 

В области Boundary selection выберите 3. 

 
Рис. 6.15. Изменение температуры на поверхности в самой разо-

гретой точке и в тепловом центре заготовки со временем 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся трёхмерный график (рис. 6.16). 
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Рис. 6.16. Распределение температур на грани заготовки      

с граничными условиями (q=const) для различных моментов 
времени 

7.    Нагрев    изделий    при   радиационном   
теплообмене 

7.1. Решение  задачи  нагрева  при  радиационном 
теплообмене  (нестационарный  режим  1D модель) 
Ранее было описано решение задач нагрева для гранич-

ных условий I, II и III родов, теперь решим эти же задачи  
для  условий  радиационного  теплообмена  при  учёте со-
пряжённого теплообмена от другого тела, которое назовём 
излучателем. 
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Режим предназначен для расчета нагрева листа метал-
ла с толщиной, на порядок меньшей двух других размеров. 
В качестве граничного условия принят радиационный теп-
лообмен от поверхности к поверхности, и эффективный 
тепловой поток определяется с учётом степени черноты 
излучающей и поглощающей поверхностей металла и из-
лучателя, а со стороны теплового центра – режим условия 
адиабаты. Для нагреваемой пластины выбираем режим 1D. 

Рассмотрим модель однослойной пластины толщиной 
0,1 м с граничными условиями II рода (условия адиабаты) 
с одной стороны и радиационный поток от источника с по-
стоянной температурой c другой. Начальная температура 
пластины  T0 = 273,15 К, степень  черноты  поверхности 
 = 0,8, температура окружающей среды  Tamb = 273,15 К. 
Источник излучения в виде тонкой пластины с постоянной 
температурой T0 = 1273,15 К, степенью черноты поверхно-
сти  = 1 находится на расстоянии 0,1 м. Между источни-
ком и нагреваемой пластиной отсутствует среда взаимо-
действия. Время нагрева пластины 1000 с.  

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator.  
Выберите в списке Space Dimension 1D.  
В Application Mode выберите режим Heat Transfer 

Module > General Heat Transfer > Steady-state analysis. 
Нажмите OK.  
Откроется рабочая область с одной координатной осью.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects>Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 10 см. Введите в поле цифры 0 

«пробел»  0.1.  
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Нажмите OK. В рабочей области на оси х появится ли-
ния, названная по умолчанию I1. Это же окно можно от-
крыть, если щелкнуть на кнопке Line при нажатой клави-
ше Shift.  

Снова выберите пункт меню Draw > Specify Objects > 
Line. 

В открывшемся окне введите координаты источника в 
поле Coordinates.  

Источник находится от пластины на расстоянии 10 см. 
Введите в поле цифры 0.2 «пробел» 0.2001.  

Нажмите OK. В рабочей области на оси х появится ли-
ния, названная по умолчанию I2. 

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings… (в послед-
ней версии программы оно вызывается клавишей F8).  

В Subdomain selection выберите номер пластины 1.       
В рабочей области эта  область сразу выделится красным.   

Введите в поля свойства в соответствии с табл. 7.1. 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Таблица 7.1.                     Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см Сталь 38.67 7850 608.3 0 
Введите 273.15 как начальное значение в поле 

Temperature. 
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Повторите эти действия для пластины 2. Только после 
открытия вкладки Init, введите начальное значение в поле 
Temperature 1273.15. 

Нажмите OK. 
Граничные условия  

Откройте окно Physics > Boundary Settings… (F7).  
В Boundary selection выберите номер границы 1.В ра-

бочей области соответствующая граница выделяется крас-
ным.  

Введите граничные условия в соответствии с табл. 7.2. 
Таблица 7.2.                      Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Окружающая 
среда–сталь 

Thermal 
insulation 

 

2 Сталь–среда Heat flux 
Tinf = 273.15 К;Radiation 

type=Surface-to-surface;  =0.8; 
Tamb= 273.15; J0=J 

3 Среда-
источник Temperature 

T0=1273 К;Radiation 
type=Surface-to-surface;  =1; 

Tamb = 1273.15; J0=J 

4 
Источник–

окружающая 
среда 

Thermal 
insulation  

В нашем случае можно использовать линейный реша-
тель, так как все физические свойства и коэффициенты 
приняты не зависящими от температуры.  

Нажмите OK. 
Генерация сетки ничем не отличается от предыдущих 

пунктов. Установки для расчёта повторите,  как в разд. 4.2.  
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ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 7.1).  
По результатам расчета в конце нагрева температура 

на поверхности пластины получилась 614,0 К, а темпера-
тура теплового центра – 467,1 К. 

 
Рис. 7.1.  Распределение  температур  по  толщине  пластины     в 
конце радиационного нагрева от источника, расположенного на 
расстоянии 0,1 м (нестационарная задача при отсутствии среды 

между источником и нагреваемым телом) 

7.2.  Решение задачи нагрева при   радиационном 
теплообмене  (нестационарный    режим   1D     модель  
с  учётом воздуха,  находящегося  между   источником  

и  нагреваемым телом) 
Режим предназначен, как и в предыдущем примере, 

для расчета нагрева листа металла с толщиной, на порядок 
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меньшей двух других размеров. В качестве граничного ус-
ловия принят радиационный теплообмен от поверхности к 
поверхности, и эффективный тепловой поток определяется 
с учётом степени черноты излучающей и поглощающей 
поверхности металла и излучателя, а со стороны теплового 
центра – режим условия адиабаты. Для нагреваемой пла-
стины выбираем режим 1D. Отличие от предыдущего при-
мера заключается в присутствии между источником и на-
греваемым телом воздуха. 

 
Рассмотрим модель однослойной пластины толщиной 

0,1 м с граничными условиями II рода (условия адиабаты) 
с одной стороны и радиационный поток от источника с по-
стоянной температурой c другой. Начальная температура 
пластины  T0 = 273,15 К, степень черноты  поверхности  
 = 0,8, температура окружающей среды  Tamb = 273,15 К. 
Источник излучения в виде тонкой пластины с постоянной 
температурой T0 = 1273,15 К, степенью черноты поверхно-
сти  = 1 находится на расстоянии 0,1 м. Между источни-
ком и нагреваемой пластиной находится воздух. Зависи-
мость теплофизических коэффициентов для воздуха пред-
ставлена в табл. 7.3. Время нагрева пластины 1000 с.  

Навигатор в этой модели ничем не отличается от нави-
гатора  в предыдущей. 

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 0,1 м. Введите в поле цифры 0 «про-

бел»   0.1.  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1.  
Это же окно можно открыть, если щелкнуть на кнопке 

Line при нажатой клавише Shift.  
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Таблица 7.3.         Зависимость теплофизических коэффициентов 
для воздуха при давлении 0,1 МПа от температуры 

Температура, 
˚С 

Коэффициент теп-
лопроводности, 

Вт/(м·˚С) 

Удельная те-
плоёмкость, 
Дж/(кг·˚С) 

 
Плотность 
воздуха, 

кг/м3 

 
T k Cp ρ 

273 0,0244 1004 1,293 
373 0,0321 1009 0,946 
473 0,0393 1026 0,747 
573 0,0461 1047 0,616 
673 0,0521 1068 0,524 
773 0,0574 1093 0,456 
873 0,0623 1114 0,404 
973 0,0671 1135 0,363 
1073 0,0718 1156 0,328 
1173 0,0763 1172 0,301 
1273 0,0807 1185 0,276 

Снова  выберите  пункт меню Draw  > Specify Objects > Line. 
В открывшемся окне введите координаты между метал-

лом и источником в поле Coordinates.  
Источник находится от металла на расстоянии 10 см. 

Введите в поле цифры 0.1 «пробел» 0.2. 
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I2. 
Снова выберите пункт меню Draw > Specify Objects > 

>Line. 
В открывшемся окне введите координаты источника в 

поле Coordinates.  
Введите в поле цифры 0.2 «пробел» 0.2001. 
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I3. 
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Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 
Теперь можно задать физические материала пластины, 

воздуха и источника.  
Откройте окно Physics > Subdomain Settings… (в по-

следней версии программы оно вызывается клавишей F8).  
В Subdomain selection выберите номер пластины 1. В 

рабочей области эта  область сразу выделится красным.   
Введите в поля свойства в соответствии с табл. 7.4. 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Таблица 7.4.                             Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см Сталь 38.67 7850 608.3 0 
 
Введите 273.15 как начальное значение в поле 

Temperature. 
Повторите эти действия для пластины 3. Только после 

открытия вкладки Init введите начальное значение в поле 
Temperature 1273.15. 

Нажмите OK. 
Ввод теплофизических свойств воздуха от температуры 

осуществите по аналогии с металлом (табл 7.3), используя 
меню Options и Functions.  

Откройте окно Physics > Subdomain Settings…  
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 В Subdomain selection выберите номер пластины 2. В 
рабочей области эта  область сразу выделится красным. 

Проверьте, в поле Enable conductive Heat Transfer 
(Разрешить передачу тепла теплопроводностью) должна 
стоять «галка». 

Введем в поля свойства в соответствии с табл. 7.5. 
Таблица 7.5.                         Свойства материала 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см Воз-
дух k(T) rho(T) Cp(T) 0 

В поле Opacity (Прозрачность среды) должно быть ус-
тановлено Transparent (Прозрачная). 

В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273.15 как начальное значение в поле 

Temperature. 
Нажмите OK. 
Задание граничных условий, генерация сетки и расчёт в 

этом примере ничем не отличаются от предыдущего. 
ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур по толщине пластины и 
внутри воздушного зазора (рис. 7.2).  

По результатам расчета в конце нагрева температура 
на поверхности пластины 615,0 К, а температура теплового 
центра 467,9 К. 
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Рис. 7.2.  Распределение температур по толщине пластины в 

конце радиационного нагрева от источника, расположенного на 
расстоянии 0,1 м  (нестационарная задача; между источником и 

нагреваемым телом находится воздух) 

7.3. Решение задачи нагрева при радиационном 
теплообмене    без   учёта  промежуточной    среды     

(нестационарный режим 2D модель) 
Режим предназначен для расчета нагрева металла с 

размерами сечения одного порядка, а длиной, на порядок 
большей сторон сечения. В качестве граничного условия 
принят радиационный теплообмен на три стороны поверх-
ности металла от поверхности излучателя. Эффективный 
тепловой поток определяется с учётом степени черноты 
излучающей и поглощающей поверхностей металла и из-
лучателя. На одной стороне – условия адиабаты. Для на-
греваемой заготовки выбираем режим 2D.  
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Рассмотрим модель заготовки с сечением в виде квад-
рата 0,3 м с граничными условиями II рода (условия адиа-
баты) с одной стороны и радиационный поток от источни-
ка с постоянной температурой с трёх сторон. Начальная 
температура нагрева T0 = 273,15 К, степень черноты по-
верхностей   = 0,8, температура  окружающей  среды      
Tamb = 273,15 К. Источник излучения в виде тонкой обо-
лочки с постоянной температурой T0 = 1273,15 К, степенью 
черноты поверхности  = 1 находится на расстоянии 0,1 м. 
Между источником и нагреваемым телом среда отсутству-
ет. Зависимость теплофизических коэффициентов для на-
греваемой заготовки – в табл. 4.5. Время нагрева заготовки 
1000 с. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 2D.  
В Application Mode выберите режим Heat Transfer 

Module > General Heat Transfer > Steady-state analysis. 
Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > 

Rectangle.  
Для создания внешнего контура нагревателя в открыв-

шемся окне Rectangle найдите область Size и введите  0.52 
в поле Width (Ширина), затем введите 0.42 в поле Height 
(Высота), Position(Позиция) x, у оставьте без изменения. 

Нажмите OK.  
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
Для создания внутреннего контура нагревателя в от-

крывшемся окне Rectangle найдите область Size и введите  
0.5 в поле Width (Ширина), затем введите 0.4 в поле 
Height (Высота), Position (Позиция) x=0.01, у = 0.01. 
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Нажмите OK.  
Командой меню Edit > Select All выделите созданные 

геометрические объекты. 
Затем кнопкой Difference (Различие)  создайте кон-

тур нагревателя. 
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
В открывшемся окне Rectangle найдите область Size и 

введите  0.3 в поле Width (Ширина), затем введите 0.3 в 
поле  Height (Высота),  Position  (Позиция)   x = 0.11,        
у = 0.01001. 

Нажмите OK.  
Нажмите кнопку Zoom Extents ,  для того чтобы рас-

положить фигуру на весь экран.  
ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings…. 
В Subdomain selection выберите подобласть 1. Рабочая 

область выделится красным. 
Введите в поля свойства для стали в соответствии с табл. 4.1. 
В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 1273.15 как начальное значение в поле 

Temperature. 
В Subdomain selection выберите подобласть 2. Рабочая 

область выделится красным. 
Введите в поля свойства для стали в соответствии с табл. 4.5, 

используя при этом методику, изложенную в разд. 4.3. 
В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Проверьте в поле Temperature число 273.15 как на-

чальное значение. 
Нажмите OK. 
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Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл.7.6. 

Таблица 7.6.                        Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1÷3,1
2 

Нагреватель–
окружающая среда 

Thermal 
insulation 

 

4÷6,1
1 

Нагреватель–
заготовка Temperature 

T0=1273.15 К; 
Radiation type = Surface-
to-surface;  =1; Tamb = 

1273.15; J0=J 

7,9, 
10 

Заготовка – нагре-
ватель Heat flux 

Tinf =273.15 К; 
Radiation type = Surface-
to-surface;  =0.8; Tamb = 

273.15; J0=J 

8 Заготовка – нагре-
ватель 

Thermal 
insulation 

 

Нажмите OK. 
ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . 
По умолчанию будет сгенерировано 718 конечных элемен-
тов. Чтобы увеличить количество элементов, надо нажать 

кнопку  [Mesh > Refine Mesh]. При необходимости её 
можно нажать несколько раз.  

 
 



162 

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите  0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но  распределение  температур  по  сечению  заготовки 
(рис. 7.3). 

По результатам расчета видно, что при условиях не-
стационарного режима нагрева с переменными теплофизи-
ческими коэффициентами температура теплового центра в 
квадратном сечении 435,1 К, координаты точки x=0,26; 
y=0,02, а самые разогретые точки будут в координатах 
x=0,11; y=0,31001 и x=0,41; y=0,31001 с температурой 
867,1 К. 

 7.4.   Решение          сопряжённой     задачи    нагрева      
при радиационном теплообмене с учётом  промежуточной 

среды (нестационарный режим 2D модель)  
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева металла с  прямоугольным  сечением и 
длиной,   на порядок  большей  сторон  сечения. В качестве  
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Рис. 7.3. Распределение температур по сечению заготовки      

(нестационарная задача) 

граничного условия принят радиационный теплообмен на 
поверхность металла на три стороны сечения металла от 
поверхности излучателя.  На одной стороне приняты усло-
вия адиабаты. Для нагреваемого металла надо выбрать ре-
жим 2D. Отличие от предыдущего примера заключается в 
присутствии между излучателем и нагреваемым телом 
воздуха. 

Рассмотрим модель заготовки с сечением в виде квад-
рата 0,3 м с граничными условиями II рода (условия адиа-
баты) с одной стороны и радиационный поток от источни-
ка с постоянной температурой с трёх сторон. Начальная 
температура нагрева T0 = 273,15 К, степень черноты по-
верхностей  = 0,8, температура окружающей среды          
Tamb = 273,15 К. Источник излучения в виде тонкой обо-
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лочки с постоянной температурой T0 = 1273,15 К, степенью 
черноты поверхности  = 1 находится на расстоянии 0,1 м. 
Между источником и нагреваемой заготовкой находится 
воздух. Зависимость теплофизических коэффициентов для 
нагреваемой заготовки – в табл. 4.5, а воздуха – в табл. 7.3. 
Время нагрева заготовки 1000 с. 

Открытие навигатора моделей в этом  примере расчёта 
ничем не отличается от предыдущего. 

ЗАДАНИЕ ГЕОМЕТРИИ  
Создание областей нагреваемой заготовки и нагревателя 

ничем не отличаются от предыдущего примера. 
Для учета промежуточной среды выберите пункт меню 

Draw > Specify Objects > Rectangle.  
Для создания внешнего контура воздуха в открывшемся 

окне Rectangle найдите область Size и введите  0.5 в поле 
Width (Ширина), затем введите 0.4 в поле Height (Высо-
та), Position (Позиция) x=0.01, у=0.01. 

Нажмите OK.  
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
Для создания внутреннего контура воздуха в открыв-

шемся окне Rectangle найдите область Size и введите  0.3 в 
поле Width (Ширина), затем введите 0.3 в поле Height 
(Высота), Position (Позиция) x=0.11, у = 0.01. 

Нажмите OK.  
Воспользуемся кнопкой Create Composite Object (Создание 

составного объекта) . Появится окно, показанное на рис. 7.4. 
Затем в строке диалогового окна Set formula (Формула 

набора) замените R1+R2 на R1-R2 и нажмите кнопку OK.  
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
В открывшемся окне Rectangle найдите область Size и вве-

дите  0.3 в поле Width (Ширина), затем введите 0.29999 в поле 
Height (Высота), Position (Позиция) x = 0.11; у = 0.01001. 
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Нажмите OK. 

 
Рис. 7.4. Диалоговое окно создания составного объекта 

 Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Повторите для подобласти 1 физические установки из 
предыдущего примера.  

Откройте окно Physics > Subdomain Settings…. 
В Subdomain selection выберите подобласть 2. Рабочая 

область выделится красным. 
Введите  в  поля свойства  для  воздуха,  в соответствии  с 

табл. 7.3, используя при этом методику, изложенную в  разд.  4.3. 
В остальных полях оставте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273.15 как начальное значение в поле Temperature. 
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В Subdomain selection выберите подобласть 3. Рабочая 
область выделится красным. 

Повторите пункты с 8 по 11 из предыдущего примера. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите  граничные условия  в  соответствии с табл. 7.7. 
Нажмите OK. 

Генерация сетки и расчёт в этом примере ничем не от-
личаются от предыдущего примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но  распределение  температур  по  сечению заготовки 
(рис. 7.5). 

По результатам расчета видно, что при условиях неста-
ционарного режима нагрева с учётом воздуха между на-
гревателем и заготовкой с переменными теплофизически-
ми  коэффициентами  материала заготовки   и    воздуха 
температура теплового центра  в  квадратном сечении 
437,7 К, координаты точки x=0,26; y=0,02, а самые разо-
гретые точки будут в координатах x=0,11; y=0,31 и x=0,41; 
y=0,31 с температурой 869,0 К. 

В главном окне (рис. 7.5) выведено распределение 
температур по сечению заготовки для момента времени 
1000 с. Для того чтобы увидеть распределение температур 
по сечению заготовки в другие моменты времени, необхо-
димо выполнить следующее. 
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Таблица 7.7.                        Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1÷3,1
6 

Нагреватель–
окружающая среда 

Thermal 
insulation 

 

4÷6, 
13, 
15 

Нагреватель–
воздух Temperature 

T0=1273.15 К; 
Radiation type = Surface-

to-surface;  =1;           
Tamb = 1273.15; J0=J 

9,11, 
14 Заготовка – воздух Heat flux 

Tinf =273.15 К; 
Radiation type = Surface-

to-surface;  =0.8;       
Tamb = 273.15; J0=J 

7,8, 
10,  
12 

Заготовка – нагре-
ватель  

Thermal 
insulation 

 

Откройте окно Postprocessing > Plot Parameters.  
Во вкладке General раскройте список Solution at time. 

Здесь можно выбрать значение времени, для которого не-
обходимо посмотреть распределение. 

Выберите значение 100. 
Нажмите кнопку Apply. Вы увидите распределение 

температур в этот момент времени. Оно выводится как 
распределение температур по сечению в виде контурной 
картинки, раскрашенной различными оттенками в соответ-
ствии с температурой (рис. 7.6). 

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги времени. 
Затем выберите вкладку Point. 
В поле Coordinates    для х:   выберите   значение    0.26,    
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Рис. 7.5.  Распределение температур по сечению заготовки с 

учётом присутствия воздуха между нагревателем и заготовкой 
(нестационарная задача) 

y: 0.02 – точка теплового центра сечения заготовки, через 
пробел наберите значения для x: 0.11; y: 0.31 – самая разо-
гретая точка на поверхности металла. 

Нажмите OK. Вы увидите окно с графиком переходного 
процесса в тепловом центре сечения (рис. 7.7). 

С помощью кнопки Zoom window можно увеличить 
любую часть графика. 

Для построения графика распределения температур по 
толщине заготовки для различных моментов времени, не-
обходимо сделать следующее. 

Откройте окно Postprocessing  > Domain Plot Parameters. 
В области Plot type включите радиокнопку 

Line/Extrusion Plot.  
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 
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Рис. 7.6.  Распределение температур по сечению заготовки в 

момент времени 100 с (нестационарная задача с учётом зависи-
мости теплофизических коэффициентов от температуры) 

 В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Line/Extrusion в области Plot type, 
отметьте радиокнопку Line Plot.  

В поле Expression должно стоять T. В списке Boundary 
Selection должна быть выбрана подобласть 10 (граничные 
условия для адиабаты). 

Нажмите кнопку Line settings.  
В открывшемся окне в списке Line color выберите 

Color, в списке Line style – Cycle, в списке Line marker – 
Cycle. 
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Рис. 7.7. Изменение температуры на поверхности в самой разо-

гретой точке и в тепловом центре заготовки со временем 
Нажав кнопку Color, можно выбрать любой цвет. 
Поставьте галочку Legend. 
Нажмите OK в окне Line settings. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся график (рис. 7.8). 

7.5. Решение задачи нагрева при радиационном   
теплообмене   (нестационарный  режим  3D  модель       

с учётом зависимости теплофизических коэффициентов 
от температуры) 

Режим предназначен для расчета нагрева заготовки (ку-
ба, параллелепипеда). Все размеры одного порядка. В ка-
честве граничного условия принят радиационный тепло-
обмен с пятью гранями поверхности заготовки от поверх-
ности излучателя,  а  на  одной  грани –  условия  адиабаты. 
Эффективный тепловой поток определяется с учётом сте-
пени черноты излучающей и поглощающей поверхностей 
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металла и излучателя. Для нагреваемой заготовки надо вы-
брать режим 3D. 

Рассмотрим модель заготовки в виде куба с граничными 
условиями II рода (условия адиабаты) с одной стороны и 
радиационный поток от источника с постоянной темпера-
турой   с   пяти   сторон.   Начальная   температура  нагрева  

 
Рис. 7.8. Распределение температур на стороне сечения заготов-

ки с условиями адиабаты для различных моментов времени 
T0 =273,15 К, степень черноты поверхностей = 0,8, темпе-
ратура окружающей среды  Tamb = 273,15 К. Источник из 
лучения в виде тонкой оболочки с постоянной температу-
рой T0 = 1273,15 К, степенью черноты поверхности  = 1 
находится на расстоянии 0,1 м. Между источником и на-
греваемым телом среда отсутствует. Зависимость теплофи-
зических коэффициентов для нагреваемой заготовки – в 
табл. 5.5. Время  нагрева  заготовки 1000 с. Ребро куба – 
0,5 м.  
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НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 3D.  
В Application Mode выберите режим > Heat Transfer 

Module > General Heat Transfer > Steady-state analysis. 
Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Block.  
Для создания внешнего контура нагревателя в открывшемся 

окне Block найдите область Length (Длина) и введите  0.74 в 
поля x, y и в поле z  0.64, в поле Axis base point (Арифметиче-
ская точка оси) для x, y и z введите числа    –0.02. 

Нажмите OK. 
 Повторите выбор пункта меню Draw > Block.  
Для создания внутреннего контура нагревателя в от-

крывшемся окне Block найдите область Length (Длина) и 
введите  0.70 в поля x, y и в поле z  0.60. 

Нажмите OK.  
Командой меню Edit > Select All выделите созданные 

геометрические объекты. 
Затем кнопкой Difference (Различие)  создайте кон-

тур нагревателя. 
Повторите выбор пункта меню Draw > Specify Objects > Block.  
Для создания нагреваемой заготовки в открывшемся ок-

не Block найдите область Length (Длина) и введите  0.5 в 
поля x, y z. , в поле Axis base point (Арифметическая 
точка оси) для x, y введите 0.1, а для z – 0.0001. 

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран. 

 ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings…. 
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В Subdomain selection выберите подобласть 1. Рабочая 
область выделится красным. 

Введите в поля свойства стали в соответствии с табл. 5.1. 
В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 1273.15 как начальное значение в поле 

Temperature. 
В окне Subdomain selection выберите подобласть 2. Ра-

бочая область выделится красным. 
Введите в поля свойства для стали, зависимые от темпе-

ратуры, в соответствии с табл. 4.6, используя при этом ме-
тодику, изложенную в разд. 4.3. 

В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Проверьте в поле Temperature число 273.15 как на-

чальное значение. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. В рабо-

чей области соответствующая граница выделяется красным. 
Введите граничные  условия в соответствии с табл. 7.8. 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
В отличие от двухмерной задачи эта задача решается зна-

чительно дольше, поэтому перед генерацией сетки необхо-
димо настроить параметры сетки. Для этого надо выбрать 
Mesh > Mesh parameters или нажать на кнопку F9. Откроет-
ся окно настроек. На вкладке Global в списке Predefined 
mesh sizes выберете Extremely coarse (Чрезвычайно гру-
бый). Нажмите кнопку Remesh для построения сетки с но-
выми параметрами, соответствующими режиму Extremely 
coarse. Будет сгенерировано 797 конечных элементов. Если 
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для точности этого будет недостаточно, то вместо Extremely 
coarse выберите Extra coarse (Экстра грубый) и т. д. 
Таблица 7.8.                       Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1÷5, 
18 

Нагреватель – ок-
ружающая среда 

Thermal 
insulation 

 

6÷10,
17 

Нагреватель–
заготовка Temperature 

T0=1273.15 К; 
Radiation type = Surface-

to-surface;  =1;  
Tamb = 1273.15; J0=J 

11, 
12, 
14÷ 
16 

Заготовка – нагре-
ватель Heat flux 

Tinf =273.15 К; 
Radiation type = Surface-

to-surface;  =0.8;  
Tamb = 273.15; J0=J 

13 Заготовка – нагре-
ватель 

Thermal 
insulation 

 

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите  0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур в виде срезов по толщине куба 
(рис. 7.9).  
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Для того чтобы  лучше проанализировать полученное 
температурное поле, необходимо открыть окно 
Postprocessing > меню Slice, в области Slice positioning 
для x-levels установить 9.  

Нажмите OK. 

 
Рис. 7.9. Распределение температур по сечениям заготовки (не-

стационарная задача) 

7.6.  Решение  задачи   нагрева   при    радиационном 
теплообмене  с    учётом     промежуточной    среды    
(нестационарный    режим    3D   модель   с   учётом   
зависимости      теплофизических    коэффициентов     

от температуры) 
Режим предназначен, как и в предыдущем случае, для 

расчета нагрева заготовки, у которой размеры сторон име-
ют одинаковый порядок (куб, параллелепипед). В качестве 
граничного условия принят радиационный теплообмен с 
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пятью гранями поверхности заготовки от поверхности из-
лучателя, а на одной грани – условия адиабаты. Эффектив-
ный тепловой поток определяется с учётом степени черно-
ты излучающей и поглощающей поверхностей металла и 
излучателя. Для нагреваемой заготовки надо выбрать ре-
жим 3D. Отличие от предыдущего примера заключается в 
присутствии между излучателем и нагреваемым телом 
воздуха. 

Рассмотрим модель заготовки в виде куба с гранич-
ными условиями II рода (условия адиабаты) с одной сто-
роны и радиационный поток от источника с постоянной 
температурой с пяти сторон. Ребро куба 0,5 м. Начальная 
температура нагрева T0 = 273,15 К, степень черноты по-
верхностей  = 0,8, температура окружающей среды          
Tamb = 273,15 К. Источник излучения в виде тонкой обо-
лочки с постоянной температурой T0 = 1273,15 К, степенью 
черноты поверхности  = 1 находится на расстоянии 0,1 м. 
Между источником и нагреваемой заготовкой находится 
воздух. Зависимость теплофизических коэффициентов для 
нагреваемой заготовки представлена в табл.4.5, а для воз-
духа – в табл. 7.3. Время нагрева заготовки 1000 с. 

Открытие навигатора моделей в этом  примере расчёта 
ничем не отличается от предыдущего. 

ЗАДАНИЕ ГЕОМЕТРИИ  
Создание областей нагреваемой заготовки и нагревателя 

ничем не отличается от предыдущего примера. 
Для учета промежуточной среды выберите пункт меню 

Draw > Block.  
Для создания внешнего контура воздуха в открывшемся 

окне Block найдите область Length (Длина) и введите  0.7 
в поля x, y и в поле z-0.6, в поле Axis base point (Арифме-
тическая точка оси) для x, y и z должны быть числа    0.0. 

Нажмите OK. 
 Повторите выбор пункта меню Draw > Block.  
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Для создания внутреннего контура для воздуха в от-
крывшемся окне Block найдите область Length (Длина) и 
введите  0.5 в поля x, y и z. 

Нажмите OK.  
Воспользуйтесь кнопкой Create Composite Object 

(Создание составного объекта) . Появится окно, пока-
занное на рис.7.4. 

Затем в строке диалогового окна Set formula (Формула 
набора) замените R1+R2 на R1-R2 и нажмите кнопку OK.  

Повторите выбор пункта меню Draw > Block.  
Для создания внешнего контура нагреваемой заготовки в от-

крывшемся окне Block найдите область Length (Длина) и вве-
дите  0.5 в поля x, y и в поле z – 0.495, в поле Axis base point 
(Арифметическая точка оси)   для x,  y введите  число 0.1,  для  
z – 0.005. Арифметическую точку для оси z меньше выбрать 
нельзя из-за выбранных в дальнейшем условий генерации сетки.  

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  
Физические установки в этом примере ничем не отли-

чаются от примера, описанного в разд 7.4.  
Граничные условия  

Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл. 7.9. 
Нажмите OK. 

Генерация сетки и расчёт в этом примере ничем не от-
личаются от предыдущего примера. 

ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведено 

распределение температур по толщине пластины (рис. 7.10). 
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По результатам расчета видно, что при условии неста-
ционарного режима нагрева температура теплового центра 
386,1 К. Самая разогретая точка нагреваемой заготовки 
1068,6 К. 

Откройте окно Postprocessing > Cross-Section Plot 
Parameters.  
Таблица 7.9.                         Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1÷5, 
23 

Нагреватель – ок-
ружающая среда 

Thermal 
insulation 

 

6÷10,
13, 
22 

Нагреватель–
воздух Temperature 

T0=1273.15 К; 
Radiation type = Surface-

to-surface;  =1;  
Tamb = 1273.15; J0=J 

14, 
15, 
17 
19, 
21 

Воздух – нагрева-
тель Heat flux 

Tinf =273.15 К; 
Radiation type = Surface-

to-surface;  =0.8;  
Tamb = 273.15; J0=J 

11, 
12, 
18, 
20 

Воздух – зазор 
между заготовкой 

и нагревателем 

Thermal 
insulation  

 
16 

Заготовка – нагре-
ватель 

Thermal 
insulation 

 

  
Во вкладке General проверьте, что выбраны шаги вре-

мени. 
Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0.35, y: 

0.35; z: 0.005 – точка теплового центра заготовки. Коорди-
наты одной из наиболее разогретых точек заготовки в поле 
для x: наберите 0.6, для y: 0.6, для z: 0.495. 
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Нажмите OK. 
Вы увидите окно с графиком переходного процесса в 

тепловом центре заготовки (рис. 7.11).С помощью кнопки 
Zoom window можно увеличить любую часть графика, и 
на одном рисунке совместить графики распределения тем-
ператур по толщине пластины для различных моментов 
времени. 

 

 
Рис. 7.10. Распределение температур по сечению заготовки с 

учётом присутствия воздуха между нагревателем и заготовкой 
(нестационарная задача) 

Откройте окно Postprocessing > Domain Plot 
Parameters, вкладку General. 

В области Plot type включите радиокнопку Surfase Plot.  
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Рис. 7.11. Изменение температуры на поверхности в самой разо-

гретой точке и в тепловом центре заготовки со временем 

В области Solutions to use (Используемые решения) 
раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Surface, отметьте радиокнопку 
Surface Plot. 

В области Boundary selection выберите 16. 
Нажмите OK в окне Domain Plot Parameters. Откроет-

ся трёхмерный график (рис. 7.12). 
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Рис. 7.12.  Распределение температур на гране заготовки с гра-

ничными условиями (q=const) для различных моментов времени 

8.    Нагрев    изделий    при    сопряжённом    
радиационном    теплообмене    без    учёта    

промежуточной среды 

8.1.  Решение   задачи   нагрева   при   сопряжённом   
радиационном теплообмене без учёта  промежуточной 

среды (нестационарный режим 1D модель) 
Ранее было описано решение задач нагрева для гра-

ничных условий I, II и III родов и при радиационном на-
греве. Теперь решим эти же задачи для условий сопряжён-
ного радиационного теплообмена, когда тепловой поток 
выделяется внутри пространства между двумя телами, уча-
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ствующими при радиационном теплообмене, с учётом 
влияния их друг на друга (сопряжённый радиационный те-
плообмен между двумя телами). Одно из тел, участвующих 
в теплообмене назовем кладкой, а другое – металлом. 

Режим предназначен для расчета нагрева листа метал-
ла с толщиной, на порядок меньшей двух других размеров. 
В качестве граничного условия принят радиационный теп-
лообмен от поверхности к поверхности и учетом теплового 
потока, выделяющегося между поверхностями. Эффектив-
ный тепловой поток определяется с учётом степени черно-
ты излучающей и поглощающей поверхностей металла и 
кладки. Со стороны теплового центра металла и кладки 
приняты граничные условия второго рода (условия адиаба-
ты). Для нагреваемой пластины с учетом влияния на её на-
грев кладки выбираем режим 1D. 

Рассмотрим модель однослойной пластины толщиной 
0,1 м с граничными условиями II рода (условия адиабаты) 
с одной стороны и тепловой поток 106 344 Вт/м2   совме-
стно с отражённым радиационным потоком от кладки, на 
которую   воздействует  тепловой    поток  106 344   Вт/м2  

c  другой.  Начальная   температура  металла    и   кладки  
T0 = 273,15 К, степень черноты поверхностей  = 0,8, тем-
пература окружающей среды  Tamb = 273,15 К. Толщина 
кладки 0,3 м, а расстояние между кладкой и нагреваемым 
металлом 0,6 м. Между источником и нагреваемой пласти-
ной отсутствует среда взаимодействия. Зависимость теп-
лофизических свойств металла и кладки представлена в 
табл. 4.5 и 8.3. Время нагрева системы тел 1000 с.  

Выше описан равномерно распределённый режим, при 
котором тепловой радиационный поток на кладку и металл 
одинаковый. Далее в примере будут показаны результаты 
расчёта косвенного режима, при котором тепловой поток 
от  источника   на   кладку   212 688  Вт/м2,   а  на  металл  
0 Вт/м2. Также будут показаны результаты расчёта для на-
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правленного режима, при котором тепловой поток на 
кладку 0 Вт/м2, а на металл 212 688  Вт/м2 [7]. 

Открытие навигатора моделей в этом  примере расчёта 
ничем не отличается от примера в разд. 7.1. 

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Specify Objects > Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 0,1 м. Введите в поле цифры 0 0.1.  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1.  
Это же окно можно открыть, если щелкнуть на кнопке 

Line при нажатой клавише Shift.  
Снова выберите пункт меню Draw > Specify 

Objects>Line. 
В открывшемся окне введите координаты источника в 

поле Coordinates.  
Источник находится от пластины на расстоянии 0,6 м. 

Введите в поле цифры 0.7  1.  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I2. 

Нажмите кнопку Zoom Extents , для того чтобы рас-
положить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics>Subdomain Settings…  
В Subdomain selection выберите номер пластины ме-

талла 1.  
Введите в поля свойства в соответствии с табл. 8.1. 
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Таблица 8.1.                      Свойства металла 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 10 см сталь km(T) rhom 
(T) cm(T) 0 

В Subdomain selection выберите номер пластины клад-
ки 2.   

Введите в поля свойства в соответствии с табл. 8.2. 
Таблица 8.2.                   Свойства кладки 

№ 
по-
доб
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см ша-
мот kkl(T) 2500 ckl(T) 0 

 
В остальных полях оставьте нулевые значения. 
Для того чтобы установить начальное значение темпе-

ратуры, откройте в том же окне вкладку Init. 
Введите 273.15 как начальное значение в поле 

Temperature. 
Повторите эти действия для пластины 2.  
Нажмите OK.Введите в поля свойства для металла, за-

висимые от температуры (табл. 4.6), и свойства для кладки 
(табл. 8.3), используя при этом методику, изложенную в 
разд. 4.3. 
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Таблица 8.3.  Зависимость теплофизических коэффициентов для 
шамота  от температуры металла 

Температура, 
˚С 

Коэффициент теп-
лопроводности, 

Вт/(м·˚С) 

Удельная те-
плоёмкость, 
Дж/(кг·˚С) 

T kkl ckl 

273 0.874 880 
473 1.003 926 
673 1.131 972 
823 1.259 1018 

1073 1.387 1064 
1273 1.515 1110 
1473 1.643 1156 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7).  
В Boundary selection выберите номер границы 1. В ра-

бочей области соответствующая граница выделяется крас-
ным.  

Введите граничные условия в соответствии с табл. 8.4. 
Нажмите OK. 
Генерация сетки ничем не отличается от предыдущих 

пунктов. Установки для расчёта повторите как в разд. 5.2.  
ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур по толщине металла и тол-
щине кладки (рис. 8.1).  

По результатам расчета в конце нагрева температура 
на поверхности металла 803,1 К, на кладке 1226,5 К, а тем-
пература теплового центра металла 601,4 К. 

Откройте окно Postprocessing > Cross-Section Plot 
Parameters.  

Во вкладке General проверьте, что выбраны шаги времени. 
Выберите вкладку Point. 
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Таблица 8.4.                 Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Окружающая 
среда–сталь 

Thermal 
insulation 

 

2 Металл – 
кладка Heat flux 

q0=106344 Вт/м2 (косвенный ре-
жим q0=0, направленный режим 

q0=212688), Tinf = 273.15 К; 
Radiation type=Surface-to-surface; 

 =0.8; Tamb= 273.15; J0=J 

3 Кладка – ме-
талл Heat flux 

q0=106344 Вт/м2 (косвенный ре-
жим q0=212688, направленный 

режим q0=0), Tinf = 273.15 К; 
Radiation type=Surface-to-surface; 

 =0.8; Tamb= 273.15; J0=J 

4 
Кладка – ок-
ружающая 

среда 

Thermal 
insulation  

 
В поле Coordinates для х: выберите значение 0 0.1 0.7. 
Нажмите OK. 
Вы увидите окно с графиком переходного процесса в 

тепловом центре заготовки (рис. 8.2).С помощью кнопки 
Zoom window можно увеличить любую часть графика. 

По результатам расчета направленного режима темпе-
ратура на поверхности металла в конце нагрева 917,4 К, 
что на 14,2% больше, чем при распределённом режиме, 
внутренняя поверхность кладки 588,2 К, что на 48,0 % 
меньше, чем при распределённом режиме, а температура 
теплового центра металла 681,8 К больше на 13,4 %. 
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Рис. 8.1. Распределение температур по толщине металла и клад-
ки (нестационарная задача при отсутствии среды между кладкой 

и металлам) 
При косвенном режиме температура на поверхности 

металла в конце нагрева 747,3 К, что на 7,0 % меньше, чем 
при распределённом режиме, на внутренней поверхности 
кладки 1477,6 К, что на 20,5 % больше, чем при распреде-
лённом режиме, а температура теплового центра металла 
560,3 К меньше на 6,8 % равномерно-распределённого ре-
жима. 
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                     а)                                               б) 

 
в) 

Рис. 8.2. Изменение температур на поверхности металла и 
кладки    и    в   тепловом      центре   металла   со    временем:   
а) – равномерно - распределённый режим; б) – направленный 

режим; в) – косвенный режим 
 

8.2.  Решение   задачи   нагрева   при   сопряжённом   
радиационном теплообмене без учёта промежуточной 

среды (нестационарный режим 2D модель) 
Режим предназначен для расчета нагрева металла с 

размерами сечения одного порядка, а длиной, на порядок 
большей сторон сечения. В качестве граничного условия 
принят радиационный теплообмен от поверхности к по-
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верхности и учетом теплового потока, выделяющегося ме-
жду поверхностями. Эффективный тепловой поток опре-
деляется с учётом степени черноты излучающей и погло-
щающей поверхностей металла и кладки. Со стороны теп-
лового центра металла приняты граничные условия IV ро-
да, а для кладки – условия адиабаты. Для нагреваемой за-
готовки выбираем режим 2D.  

Рассмотрим модель радиационного нагрева заготовки 
толщиной 0,1 м с граничными условиями IV рода (условия 
кондуктивного теплообмена) с трёх сторон, примыкающей 
к кладке, и тепловой поток 57 262 Вт/м2 совместно с отра-
жённым радиационным потоком от кладки, на которую 
воздействует тепловой поток 155 426  Вт/м2  c другой сто-
роны. Начальная температура нагрева T0 = 273,15 К, сте-
пень черноты поверхностей  = 0,8, температура окружаю-
щей среды  Tamb = 273,15 К. Толщина кладки 0,3 м, а рас-
стояние между кладкой и нагреваемым металлом 0,6 м. 
Между источником и нагреваемой пластиной отсутствует 
среда взаимодействия. Зависимость теплофизических 
свойств металла и кладки представлена в табл. 5.5 и 9.3. 
Время нагрева заготовки 1000 с. 

Выше описан равномерно распределённый режим, при 
котором тепловой радиационный поток на кладку и металл 
одинаковый. Далее в примере будут показаны результаты 
расчёта косвенного режима, при котором тепловой поток 
от  источника  на  кладку   212 688  Вт/м2,   а   на   металл  
0 Вт/м2. Также будут показаны результаты расчёта для на-
правленного режима, при котором на кладку будет посту-
пать поток 0 Вт/м2,а на металл 212 688  Вт/м2 [7]. 

НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 2D.  
В Application Mode выберите режим Heat Transfer 

Module > General Heat Transfer > Steady-state analysis. 
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Нажмите OK.  
ЗАДАНИЕ ГЕОМЕТРИИ  

Выберите пункт меню Draw > Specify Objects > 
Rectangle.  

Для создания внешнего контура кладки в открывшемся 
окне Rectangle найдите область Size и введите  1.3 в поле 
Width (Ширина), затем введите 1.3 в поле Height (Высо-
та), Position(Позиция) x, у оставить без изменения. 

Нажмите OK.  
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
Для создания внутреннего контура кладки в открыв-

шемся окне Rectangle найдите область Size и введите  1 в 
поле Width (Ширина), затем введите 1 в поле Height (Вы-
сота), Position (Позиция) x=0.3, у = 0.3. 

Нажмите OK.  
Командой меню Edit > Select All выделите созданные 

геометрические объекты. 
Затем кнопкой Difference (Различие)  создайте кон-

тур кладки. 
Повторите выбор пункта меню Draw > Specify 

Objects>Rectangle.  
В открывшемся окне Rectangle найдите область Size и 

введите  0.7 в поле Width (Ширина), затем – 0.1 в поле 
Height (Высота) , Position (Позиция) x = 0.3; у = 0.3. 

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран.  
ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти 

Откройте окно Physics > Subdomain Settings…. 
В Subdomain selection выберите подобласть 1. Рабочая 

область выделится красным. 
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Введите в поля свойства для стали в соответствии с 
табл. 8.1, используя при этом методику, изложенную в 
разд. 4.3. 

В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Введите 273.15 как начальное значение в поле 

Temperature. 
В Subdomain selection выберите подобласть 2. Рабочая 

область выделится красным. 
Введите в поля свойства для кладки в соответствии с 

табл. 8.2, используя при этом методику, изложенную в 
разд. 4.3. 

В остальных полях оставьте нулевые значения. 
Откройте в том же окне вкладку Init. 
Проверьте в поле Temperature число 273.15 как на-

чальное значение. 
Нажмите OK. 

Граничные условия  
Откройте окно Physics > Boundary Settings… (F7). 
В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл. 8.5. 
Нажмите OK. 

ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . 
По умолчанию будет сгенерировано 682 конечных элемен-
тов. 

Точность расчёта при таком количестве элементов бу-
дет недостаточной,  поэтому  увеличиваем  количество эле-  
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Таблица 8.5.                   Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1-
3,11 

Окружающая 
среда–кладка 

Thermal 
insulation 

 

7 Металл–
кладка Heat flux 

q0=57262 Вт/м2 (косвенный 
режим q0=0, направленный 

режим q0=212688),                
Tinf = 273.15 К; Radiation 

type=Surface-to-surface;  =0.8; 
Tamb= 273.15; J0=J 

6,8, 
10 

Кладка–
металл Heat flux 

Для 6,10 q0=49082 Вт/м2; для 
8 q0=57262 Вт/м2 (косвенный 

режим для 6,10            
q0=67165 Вт/м2;для 8 

q0=78359 Вт/м2, направлен-
ный режим q0=0),                  

Tinf = 273.15 К; Radiation 
type=Surface-to-surface;  =0.8; 

Tamb= 273.15; J0=J 

4,5,9 Кладка–
металл Continuity  

ментов, нажав кнопку  (Mesh > Refine Mesh). Количе-
ство элементов увеличивается до 2728. При необходимо-
сти её можно нажать несколько раз.  

РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите  0:20:1000.  
Нажмите OK. 
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Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После    работы   решателя в главном  окне  будет   вы-

ведено  распределение температур по сечению заготовки 
(рис. 8.3).  

По результатам расчета видно, что при условиях не-
стационарного режима нагрева с переменными теплофизи-
ческими коэффициентами металла и кладки температура 
теплового центра для металла 448,1 К, координаты точки 
x=0,65; y=0,3, а температура поверхности металла 571,3 К, 
координаты x=0,65; y=0,4 и кладки 1084,4 К, координаты 
x=0,65; y=1. 

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги по 
времени. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение через 

пробел 0.65 0.65 0.65, для y: 0.3 0.4 1. 
Нажмите OK. 
Вы увидите окно с графиком переходного процесса в 

тепловом центре заготовки (рис. 8.4). 
С помощью кнопки Zoom window можно увеличить 

любую часть графика. По результатам расчета в конце на-
грева температура на поверхности металла при направлен-
ном режиме получилась 889,3 К, что на 55,7 % больше, чем 
при распределённом режиме на внутренней поверхности 
кладки 435,9 К, что на 148 % меньше, чем при распреде-
лённом режиме, а температура теплового центра металла 
638,5 К больше на 42,5 %. 
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Рис. 8.3. Распределение температур по сечению кладки и метал-

ла (нестационарная задача) 

При косвенном режиме нагрева: температура на по-
верхности металла в конце нагрева 480,8 К, что на 18,2 % 
меньше, чем при равномерно-распределённом режиме; на 
внутренней поверхности кладки температура 1218,1 К, что 
на 12,3 % больше, чем при равномерно-распределённом 
режиме; температура теплового центра металла 385,6 К 
меньше на 16,2 % равномерно-распределённого режима. 
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                     а)                                               б) 

 
в) 

Рис. 8.4. Изменение температур на поверхности металла и 
кладки и в тепловом центре металла со временем: а) – равно-

мерно-распределённый режим; б) – направленный режим;         
в) – косвенный режим 

8.3.  Решение   задачи    нагрева   при  сопряжённом   
радиационном теплообмене без учёта промежуточной 

среды (нестационарный режим 3D модель) 
Режим предназначен для расчета нагрева заготовки 

(куба, параллелепипеда). Все размеры одного порядка. В 
качестве граничного условия принят радиационный тепло-
обмен от поверхности к поверхности и с учетом теплового 
потока, выделяющегося на границе. Эффективный тепло-
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вой поток определяется с учётом степени черноты излу-
чающей и поглощающей поверхностей металла и кладки. 
Эффективный тепловой поток определяется с учётом сте-
пени черноты излучающей и поглощающей поверхностей 
металла и кладки, а со стороны теплового центра металла и 
кладки приняты граничные условия IV рода.  Для нагре-
ваемой заготовки надо выбрать режим 3D.  

Рассмотрим модель радиационного нагрева заготовки 
куба с размерами грани 0,1 м с  граничными  условиями  
IV рода (условия кондуктивного теплообмена) на одной из 
сторон, примыкающих  к  кладке и граничные условия  
второго рода  (тепловой   поток  на   каждую  сторону 
39174 Вт/м2) совместно с отражённым радиационным по-
током от кладки у пяти сторон. Суммарный тепловой по-
ток от источника на металл 173 514  Вт/м2 . Начальная 
температура нагрева T0 = 273,15 К, степень черноты всех 
поверхностей    = 0,8, температура окружающей среды  
Tamb = 273,15 К. Толщина кладки 0,3 м, а расстояние между 
кладкой, расположенной сверху и с боков от нагреваемого 
металла,    0,6 м. Между источником и нагреваемой пла-
стиной отсутствует среда взаимодействия. Зависимость 
теплофизических свойств металла и кладки представлена в 
табл. 4.5 и 8.3. Время нагрева заготовки 1000 с. 

Ранее описан равномерно-распределённый режим, при 
котором тепловой радиационный поток одинаков на клад-
ку и металл. Далее в примере будут показаны результаты 
расчёта косвенного режима при направлении радиацион-
ного теплового потока от источника на кладку в количест-
ве 212 688  Вт/м2 , а  на   металл 0 Вт/м2, а   также  для  
направленного режима, при котором на кладку будет по-
ступать  радиационный  поток  0 Вт/м2, а  на металл 
212688  Вт/м2 [7]. 
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НАВИГАТОР МОДЕЛЕЙ 
Откройте Model Navigator. 
Выберите в списке Space Dimension 3D.  
В Application Mode выберите режим Heat Transfer 

Module > General Heat Transfer > Steady-state analysis. 
Нажмите OK.  

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw > Block.  
Для создания внешнего контура кладки в открывшемся 

окне Block найдите область Length (Длина) и введите  1.3 
в поля x, y, z.  

Нажмите OK. 
 Повторите выбор пункта меню Draw > Block.  
Для создания внутреннего контура кладки в открывшемся 

окне Block найдите область Length (Длина) и введите  0.7 в 
поля x, y и в поле z, а в поле Axis base point (Арифметиче-
ская точка оси) для x, y и z введите числа  – 0.3. 

Нажмите OK.  
Командой меню Edit > Select All выделите созданные 

геометрические объекты. 
Затем кнопкой Difference (Различие)  создайте кон-

тур кладки. 
Повторите выбор пункта меню Draw > Block.  
Для создания нагреваемой заготовки в открывшемся ок-

не Block найдите область Length (Длина) и введите  0.7 в 
поля x, y, а в поле z – 0.1. , в поле Axis base point (Ариф-
метическая точка оси) для x, y, z введите числа – 0.3. 

Нажмите OK.  
Нажмите кнопку Zoom Extents , для того чтобы рас-

положить фигуру на весь экран. 
Физические установки в этом примере ничем не отли-

чаются от примера, описанного в разд. 8.3. 
Граничные условия  

Откройте окно Physics > Boundary Settings… (F7). 
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В Boundary selection выберите номер границы. 
В рабочей области соответствующая граница выделяет-

ся красным. 
Введите граничные условия в соответствии с табл. 8.6. 

Таблица 8.6.                    Граничные условия 

№ гра-
ницы Граница Вид ГУ Коэффициенты ГУ 

1-6,17 
Окружаю-
щая среда–

кладка 

Thermal 
insulation 

 

11 Металл–
кладка Heat flux 

q0=39179 Вт/м2 (косвенный режим 
q0=0, направленный режим 

q0=212688), Tinf = 273.15 К; Radiation 
type=Surface-to-surface;  =0.8; Tamb= 

273.15; J0=J 

9, 10, 
12, 14, 

16 

Кладка–
металл Heat flux 

Для 9,10,14,16 q0=33582 Вт/м2; для 
12 q0=39179 Вт/м2 (косвенный ре-

жим для 9,10,14,16 q0=41165 Вт/м2; 
для 12 q0=48026 Вт/м2, направлен-
ный режим q0=0), Tinf = 273.15 К; 
Radiation type=Surface-to-surface; 

 =0.8; Tamb= 273.15; J0=J 
6-

8,13,15 
Кладка–
металл 

Continuit
y  

Нажмите OK. 
ГЕНЕРАЦИЯ СЕТКИ 
После задания всех граничных условий определите 

сетку командой Mesh > Initialize Mesh или кнопкой . По 
умолчанию будет сгенерировано 682 конечных элемента. 

Точность расчёта при таком количестве элементов бу-
дет недостаточной, поэтому увеличиваем количество эле-

ментов, нажав кнопку несколько раз  (Mesh > Refine 
Mesh). Количество элементов увеличивается до 17546.  
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РАСЧЕТ 
В меню Solve (Решать) выберите Solver Parameters 

(Параметры решателя). 
В списке Solver (Решатель) выберите Time dependent 

(Зависимый от времени). 
На вкладке General в первом поле Times вместо 0:0.1:1 

введите 0:20:1000.  
Нажмите OK. 

Нажмите кнопку Solve (Решать)  (Solve > Solve 
Problem).  

ВИЗУАЛИЗАЦИЯ 
После  работы  решателя в главном  окне  будет  выведено  

распределение температур по сечению заготовки (рис. 8.5).  
По результатам расчета видно, что для равномерно - 

распределённого режима при условиях нестационарного 
режима нагрева с переменными теплофизическими коэф-
фициентами металла и кладки температура теплового цен-
тра для металла равна 380,4 К, (координаты точки x=0,65, 
y=0,65, z=0,3), а температура поверхности металла 448,1 К 
(координаты x=0,65, y=0,65, z=0,4) и температура поверх-
ности кладки 848,4 К (координаты x=0,65, y=0,65, z=1). 

Откройте окно Postprocessing > Cross-Section Plot 
Parameters.  

Во вкладке General проверьте, выбраны ли шаги времени. 
Выберите вкладку Point. 
В поле Coordinates для координат: х: выберите через 

пробел значения 0.65 0.65 0.65; для y: 0.65 0.65 0.65; для z: 
0.4 0.3 1. 

Нажмите OK. 
Вы увидите окно с графиком переходного процесса в 

тепловом центре заготовки (рис. 8.6).С помощью кнопки 
Zoom window можно увеличить любую часть графика. 
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Рис. 8.5. Распределение температур по сечению кладки и метал-

ла (нестационарная задача) 

По результатам расчета при направленном режиме в 
конце нагрева температура на поверхности металла     
883,3 К, что на 97,1 % больше, чем температура при рав-
номерно-распределённом режиме на внутренней поверх-
ности кладки 322,1 К, что на 163 % меньше, чем темпера-
тура при равномерно-распределённом режиме, а темпера-
тура теплового центра металла 630,0 К больше температу-
ры равномерно-распределённого режима на 42,5 %. 

При косвенном режиме температура на поверхности 
металла в конце нагрева 365,0 К, что на 22,7% меньше, чем 
температура при равномерно-распределённом режиме, 
температура на внутренней поверхности кладки 956,4 К, 
что на 12,7 % больше, чем температура при равномерно-
распределённом режиме, а температура теплового центра 
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металла 317,9 К меньше на 19,2 % температуры равномер-
но-распределённого режима. 

  
                     а)                                               б) 

 
в) 

Рис. 8.6. Изменение температур на поверхности металла и 
кладки и в тепловом центре металла со временем: а) – равно-

мерно-распределённый режим; б) – направленный режим;         
в) –косвенный режим 

Для того чтобы совместить на одном рисунке графи-
ков распределения температур по толщине металла для 
различных моментов времени, необходимо выполнить сле-
дующее. 

 Откройте окно Postprocessing > Domain Plot 
Parameters, вкладку General. 
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В области Plot type включите радиокнопку Surfase Plot.  
В области Solutions to use (Используемые решения) 

раскройте список Select via: и выберите пункт Interpolated 
times (Интерполированные значения времени). 

В поле Times введите через пробелы следующие значе-
ния времен: 20 100 200 500 900 1000. 

Выберите вкладку Surfase, отметьте радиокнопку 
Surfase Plot. 

В области Boundary selection выберете 11 (поверхность 
металла, сопряжённая с кладкой при радиационном тепло-
обмене). 

Нажмите OK в окне Domain Plot Parameters. Откроет-
ся трёхмерный график (рис. 8.7). 

 
Рис. 8.7.  Распределение температур на грани металла с гранич-

ными условиями радиационного теплообмена для различных 
моментов времени. 
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9.     Нагрев   изделий     при    сопряжённом   
радиационном   теплообмене   с    учётом      

промежуточной среды с температурой по всему 
газовому пространству, равной температуре 

внутренней    поверхности     ограждения       
(нестационарный режим 1D модель) 

В разд. 8.1 было описано решение задачи для условий 
радиационного теплообмена, когда тепловой поток выде-
ляется внутри пространства между двумя телами, участ-
вующими при радиационном теплообмене, с учётом влия-
ния их друг на друга (сопряжённый радиационный тепло-
обмен между двумя телами). Отличие этой задачи заклю-
чается в том, что между телами находится трёхатомный 
газ, который также участвует в радиационном теплообме-
не. В пакете FEMLAB нет возможности решать такие зада-
чи. Поэтому для её решения воспользуемся алгоритмом, 
предложенным в [8]. Примем следующие допущения: тем-
пература газа по всему пространству между металлом и 
кладкой не отличается в любой координате в данный мо-
мент времени; газ в расчете принят серым с температурой, 
близкой температуре кладки  

Режим предназначен для расчета нагрева листа метал-
ла с толщиной, на порядок меньшей двух других размеров. 
В качестве граничного условия принят радиационный теп-
лообмен от поверхности к поверхности и с учетом тепло-
вого потока, выделяющегося на границе. Эффективный 
тепловой поток определяется с учётом степени черноты 
излучающей и поглощающей поверхностей металла, клад-
ки и газа. Со стороны теплового центра металла и кладки 
установлены условия адиабаты. Для нагреваемой пластины 
с учетом влияния на её нагрев кладки выбираем режим 1D. 

Рассмотрим модель однослойной пластины толщиной 
0,1 м с граничными условиями IV рода (условия кондук-
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тивного теплообмена с кладкой) с одной стороны и тепло-
вой поток 106 344 Вт/м2 совместно с радиационным пото-
ком от кладки, на которую воздействует тепловой поток 
106 344  Вт/м2 с другой. Начальная температура металла, 
кладки и газа T0 = 273,15 К, степень черноты поверхностей 
кладки и металла  = 0,8, газа г = 0,0, температура окру-
жающей среды  Tamb = 273,15 К. Толщина кладки 0,3 м, а 
расстояние между кладкой и нагреваемым металлом 0,6 м. 
Между источником и нагреваемой пластиной существует 
среда взаимодействия при учёте радиационного теплооб-
мена газа. Зависимость теплофизических свойств металла 
и кладки представлена в табл. 4.5 и 8.3. Время нагрева сис-
темы тел 1000 с.  

Выше описан равномерно распределённый режим, при ко-
тором тепловой радиационный поток на кладку и металл оди-
наковый. Далее в примере будут показаны результаты расчёта 
косвенного режима нагрева при направлении радиационного 
теплового потока от источника на кладку 212 688  Вт/м2 и на 
металл 0 Вт/м2, также будут представлены результаты расчёта 
для направленного режима, при котором на кладку будет по-
ступать радиационный тепловой поток 0 Вт/м2, а на металл  
212 688  Вт/м2  [7]. 

Открытие навигатора моделей в этом  примере расчёта 
ничем не отличается от разд. 7.1. 

ЗАДАНИЕ ГЕОМЕТРИИ  
Выберите пункт меню Draw>Specify Objects>Line.  
В открывшемся окне введите координаты пластины в 

поле Coordinates.  
Толщина пластины 0,1 м. Введите в поле цифры 0 0.1  
Нажмите OK. В рабочей области на оси х появится ли-

ния, названная по умолчанию I1.  
Это же окно можно открыть, если щелкнуть на кнопке 

Line при нажатой клавише Shift.  
Снова выберите пункт меню Draw > Specify Objects > Line. 
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В открывшемся окне введите координаты источника в 
поле Coordinates.  

Источник находится от пластины на расстоянии 0,6 м. 
Введите в поле цифры 0.7  1.  

Нажмите OK. В рабочей области на оси х появится ли-
ния, названная по умолчанию I2. 

Нажмите кнопку Zoom Extents , для того чтобы 
расположить фигуру на весь экран.  

ФИЗИЧЕСКИЕ УСТАНОВКИ 
Свойства подобласти для металла и кладки 

Откройте окно Physics > Subdomain Settings…  
В Subdomain selection выберите номер пластины ме-

талла 1.  
Введем в поля свойства в соответствии с табл. 9.1. 

Таблица 9.1.                    Свойства металла 

№ 
по-
доб-
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q,, Вт/м3 

1 10 см Сталь km(T) rhom 
(T) cm(T) 0 

В Subdomain selection выберите номер пластины кладки 2.   
Введем в поля свойства в соответствии с табл. 9.2. 

Таблица 9.2.                         Свойства кладки 

№ 
по-
доб-
лас-
ти 

Толщи-
на пла-
стины 

Мате-
риал 

Теплопро-
водность 
k, Вт/м·К 

Плот-
ность 

ρ, 
кг/м3 

Теплоём-
кость С, 
Дж/кг·К 

Объемная 
мощность 
Q, Вт/м3 

1 30 см Ша-
мот kkl(T) 2500 ckl(T) 0 

В остальных полях оставьте нулевые значения. 
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Для того чтобы установить начальное значение темпе-
ратуры металл и кладки, откройте вкладку Init. 

Введите 273.15 как начальное значение в поле 
Temperature. 

Нажмите OK. 
Введите в поля свойства для металла, зависимые от 

температуры (табл. 4.6) и свойства для кладки (табл. 8.3), 
используя при этом методику, изложенную в разд  4.3. 
 Граничные условия  

Откройте окно Physics > Boundary Settings… (F7).  
В Boundary selection выберите номер границы 1.  
В рабочей области соответствующая граница выделяет-

ся красным.  
Введите граничные условия в соответствии с табл. 9.3. 

Таблица 9.3.               Граничные условия 

№ 
гра-

ницы 
Граница Вид ГУ Коэффициенты ГУ 

1 Окружающая 
среда–сталь 

Thermal 
insulation 

 

2 Металл – кладка Heat flux 

q0=106344 +Qm Вт/м2 (косвен-
ный режим q0=0+Qm, направ-

ленный режим q0=212688+ Qm), 
Tinf = 273.15 К;     Radiation  

type= None 

3 Кладка – металл Heat flux 

q0=106344+ Qkl Вт/м2 (косвен-
ный режим q0=212688 +Qkl, на-
правленный режим q0=0+Qkl), 

Tinf = 273.15 К;Radiation 
type=None 

4 Ккладка – окру-
жающая среда 

Thermal 
insulation  

Нажмите OK. 
Откройте окно Options > Constants… 
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Введите обозначения и значение констант  в соответствии с 
табл. 9.4. 
Таблица 9.4.              Константы, используемые в модели 

Наименование константы Обозначение Значение 

Коэффициент излучения абсо-
лютно чёрного тела, Вт/(м2·К4) Sig 5.67e-8 

Степень черноты газа Eg 0 

Степень черноты кладки Ekl 0.8 

Степень черноты металла Em 0.8 
Площадь поверхности металла, 
участвующая в теплообмене, м2 Fm 1 

Площадь поверхности кладки, 
участвующая в теплообмене, м2 Fkl 1 

Расход топлива на горение, м3/с b 0.00555 
Энтальпия продуктов горения, 
полученных при сжигании 1 м3 
газа при температуре 2473 К 

hg 41198000 

Низшая теплота сгорания сухого 
газа, Дж/м3 Qn_p 42124000 

Нажмите OK. 
Откройте окно Options > Expressions > Scalar 

Expressions … 
Заполните табл. 9.5. 
Нажмите OK. 
Откройте окно Options > Integrations Coupling 

Variables > Boundary Variables  … 
Обозначьте для переменных на границе, интеграцию с рас-

чётной переменной в соответствии с табл. 9.6. 
Нажмите OK. 

Генерация сетки ничем не отличается от предыдущих пунк-
тов. Установки для расчёта повторите, как в разд. 4.1. 
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Таблица 9.5.                  Скалярные выражения 

Name Expressions  
Tg Tkl 
M 1-(1-Eg)*(1-Ekl)*(1-Fm/Fkl)-(1-Eg)^2*(1-Em)*(1-

Ekl)*(Fm/Fkl) 
Akl (Eg*Ekl*(1+(1-Eg)*(1-Em))*Fm/Fkl)/M 
Am (Eg*Em*(1+(1-Eg)*(1-Ekl))*Fm/Fkl)/M 
Bkl (Fm*Em*Ekl*(1-Eg))/(Fkl*M) 
Bm Em*Ekl*(1-Eg)/M 
Qm Sig*(Am*(Tg^4-Tm^4) + Bkl*(Tkl^4-Tm^4)) 
Qkl Sig*(Akl*(Tg^4-Tkl^4) - Bkl*(Tkl^4-Tm^4)) 
Tg1 2050*(0.075+(Qn_p-(Qm+Qkl)/b)/hg)+273 

Таблица 9.6.         Интегрированные значения переменных на 
границах сред 

№ границы Имя Выражения 
1 Tm - 
1 Tkl - 
2 Tm T 
2 Tkl - 
3 Tm - 
3 Tkl T 
4 Tm - 
4 Tkl - 

 ВИЗУАЛИЗАЦИЯ 
После работы решателя в главном окне будет выведе-

но распределение температур по толщине металла и тол-
щине кладки (рис 9.1). 

По результатам расчета в конце нагрева температура 
на поверхности металла 803,0 К ,она отличается от преды-
дущего примера на 0,1 К, на поверхности кладки темпера-
тура 1226,9 К, она отличается от предыдущего примера на 
0,4 К, а температура теплового центра металла 601,3 К, от-
личается от предыдущего примера на 0,1 К. Такое совпа-
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дение доказывает правильность модели с учётом в расчё-
тах промежуточной среды.  

Для проверки влияния степени черноты газа изменим 
константу Eg на 0.2. После этого повторим расчёт, по ре-
зультатам которого температура на поверхности металла 
увеличится до 852,2 К, на поверхности кладки 1288,4 К, а 
температура теплового центра металла 623,6 К. 

 
Рис 9.1 Распределение температур по толщине металла и кладки 
(нестационарная задача с присутствием среды между кладкой и 

металлам) 

Теперь откройте окно Postprocessing > Cross-Section 
Plot Parameters.  

Во вкладке General проверьте, что выбраны шаги вре-
мени. 

Затем выберите вкладку Point. 
В поле Coordinates для х: выберите значение 0 0.1 0.7. 
Нажмите OK. 
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Вы увидите окно с графиком переходного процесса в 
тепловом центре заготовки (рис. 9.2). 

 
                     а)                                               б) 

 
в) 

Рис. 9.2. Изменение температур на поверхности металла и 
кладки и в тепловом центре металла со временем: а) – равно-

мерно-распределённый режим; б) – направленный режим;         
в) – косвенный режим 

С помощью кнопки Zoom window можно увеличить 
любую часть графика. 

По результатам расчета в конце нагрева температура на 
внутренней поверхности металла при направленном режи-
ме 914,0 К.. Эта температура на 7,3 % больше, чем при 
равномерно-распределённом режиме. На внутренней по-
верхности кладки температура 533,3 К, что в 2,4 раза 
меньше, чем при равномерно-распределённом режиме. 
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Температура теплового центра металла при направленном 
режиме 681,4 К, что больше температуры при равномерно-
распределённом режиме  на 9,2%. 

При косвенном режиме температура на поверхности 
металла в конце нагрева 887,4 К, что на 4,1 % больше, чем 
при равномерно-распределённом режиме, температура на 
внутренней поверхности кладки 1570,8 К, что на 21,9 % 
больше температуры при равномерно-распределённом ре-
жиме, температура теплового центра металла 628,7 К, что 
на 0,8 % больше температуры при равномерно-
распределённого режима. 
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